[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Virtual directory does not allow contents to be listed using SSL certificates in IIS 6

Posted on 2006-10-30
2
Medium Priority
?
5,300 Views
Last Modified: 2008-01-09
I have an IIS 6 server with 6 different web pages.  All different web page headers but same internal IP address.  Each virtual web page has the ip address listed, not " all unassigned".  The 4 web pages, virtual directory setup, work fine from outside organization and internally. These 4 working web pages have just anonymous access allowed.   But the 2 web pages set up with SSL certificates receive the following error when trying to access the web page from outside the organization:  "Directory listing denied.  The virtual directory does not allow contents to be listed."  The certificates are valid.  The authentication is both anonymous and check windows authentication.  The default home page can be found, I'm just unsure as to which setting would be causing this in iis.  Also, the NTFS security is default and there are currently no iusr_servername on the web page directory.   Any and all help is appreciated.
0
Comment
Question by:aguest44
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 10

Accepted Solution

by:
harperse earned 750 total points
ID: 17842224
It sounds like your default document is not correct on your site.  Double check the default document, and if that doesn't work, check the Directory Listing box to see if you get a browse listing.

Best of luck,
harperse
0
 

Author Comment

by:aguest44
ID: 17850203
The certificates for SSL are hard coded in the default.html page.  I needed to put in the specific IP address in each of the IIS settings for the web page, so that the correct web page got the correct certificate.  Then the initial web page came up correctly.  The original setting was "All IP addresses", once I changed that to the specific ip  the web pages started functioning, by applying the correct certificate for the page, and then opening.  Thanks for your help.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question