Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 679
  • Last Modified:

openssl install error


why am I getting this error?

/usr/local/bin/rpm -U /tmp/opendir/ssl/openssl-0.9.6m-1.aix4.3.ppc.rpm
error: failed dependencies:
        /bin/sh is needed by openssl-0.9.6m-1
        /usr/bin/perl is needed by openssl-0.9.6m-1
        libc.a(shr.o) is needed by openssl-0.9.6m-1

0
lomlom
Asked:
lomlom
  • 3
  • 2
  • 2
  • +3
1 Solution
 
robertfwoodsCommented:
Please supply version of AIX (oslevel, or oslevel -r)
Where did you obtain the openssl-0.9.6m-1.aix4.3.ppc.rpm file?

Do you have the installation disks that came with your system?
You will need the Expansion package (Sometimes called the Bonus Pack).
You will need the AIX Toolbox for Linux Applications for Power systems (not the one labeled source).

I have not attempted this on AIX 4.3 or earlier. Might be difficult because the "L" in AIX 5L stands for Linux Affinity. Which was not present in AIX 4.3.

0
 
lomlomAuthor Commented:
oslevel
4.3.3.0

 oslevel -r
4330-11

I have the original OS CDs only but not the linux tools CDs?

0
 
sjm_eeCommented:
The 20 point answer is to upgrade to AIX 5.1 minimum. 4.3 is ancient history and you will find it hard to find the prerequisites which will run at that level of AIX.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
hubtechCommented:
The real 20 point answer is you need the things identified as dependencies:

/bin/sh = bourne shell
/usr/bin/perl = Perl
libc.a(shr.o) = libc

... hubtech
0
 
gheistCommented:
install perl.rte form AIX cd, than install openssl from rpm-s, post the result after.
0
 
gheistCommented:
My answer presents solution, but other experts contributed reaching that.
0
 
VenabiliCommented:
I know but with 20 points only...
0
 
gheistCommented:
First answer presents wrong claim Linux affinity toolkit is not available for AIX 4.3. It is available for AIX 4.3.3, including maintenance revision presented by asker. So 2nd answer gets points.
0
 
hubtechCommented:
The original question was "why am I getting this error?" and showed error messgaes indicating failed dependencies.  My response answers the question most directly and presents the list of packages required to resolve the issue.
0
 
lomlomAuthor Commented:
You guys are all awesome but the closest one to the answer is Gheist.
There is no question there is a missing dependency but what was it? and that is why I'm giving 50 points to Gheist.
I apologize about the points as I don't understand it very well in this forum.

One point though, forums is about passion not points, I honestly felt that points are the reason why the forumers answering the questions.

I'll give away more points to the best answer in my next questions.

Thanks to you all
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
  • 2
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now