Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Thunderbird picking up bgcolor in html attachment as its own background color

Posted on 2006-10-31
5
354 Views
Last Modified: 2008-03-03
I'm trying to send an html attachment with Thunderbird, and I notice
that the message area picks up the background color defined in the html document!
 This happens to be almost black (0x333333) so the black text of the
message is barely visible.  The html attachment is:

<body bgcolor="#333333">
<!--url's used in the movie-->
<!--text used in the movie-->
<!-- saved from url=(0013)about:internet -->
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"
codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab..."
width="100%" height="100%" id="DataFloodAnimation" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="DataFloodAnimation.swf" /><param
name="quality" value="high" /><param name="bgcolor" value="#333333"
/><embed src="DataFloodAnimation.swf" quality="high" bgcolor="#333333"
width="100%" height="100%" name="DataFloodAnimation" align="middle"
allowScriptAccess="sameDomain" type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>
</body>

I just want to send this file as a simple attachment.  I don't want
Thunderbird trying to interpret it and use the bgcolor defined there as its own
background of the text area.  How can stop Thunderbird from doing this?

Thanks,
Steve
0
Comment
Question by:steva
  • 2
  • 2
5 Comments
 
LVL 97

Expert Comment

by:war1
ID: 17842436
Greetings, steva !

Try renaming the attachment to .txt file. Then when recipient receives the attachment, he/she can rename the attachment back to .html to open it.

Best wishes!
0
 

Author Comment

by:steva
ID: 17843761
Yes, that works, but that's not a fix.  Can someone explain why this is happening and how to tell Thunderbird to leave html attachments alonel?

Thanks
0
 
LVL 30

Expert Comment

by:Marc Z
ID: 17853603
In TB, try Tools->Options->Composition -> General and select Forward Messages Inline

If that doesn't work, try Tools->Options->Display ->Formatting and at the HTML Messages confirm that Text is set to Black and Background Color is set to White.

0
 
LVL 30

Accepted Solution

by:
Marc Z earned 500 total points
ID: 17853706
OK, one more from Here. http://kb.mozillazine.org/Send_attachments_as_real_attachments
Thunderbird normally sends attachments inline (as part of the message body), not as real attachments.

Some recipients will see some of your attachments as part of the message body, even if this makes no sense. For example, if you attach a plain text file, then some recipients will not see an attached file. Instead, they will see the contents of the file at the bottom of your message. If the file is encoded data, then some recipients might see garbage at the bottom of your message.

To send attachments as real attachments, set the value of your mail.content_disposition_type preference to 1. You can do this by using about:config, or by editing your user.js file and adding:

user_pref("mail.content_disposition_type", 1);

After you make this change, Thunderbird sends all files as attachments. Even if you paste a file into the body of an e-mail, some recipients might see it as a separate attachment.


This may be this bug https://bugzilla.mozilla.org/show_bug.cgi?id=65794
0
 

Author Comment

by:steva
ID: 17855847
mtz1of4.

I found bug  76804 also that seems to be relevant.  I think the solution for now is to not try to send html files as attachments.  I'll just zip it.

Thanks for all your suggestions, though.

steve
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Project Management with emails 7 75
Outlook Rule removing emails from GMail Server? 4 66
pop/imap email 32 47
Windows mail 2012 - repeating message 4 45
This article covers general Notes 8.5 troubleshooting information including recreating the Notes\Data folder.
Are you irritated by repeating emails issue in Microsoft Outlook 2016 after recent update ?  Lets’ see how to resolve and prevent duplicate emails in the Outlook 2016 using some simple techniques.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

790 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question