Solved

"Item no longer exists" in OMA. With error 1000 in Event log

Posted on 2006-10-31
17
348 Views
Last Modified: 2011-10-03
"Hello and Welcome" :P

Right then. my lovely Exchange server was working a ter-reat the other week. then i turned it off for a couple weeks when i went away. i've come back off my holidays and now I'm getting OMA errors.

bloody. microsoft. grr.

when i open OMA, it's no longer asking me for my UID/PASS, just going straight into a screen that says 'the item no longer exists. It may have been moved or changed'. No it hasn't! Stupid thing!

likewise, in event viewer, i get this unhelpful message:
============================
Event Type:      Error
Event Source:      MSExchangeOMA
Event Category:      (1000)
Event ID:      0
Date:            31/10/2006
Time:            09:30:15
User:            N/A
Computer:      Me-SERVER
Description:


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
=============================

I've scurried through the web for a solution and nearly came across one that works which relates to the local path of the exchange-oma VD IIS folder.  Apparently you get this error when the local path is set to "\\.\Back Office Storage\domain.local\blah" rather than "\\.\Back Office Storage\domain.com\blah"

Soooo i changed it to my public domain name and did an IIS reset. and got the same result.

NOW THEN although IIS says it's changed the path for me, when i go back into the exchange-oma VD properties, it's reset itself back to domain.local.

so i'm confused. and irritated.

No one else has touched me box whilst i've been away; and it's setup correctly for SSL with a certificate, etc.

pesky pesky pesky.
0
Comment
Question by:Corcoran Smith
  • 12
  • 5
17 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 17841055
Lack of authentication prompt usually means one of the authentication settings is wrong.
Ensure that anonymous authentication isn't enabled on any of the Exchange virtual directories in IIS manager, except /exchweb.

Test it from Internet Explorer on your desktop with Show Friendly HTTP error messages disabled. That will show you a more useful error message than Pocket IE does.

Simon.
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841083
i've checked it from https://localhost/oma/ and get the same error both ways. I only seem to get access to OMA when logged on as administrator which is weird as all my users have mobile access turned on.

think i was testing from 'administrator' on my XDA which is why it's not asking me for another user.

IIS setting checked and its not enabled.
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841109
i have SSL ticked on my OMA. but i think it was there before. i certainly haven't changed it today (when it stopped bloody working)
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841131
turned on Integrated Auth for the Oma folder.  Now i get the following in the event log:



=======================================
Event Type:      Error
Event Source:      MSExchangeOMA
Event Category:      (1000)
Event ID:      1503
Date:            31/10/2006
Time:            11:43:48
User:            N/A
Computer:      BDS-SERVER
Description:
An unknown error occurred while processing the current request:
Message: No ServicesObject found!
Source: Microsoft.Exchange.OMA.UserInterface
Stack trace:
   at Microsoft.Exchange.OMA.UserInterface.Page.InitSessionVars()
   at Microsoft.Exchange.OMA.UserInterface.Page.Page_Load(Object sender, EventArgs e)
   at System.Web.UI.Control.OnLoad(EventArgs e)
   at System.Web.UI.MobileControls.MobilePage.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain()

Message: Exception of type System.Web.HttpUnhandledException was thrown.
Source: System.Web
Stack trace:
   at System.Web.UI.Page.HandleError(Exception e)
   at System.Web.UI.Page.ProcessRequestMain()
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequest(HttpContext context)
   at System.Web.HttpServerUtility.ExecuteInternal(String path, TextWriter writer, Boolean preserveForm)

Message: Error executing child request for oma.aspx.
Source: System.Web
Stack trace:
   at System.Web.HttpServerUtility.ExecuteInternal(String path, TextWriter writer, Boolean preserveForm)
   at System.Web.HttpServerUtility.Transfer(String path, Boolean preserveForm)
   at Microsoft.Exchange.OMA.UserInterface.UserError.OkClick(Object sender, EventArgs e)
   at System.Web.UI.MobileControls.Command.OnClick(EventArgs e)
   at System.Web.UI.MobileControls.Command.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String argument)
   at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
   at System.Web.UI.MobileControls.MobilePage.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
   at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
   at System.Web.UI.Page.ProcessRequestMain()
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequest(HttpContext context)
   at System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841147
sod. yeah that's because it doesn't like Windows Integrated Auth security!
turned it off again *chuckle*
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841200
!!!!!!!!!!!!! GGGGGGGGGGGRRRRRRRRRRRRRRRRRRRRRRr.

can now browse OMA from server https://localhost/oma but not from my device.

Can hit OMA on my home exchange box from my device.

maybe a certificate issue???
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17841268
A lot of the problems with this feature are down to certificate.
Make sure that you don't have require SSL enabled on the /exchange virtual directory as that can break things.

Simon.
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841270
... or maybe an access issue?  Balls.

re-installed the cert. same problem - just not authenticating.

Si what's your VD path for 'exchange-oma' set to on a box near you? Maybe that's the problem??
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841273
no i Do have SSL enabled on /exchange, as everything's running HTTPS.

but this was set before.. so not sure this is the problem? Unless you just want it off for testing porpoises?
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841283
ok SSL off on both /exchange and /oma

same issue when connecting from the web.
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841311
yeah it was the VD.

changed the path before, then did an iisreset which... err.. reset it.

changed the path, did a 'default web site': stop. then a 'start'. THEN an IISreset, which kept the new path.

works ok. or seems to. no more eventlog errors.


cheers Si
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17841314
Don't confuse the setting for require SSL with your ability to use SSL. You can use SSL without the require SSL option being on.

When you hit the web site, do you get an SSL certificate prompt?

Simon.
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841323
Si yeah i get the prompt when i browse to it. and when i'm in OMA on a PC i also get the certificate pop=up stuff.

not sure i understand using vs. requiring though..... *frowns*

I have 'require SSL' ticked on, on all my exchange related folders in default website?!
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17841387
Require SSL means that the web server will reject the connection UNLESS it is coming over SSL.
If you turn that option off, you can still use SSL, it just will not reject the connection if it comes over http.
The problem is that OMA and Exchange ActiveSync make internal calls to the /exchange virtual directory on port 80. That cannot be changed. If you have require SSL enabled, everything breaks.

For the deployments that I do, this isn't a problem as I simply do not allow anonymous port 80 traffic in to the network. I only open two ports on the firewall - 25 (SMTP) and 443 (https). Nothing else is required. What happens behind the firewall doesn't really matter.

Simon.
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841396
yeah i do the same thing with my routers. so i can turn off the 'require SSL' on all the web folders in exchange??
0
 
LVL 104

Accepted Solution

by:
Sembee earned 500 total points
ID: 17841411
You can if you wish. It is vital for the operation of this feature that it is disabled on the /exchange virtual directory. For everything else it doesn't matter.

Simon.
0
 
LVL 2

Author Comment

by:Corcoran Smith
ID: 17841444
ok thanks man. i will ensure it's not ticked.

500 more points to add to yer Trillion?! :)
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now