• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1439
  • Last Modified:

ive restored SBS .. got some exchange errors though URGENT! q266418 MAIL32.dll

sbs seems fine but the following is true:

Outlook web access comes up with the following problem:

get to login... try to login and then the following:

HTTP/1.1 503 Service Unavailable (but i think this is something i maybe able to sort out regarding permissions on Virtual Directories.

No outlook clients connect..

When I try and load exchange system manager it says;

Exchange detected that "c:\windows\system32\mapi32.dll" is not the correct version required ot run exchange system manager or exchange server 2003. This may cause failures in exchange server manager, affect availability of your server, or both. For more information see MIcrosoft knowledge base article q266418 at http://support.microsoft.com.

Ive tried reinstall as per http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_21617598.html

but i got an error.. THE SAME errpr/.... im at a clients.. and everything seems to be working on my sbs restore BAR THIS.. THE BIG ONE..

thanks in advance

Romolo
0
Romolo
Asked:
Romolo
  • 11
  • 5
1 Solution
 
RomoloIT Professional ConsultantAuthor Commented:
can i completely uninstall exchange on sbs 2003

then reboot

then install

then restore mailboxes from last backup

then somehow (i imagine AD) attach the mailboxes back to the user accounts.

what peoples take on this...

thanks

romolo
0
 
RomoloIT Professional ConsultantAuthor Commented:
Im just tring a IS restore now with exhcange services still running

I'd really appreciate some help here though as this is dicey.. everything else appears fine.

thanks everyone.. please comment

romolo
0
 
dynamitedotorgCommented:
Have you got Outlook installed on the Exchange server itself? If so, that causes a known problem with MAPI.

To fix in you need to uninstall Outlook and re-run the Exchange server setup and pick the reinstall option.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Robberbaron (robr)Commented:
are the Service Pack levels the same as before the re-install ?
0
 
RomoloIT Professional ConsultantAuthor Commented:
only what came with SBS.. full install so i imagine outlook will be installed bc it will be a deployable app./. cant check just yet.. server is rebooting

the server was sp1 BEFORE the rebuild new one sp1... its SBS 2003.

i am in unique position of having a vmware image of the old server so i can check on anything for previous install

thanks in advance

Romolo
0
 
RomoloIT Professional ConsultantAuthor Commented:
i have tried unregistering and registering the mapi32.dll whilst all users are not using outlook and i simply get the same error when i unstall or reinstall

navigate to c:\windows\system32

regsvr32 /u mapi32.dll

and

regsvr32 mapi32.dll

mapi32.dll was loaded, but the DllRegisterServer entry point was not found

This file can not be registered

ANy ideas anyone... Need this urgently

Thanks

Romolo


0
 
RomoloIT Professional ConsultantAuthor Commented:
i have tried unregistering and registering the mapi32.dll whilst all users are not using outlook and i simply get the same error when i unstall or reinstall

navigate to c:\windows\system32

regsvr32 /u mapi32.dll

and

regsvr32 mapi32.dll

mapi32.dll was loaded, but the DllRegisterServer entry point was not found

This file can not be registered

ANy ideas anyone... Need this urgently

Thanks

Romolo


0
 
RomoloIT Professional ConsultantAuthor Commented:
When i tried to check on the microsoft-server-activesync for permissions

the folder is NOT there

c:\Program Files\exchsvr\oma\sync

. I have tried a reinstall the other day so i would have thought IF this was missing it would put it back.

How would I put this back

thanks

Romolo
0
 
Robberbaron (robr)Commented:
The c:\Program Files\exchsvr\oma\sync  folder is there on my SBS SP1, but no files inside.

Is Outlook installed on Server because it should NOT be.  It doent matter if clients are using Outlook because they are completely separate.

Outlook is installed on the clients using the //connectcomputer method.


my SBS box has mapi.dll in the Windows System folder.  ver 6.5.7638.1   (SERVICE PACK 2)
also in C:\program files\Exchasrvr\bin   (same version)

A different version is in the ClientApps\Outlook2003 folder as that is the one Outlook uses.

You could try installing Exchange SP2 but there is no Uninstall for it. You would have to go back to restore again.  Read the instructions/requirements of SP2 before installing, esp IMF removal.
0
 
RomoloIT Professional ConsultantAuthor Commented:
outlook is NOT on server

mapi32.dll is fialing when loading exchange.. I have reinstalled, ive tried just system tools reinstall.. renaming file and reinstall..

are you using outlook mobile access (OMA)

Romolo
0
 
Robberbaron (robr)Commented:
not using OMA.

What version is Exchange , what version mapi32.dll is ANYWHERE on your system. (it might be finding an old one you didnt expect)
0
 
RomoloIT Professional ConsultantAuthor Commented:
i have copied mapi32.dll from c:\prog~1\exchsvr\bin to c:\windows\system32

error has gone away... but OMA still does not work.

2003

can you confirm if http://oma.server.com/oma

is supposed to be blank when logged in.

thanks

Romolo
0
 
Robberbaron (robr)Commented:
1/ So exchange is up and running otherwise ?

2/ if i try http://server/oma .....              oma.server.com/oma doesnt resolve on my system.
 I get asked for a login and then get

"A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator."

But ive never used OMA so dont kniw if it is installed or configured.

0
 
RomoloIT Professional ConsultantAuthor Commented:
yes.. it WAS before..

i just kept getting this odd error.

im unsure if it has anything to with my SSL... being restored.

can you uninstall SSL

and resintall without buying another ...etc..

not done SSL's before

thanks

Romolo
0
 
RomoloIT Professional ConsultantAuthor Commented:
i've tried to reinstall now.. and things are not so good.

please see

http://www.experts-exchange.com/Operating_Systems/SBS_Small_Business_Server/Q_22050132.html

thanks

Romolo
0
 
RomoloIT Professional ConsultantAuthor Commented:
it WAS referring to another mapi32.dll

i copied that one from the bin directory.;. all seems better

thanks robberbaron

romolo
0
 
Robberbaron (robr)Commented:
good
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 11
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now