?
Solved

allow / unblock  vba in exchange

Posted on 2006-10-31
14
Medium Priority
?
4,286 Views
Last Modified: 2016-02-11
When people try to send an excel file (that they used to send yesterdway without error), they are getting a bounce now with this error:

< mail82-server.com #5.0.0 X-Postfix; host 200.200.200.200[200.200.200.200] said: 552 MS-Office file containing VBA macros found inside of the email (in reply to end of DATA command)>

Is there a way to allow the VBA / VBS files to exchange. From the limited research I've done, it seems like it is being blocked by Office ...

can someone verify where/how I do this?

thanks in advance
0
Comment
Question by:thomye
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
14 Comments
 
LVL 104

Expert Comment

by:Sembee
ID: 17844677
There is nothing inside Exchange, except on SBS to block the messages. I would suspect that it is a third party tool that is doing the blocking - anti virus most likely.

Simon.
0
 
LVL 1

Author Comment

by:thomye
ID: 17844766
the host 200.200.200.200 is my exchange server. there is no anti-virus on the exchange server or my outlook client machine.
0
 
LVL 27

Expert Comment

by:Exchange_Admin
ID: 17844838
"5.0.0 X-Postfix"
Are you using a 3rd party anti-spam/anti-virus service? If so check with them to see about unblocking it.
What I placed in quotes above leads me to believe it.
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 104

Expert Comment

by:Sembee
ID: 17844841
But it isn't an Exchange message - so it isn't Exchange server generating that message.

Do you have a firewall that claims to scan SMTP traffic?

Simon.
0
 
LVL 8

Accepted Solution

by:
xxgenius earned 500 total points
ID: 17844966
Look at this person's page listed with the title "SMTP errors... (warning, computer crap here)"
http://www.mickbergman.com/
0
 
LVL 1

Author Comment

by:thomye
ID: 17845039
thanks for the comments ...

i tested an email by setting up an smtp inside our firewall to bypass our spam filter and firewall ... the email delivered successfully

so at this point, i've only ruled out that it isn't exchange ... not sure if its our firewall (which is a sonicwall) or our filter ...


thanks again .. i'll post all updates
0
 
LVL 1

Author Comment

by:thomye
ID: 17845110
insane ... thank you for the posts

IT WAS OUR SONICWALL --

weird though, under "Security Services --> Email Filter" there is nothing activated/checked

but under "Security Services --> Gateway AntiVirus --> Gateway Anti-Virus Global Settings", the SMTP protocol was checked/activated.

The file i'm trying to send is a "know" good (virus free) file so I don't know why the firewall is blocking it ... But I unchecked the SMTP protocol and the file comes through happily


thanks for the needle in the haystack "xxgenius"
0
 
LVL 1

Expert Comment

by:BarkersIT
ID: 22289622
This was also the same for us, but this worked a treat, thanks a lot
0
 

Expert Comment

by:bvf79jr
ID: 23907961
EXACT same problem - Sonicwall was the culprit. This cut out what would've been a lot of wasted time searching through exchange, Postini spam filter, and the Sonicwall. Thanks!
0
 
LVL 3

Expert Comment

by:linetex
ID: 25413376
Worked a treat for my client too....I was checking E-mail filter sections for forbidden File Extentions, as vbs is listed as default.

Thanks

0
 

Expert Comment

by:MHCIT
ID: 32956941
We have a Sonic Wall NS5000 unit and we are having the same issue, but I can't find the Gateway Anti-Virus Global Settings under the Gateway Antivirus, any where else it could be?
0
 
LVL 1

Expert Comment

by:cnshealthcare
ID: 33072104
Same here Sonicwall TZ210 same issue.  Thanks all!
0
 
LVL 10

Expert Comment

by:ThorinO
ID: 37538300
I found this in a different location on a SonicWALL NSA 2400 5.6 firmware.

Security Services -> Gateway Anti-Virus -> Settings button under SMTP -> uncheck "Restrict Transfer of MS-Office type files containing macros (VBA 5 and above)"
0
 

Expert Comment

by:1stopitdept
ID: 40799193
ThorinO had correct solution for us on NSA3600
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
how to add IIS SMTP to handle application/Scanner relays into office 365.
This video discusses moving either the default database or any database to a new volume.
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question