We help IT Professionals succeed at work.

J2EE 1.4

suketu9
suketu9 asked
on
Medium Priority
245 Views
Last Modified: 2010-03-04
Which Apache Tomcat Server is complaint with J2EE 1.4. I have downloaded Tomcat 5.5 , when I try to run my J2EE enterprise Application Project it does not find my apache tomcat 5.5 server and when i click on the link which says if you dont see your server i see two servers under apache geronimo 1.0 and 1.1. So does that mean I have to download this geronimo server or is their some setting i need to do in tomcat 5.5. please let me know.

thanks
Comment
Watch Question

CERTIFIED EXPERT
Commented:
Tomcat is only a web application server - It is  a container which can run only web applications: It means only sevrlets and JSP pages (which can be packed in WAR file). But it can not run Enterprise JavaBeans: session, entity and messagedriven beans (packed in EAR file).
To run Enterprise Applications you need a J2EE application server, such as JBOSS, Geronimo, JonAS, etc
The complete list of J2EE 1.4 certified software you can find on http://java.sun.com/j2ee/compatibility_1.4.html
So if you have only JSP pages and servlets in your application you can run them in Tomcat.
If you have more complex application with EJB beans then choose another server

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.