get rid of "Click to run activex control on this webpage" for viewers

I have a page that has a quicktime control right on the page like this

                                            <object bgcolor="#000000" classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" codebase="http://www.apple.com/qtactivex/qtplugin.cab"
                                                height="255" width="320">
                                                <param name="src" value="http://www.huntn.biz/backoffice/applications/123signup/_FILES/The_Club_Med_QT5-6.mov">
                                                <param name="autoplay" value="false">
                                                <param name="controller" value="true">
                                                <embed src="http://www.huntn.biz/backoffice/applications/123signup/_FILES/The_Club_Med_QT5-6.mov"
                                                    pluginspage="http://www.apple.com/quicktime/download/" type="video/quicktime"
                                                    controller="true" autoplay="false" height="255" width="320">
                                            </object>

I would like to make it so that it doesnt show the "Click to run activex control on this webpage".  Any ideas?

Thanks in advance
LVL 8
rodmjayAsked:
Who is Participating?
 
callrsConnect With a Mentor Commented:
The msdn link gives some methods to prevent the site viewers from getting the message without them having to install the fix. The first of those methods which I just tested is:

1) Create a new file, say "controlX.js":

document.write('<object bgcolor="#000000" classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" codebase="http://www.apple.com/qtactivex/qtplugin.cab" height="255" width="320">')
document.write('<param name="src" value="http://www.huntn.biz/backoffice/applications/123signup/_FILES/The_Club_Med_QT5-6.mov">')
document.write('<param name="autoplay" value="false">')
document.write('<param name="controller" value="true">')
document.write('<embed src="http://www.huntn.biz/backoffice/applications/123signup/_FILES/The_Club_Med_QT5-6.mov" pluginspage="http://www.apple.com/quicktime/download/" type="video/quicktime" controller="true" autoplay="false" height="255" width="320"></object>')

2) Place this in your html file:

    <script src="controlX.js"></script>
0
 
b0lsc0ttIT ManagerCommented:
rodmjay,

There isn't any way for you to have control over this.  It is completely dependant on the browser and its security settings.  Some users may never see it but for those that do there is no way to "force" the object to be "safe" and accepted.

It would be nice in some ways but would definitely be abused and defeat the purpose of security control if it were possible.  Let me know if you have any questions or need more information.

b0lsc0tt
0
 
callrsCommented:
Problem is in IE7. You can fix it locally:
http://www.pchell.com/support/activex.shtml  How to Fix the Prompt for Click to Run an ActiveX Control on this webpage

0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
callrsCommented:
0
 
b0lsc0ttIT ManagerCommented:
I may have misread what you asked.  I thought you were describing the message that appears in the browser window below the address bar in IE.  If this is actually about the pop up confirmation box then only part of what I said is true.  Unfortunately the part that is true is the purpose of your question, a way for you to make it not appear.  Making it so the message does not appear depends on the actions of either the developer (Apple in this case with Quicktime) or the visitor.  In some cases even the visitor can't by pass it until an updated control is released.

Sorry if my first post caused any confusion. :)
0
 
b0lsc0ttIT ManagerCommented:
@Callrs - Great details!  I had not seen that fix.  I hope it works for him too because it seems like exactly the thing Rodmjay wants.

bol
0
 
b0lsc0ttIT ManagerCommented:
I'm glad that I could help you with this.  I had actually thought that I hadn't understood your question correctly and that Callrs' posts were going to be more helpful.  Thank you for the grade, the points and the fun question.

bol
0
 
callrsCommented:
Thanks for the acknowledgment b0lsc0tt.  Hope you don't mind, but I e-mailed rodmjay who then agreed with what you said about the later answer. So for a better PAQ, http:Q_22058532.html requests a change.
0
 
b0lsc0ttIT ManagerCommented:
No problem.  It is better to get the right answer and I understand making a mistake (or was Rodmjay just teasing me??? :D).  I don't object.

bol
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.