• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 963
  • Last Modified:

Netware Newbie -- Locked File in Windows XP

Scenario: Netware 6.5 sp5. Windows XP SP2 latest patches.
Problem: An excel document is locked for editing by 'username1'. Would you like to Open or 'Notify' when the original is available Excel standard error message.
Question: How do I unlock the file? Or, how do I delete the file when Windows thinks it is locked?
Troubleshooting: I've already loaded MONITOR and verified that the Open Files / File Locks sections says that there are "No locks" for the given Excel document.


Hmm... I'm a newbie with Netware, so I'm probably overlooking something basic...

Thanks!
0
sow56091
Asked:
sow56091
1 Solution
 
ShineOnCommented:
Don't use MONITOR for your file status info.  Use NoRM.

In your favorite browser, go to https://<your server IP>:8009
Log in as admin, and on the volume management page, select the volume the file is on.

Continue selecting folder names until you get to the directory the file is in.

Click on the question-mark next to the file.  It will give you all the file attribute/owner/lock status info.

If the file is locked, it will say so, and by what user, and if there's no evidence of that user actually having that file open (here's where you can use MONITOR) you can select to close the file.

If it's not locked, or even open, then my guess is it's >not< open or locked - that since it's an Excel file it may have a linked document that IS open, so it's giving you a locked message.  I've seen this kind of thing happen when there's a linked lookup table, for example, and the lookup table isn't available for some reason.

One thing about sharing Microsoft Office files on NetWare - if you are having oddball problems, it's probably a Microsoft issue, and probably caused by Opportunistic Locking.  

Still in NoRM, in the Manage Server section is a "set parameters" page.  Go there, and look at the NCP category.  In there should be two entries, "Level 2 OpLocks Enabled" and "Client File Caching Enabled".  They should both be set to "off" which disables opportunistic locking at the server.

To further improve things, also disable oplocks at the client, by setting the client32 properties, Advanced Settings tab, File Caching to "Off" and File Commit to "On."  That way the client PC won't try to use oplocks even though the server will refuse an opportunistic lock request.
0
 
sow56091Author Commented:
Yes, sorry for the delay. ShineOn should get the points. Thanks ShineOn
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now