Solved

Terminal Server 2003 Input Languages

Posted on 2006-10-31
8
800 Views
Last Modified: 2011-01-31
I have a problem with input languages defaulting to english (US) in a terminal server session
We require the default language to be english (NZ)
We have a mix of HP T5520 Thin clients running CE 5.0 using RDP and HP Fat Client PCs running XP SP2 using RDP.
When we change the default language to english (NZ) on the Fat Client PCs running XP it imports these settings to the RDP session however when we change this on the T5520 Thin clients running CE 5.0 it does not import these settings.
I have also tried changing the regional settings by logging onto the terminal server with an administrators account, putting it into change mode and then making the change (rebooted).
The change applies only until I log off and back on again and its back to english (US)
I also tried allowing access through Group Policy to Regional Seetings so the user could change the default language for their session however as soon as they log off it changes back to english (US)
WHATS GOING ON HERE? New Zealand does still exist down here people.

Has anyone else had the same / similar issues and resolved this problem?
0
Comment
Question by:stdcitunit
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
8 Comments
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 17847029
just a cheap shot from an Aussie, but when did you guys get computers? :P
0
 
LVL 2

Author Comment

by:stdcitunit
ID: 17847215
Long time ago but it appears Mister Gates may have forgotten about us.
0
 
LVL 15

Accepted Solution

by:
harleyjd earned 500 total points
ID: 17847877
It's not an anti-kiwi thing, it's an anti-anybodybuttheusa thing.

My solution was to create a .reg file with:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Control Panel\International]
"iCountry"="61"
"iCurrDigits"="2"
"iCurrency"="0"
"iDate"="1"
"iDigits"="2"
"iLZero"="1"
"iMeasure"="0"
"iNegCurr"="1"
"iTime"="0"
"iTLZero"="0"
"Locale"="00000C09"
"s1159"="AM"
"s2359"="PM"
"sCountry"="Australia"
"sCurrency"="$"
"sDate"="/"
"sDecimal"="."
"sLanguage"="ENA"
"sList"=","
"sLongDate"="dddd, d MMMM yyyy"
"sShortDate"="d/MM/yyyy"
"sThousand"=","
"sTime"=":"
"DefaultBlindDialFlag"=hex:00
"sTimeFormat"="h:mm:ss tt"
"iTimePrefix"="0"
"sMonDecimalSep"="."
"sMonThousandSep"=","
"iNegNumber"="1"
"sNativeDigits"="0123456789"
"NumShape"="1"
"iCalendarType"="1"
"iFirstDayOfWeek"="0"
"iFirstWeekOfYear"="0"
"sGrouping"="3;0"
"sMonGrouping"="3;0"
"sPositiveSign"=""
"sNegativeSign"="-"

[HKEY_CURRENT_USER\Control Panel\International\Geo]
"Nation"="12"

and a batch file with:

regedit /s \\domainname\netlogon\ausregional.reg

then run that as part of the User configuration > Login Script in a dedictated GPO for TS users.

It should stick after one run, but it was so easy, I've just left it in place.

All you'll need to do it set up a user as NZ, then export those 2 keys to your .reg file. As it's a "current user" setting, they should have access to it, but you may have to remove any registry editing settings you have enabled.

You could go the long way, and create a GPO adm template, but that would drive me batty...


0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 2

Author Comment

by:stdcitunit
ID: 17854694
Hi Harley,
Its a good suggestion.
So I may have to allow write access to the registry for this to work?
0
 
LVL 2

Author Comment

by:stdcitunit
ID: 17855090
The following solution worked for me.

Locate and then click the following key in the registry:


HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout


3. On the Edit menu, click Add Value, and then add the following registry
value:


                   Value name: IgnoreRemoteKeyboardLayout


                   Data type:  REG_DWORD


                   Value data: 1


4. Quit Registry Editor.


I did have to make sure that the registry keys were set as follows for HKEY_USERS\.DEFAULT\Control Panel\International AND HKEY_USERS\.DEFAULT\Control Panel\International\Geo

[HKEY_USERS\.DEFAULT\Control Panel\International]
"iCountry"="61"
"iCurrDigits"="2"
"iCurrency"="0"
"iDate"="1"
"iDigits"="2"
"iLZero"="1"
"iMeasure"="0"
"iNegCurr"="1"
"iTime"="0"
"iTLZero"="0"
"Locale"="00000C09"
"s1159"="AM"
"s2359"="PM"
"sCountry"="Australia"
"sCurrency"="$"
"sDate"="/"
"sDecimal"="."
"sLanguage"="ENA"
"sList"=","
"sLongDate"="dddd, d MMMM yyyy"
"sShortDate"="d/MM/yyyy"
"sThousand"=","
"sTime"=":"
"DefaultBlindDialFlag"=hex:00
"sTimeFormat"="h:mm:ss tt"
"iTimePrefix"="0"
"sMonDecimalSep"="."
"sMonThousandSep"=","
"iNegNumber"="1"
"sNativeDigits"="0123456789"
"NumShape"="1"
"iCalendarType"="1"
"iFirstDayOfWeek"="0"
"iFirstWeekOfYear"="0"
"sGrouping"="3;0"
"sMonGrouping"="3;0"
"sPositiveSign"=""
"sNegativeSign"="-"

[HKEY_USERS\.DEFAULT\Control Panel\International\Geo]
"Nation"="12"

-----------------------------------------------------------------------

Harleyjd's suggestion put me on the right track to resolving this issue so he gets the points

JayJay_70 beat us in the cricket last night so we'll give him bragging rights this time round.
0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 17855116
ah! small victories, small victories!
0
 
LVL 15

Expert Comment

by:harleyjd
ID: 17855708
Thanks for the points - you wouldn't have to change any registry permissions - they will have full access to their own HKCU. What I was referring to was the GPO blocks you can put on regedit - if you had implemented them you might have needed to turn it off.

I can't help but notice you've pasted Australian settings in your example...


OI OI OI!

0
 
LVL 48

Expert Comment

by:Jay_Jay70
ID: 17855716
**Grin** :-)
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I guess it is not common knowledge to most Wintel engineers/administrators: If you have an SNMP-based monitoring system in your environment (and it's common to have SNMP or Syslog) it's reasonably easy to enable monitoring of the Windows Event logs,…
Learn about cloud computing and its benefits for small business owners.
Come and listen to Percona CEO Peter Zaitsev discuss what’s new in Percona open source software, including Percona Server for MySQL (https://www.percona.com/software/mysql-database/percona-server) and MongoDB (https://www.percona.com/software/mongo-…
This is a high-level webinar that covers the history of enterprise open source database use. It addresses both the advantages companies see in using open source database technologies, as well as the fears and reservations they might have. In this…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question