?
Solved

OWA- links in email body not behaving.

Posted on 2006-10-31
4
Medium Priority
?
351 Views
Last Modified: 2010-03-06
I've noticed that when using OWA, clicking on http links in the body of the
email message result in the OWA logon screen popping up again.

It looks as if the links have been re-written and point back at owa rather
than the website their intended to link to.

Also the logon screen that pops up won't accept credentials that normally work.

Has anybody come across this or know how to fix it?

Thanks.
0
Comment
Question by:farfo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 26

Assisted Solution

by:jar3817
jar3817 earned 450 total points
ID: 17847392
I've seen this behavior when using either using a browser other than IE or non-ssl connection to OWA.

If you're using standard http for owa, you might want to consider buying a certificate (godaddy has them for like $20/yr) and enabling https. It makes your users feel like you care about their security.

If you're using another browser, there isn't much you can do about it. OWA was written specifically for IE (go microsoft!) and usually doesn't act as intended in other browsers.
0
 

Author Comment

by:farfo
ID: 17847458
Definitely using both IE and an SSL connection to the site.   Using forms based authentication which
can't be enabled unless you are using SSL.  Also get the padlock bottom right etc.
0
 
LVL 104

Accepted Solution

by:
Sembee earned 450 total points
ID: 17849712
OWA rewrites the URL as a security measure. It sends the URL through a parser which then opens another window.
This usually means that there is an issue with the authentication settings on the components virtual directory - exchweb.

Make sure that /exchweb in IIS manager is set to anonymous authentication only.

Simon.
0
 

Author Comment

by:farfo
ID: 17849996
Our F.E. sits behind a ISA server 2004 machine.

I don't understand why- but when I shifted the Forms based authentication role from the F.E. to the ISA server
(i.e. disabling on FBA on F.E. and switching from integrated to FBA on ISA),  links in emails started behaving as they should.

Thanks for getting back to me.

0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses
Course of the Month12 days, 21 hours left to enroll

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question