Solved

Can't Access SATA Drive on Dell SC420

Posted on 2006-10-31
4
1,720 Views
Last Modified: 2008-01-09
We have a server running Windows 2000 Server for which we have no access to the system password (the owner of the machine is now deceased).  We need to get some website files off the disks on this server.  The server is a Dell SC420 with two (2) 250GB SATA drives attached to the onboard SATA controller.  The BIOS setting for the "fake raid" CERC controller in this server is set to "Auto detect".   I have installed a regular IDE drive into this system and installed Windows 2000 Server.  This worked fine.  However, when I boot the system, the SATA drives do NOT show up.   I have tried changing the settings in the BIOS to Raid Off (and Raid On just to check if there was an Array previously configured on these drives - there was not).  In each case, I cannot see any volumes on these drives that are accessible on the server.  If I go into Disk Management, the drives ARE recognized but they show up as "Disk 1 - Dynamic - Unreadable" and "Disk2 - Dynamic - Unreadable".  Now, I have no idea how these drives were configured previously as the owner of the system is now deceased.  It could be that this is a software based RAID 1 mirror using Windows 2000 but if that is the case I would think I would still be able to access the drives.  If i click on the drives in Disk Management it gives me the option to "Revert to Basic" but I'm afraid of using that option for fear of it blowing the existing data on the drive away.   Originally I thought that these 2 drives were mirrored using the CERC "fake raid" card in the system but when I enable that through setting the BIOS setting to RAID ON, it shows both drives as JBOD in the Adaptec Raid Utility and when I tried to install the CERC 2s driver it said that none of the hardware on my system was supported.   I have also tried taking these drives and putting them into an external SATA>USB drive carrier and accessing them under XP Pro but the drives are not recognized on that system either.  Surely there must be some way to mount these drives....  What am I missing here?  
0
Comment
Question by:emilysam
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 92

Assisted Solution

by:nobus
nobus earned 100 total points
ID: 17848027
here the MS guide :
http://support.microsoft.com/kb/309044

and here another one without data loss :   http://faq.arstechnica.com/link.php?i=1806
0
 
LVL 6

Accepted Solution

by:
Mnf earned 400 total points
ID: 17848186
When you remove a dynamic disk from a computer, the remaining online dynamic disks retain information about it and its volumes. The removed disk is displayed in Disk Management as a Dynamic/Offline disk and assigned the status of "Missing."
You need at least one online dynamic disk to retain information about Missing disks and their volumes. When you remove the last dynamic disk, you lose the information, and the Missing disks are no longer displayed in Disk Management
After you connect the disks to the new computer, from the Disk Management snap-in, select Rescan Disks on the Action menu. The New Signature Wizard is displayed. When you physically connect a dynamic disk, the rescan causes the disk to be displayed in Disk Management as Dynamic/Foreign . You might need to convert it to Dynamic/Online , and then activate the volumes. When you connect a new disk to a computer, or rescan the dynamic mirrored volume and move only one disk, it displays as Dynamic/Offline , and you need to manually activate it.
then you have to "Importing Foreign Disks" this well make your system recognize the Dynamic/Foreign.
http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/core/fndb_con_lxgq.mspx?mfr=true

i think you can reset your admin password for the old Windows 2000 Server you already have.
Here are 4 of the most used/free tools to reset your password:

-Petter Nordahl-Hagen's Offline NT Password & Registry Editor - A great boot CD/Floppy that can reset the local administrator's password.
http://www.petri.co.il/forgot_administrator_password.htm#1

-Openwall's John the Ripper - Good boot floppy with cracking capabilities.
http://www.petri.co.il/forgot_administrator_password.htm#2

-EBCD – Emergency Boot CD - Bootable CD, intended for system recovery in the case of software or hardware faults.
http://www.petri.co.il/forgot_administrator_password.htm#3

-Austrumi - Bootable CD for recovering passwords and other cool tools.
http://www.petri.co.il/forgot_administrator_password.htm#4

this is the full artical
http://www.petri.co.il/forgot_administrator_password.htm
0
 

Author Comment

by:emilysam
ID: 17850047
Update... I did indeed try to reset the password using the offline editor installed on a linux boot disk.  This did NOT work as it was showing the filesystem type for the SATA drive as "SFS" and it therefore could not access it.  Very strange.  I have no idea what SFS is.  I did find a google link referencing an obscure encrypted file system called SFS but the link was quite old and referenced the fact that SFS supported IDE drives and SCSI drives "up to 9gb", which would seem to indicate that the software was very old (it even highlighted the fact that it could do "32 bit" disk access").   While it's possible this filesystem is installed, I doubt it.  Another clue:  just to see what would come up, I ran Windows 2000 Server setup.  It found the SATA drive and the partition on there but showed the partition as Unrecognized / Damaged or something to that effect.  I have tried the "Rescan" method previously mentioned but it didn't have any effect - no Write Disk Signature wizard appeared.  So, I'm thinking that perhaps the drive IS encrypted with something or it's part of a volume or software RAID stripe set that can't be read.  Either way, I have no access to the partitions or volumes(s) on this disk.  I have now moved on to doing a brute force password crack using SAMINSIDE as I have another system that I DO have access to that quite likely has the same Administrator password on it.   However, I would love to continue trying to get access to this disk so if anyone has further suggestions I'd appreciate hearing them.
0
 

Author Comment

by:emilysam
ID: 17862457
Ahhh, the sweet smell of success!  SAMINSIDE broke the Administrator password on another computer related to the one I was having the problem with and fortunately the password was the same.  So, I have now logged into the server and can see the filesystems fine.   I guess all my issues were around the fact that the drive was part of a Mirrored set using the Dell "fakeraid" CERC-2s drive/hardware combo on the POweredge SC420.   It's likely striped by that controller in some way that is not understood by Win2k (though I did try to load the device driver).  At any rate, I have access to the data I need. Going to award points for effort on this one...
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Solid State Drive Performance Tips: Solid state storage technology is now a standard.  After testing and using several different brands and revisions of SSD's over the years I have put together a collection of tips,tools and suggestions that I ha…
Having issues meeting security compliance criteria because of those pesky USB drives? Then I can help you! This article will explain how to disable USB Mass Storage devices in Windows Server 2008 R2.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question