We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Open File - Security Warning Windows XP Pro w/ SP2

regosnell
regosnell asked
on
Medium Priority
14,994 Views
Last Modified: 2013-12-04
We are running Windows XP Pro SP2 in a Windows 2003 Server environment using AD.

We have group policies for each department.  Our customer service department is the most restrictive.  Just recently they are getting a warning message about open files when executing various things on their desktop.  Unknown Publisher/Unknown File Type and then the local path for the program they are trying to execute.  They just click OPEN and the program is available to them.  They use about 6-8 programs so they go through this routine on every boot.

Some initial research pointed to issues that occur with network apps but these are all local.



The question is difficult and we are in need so it's worth 500 points and hopefully I have made myself clear.
Comment
Watch Question

Commented:
Possible solution:

The popup on XP for running an unknown program has a box that says something like "always ask before running this program".  It is checked by default.  Uncheck it the next time you run the program and it won't ask again.

Hope that helps.
Rich RumbleSecurity Samurai
CERTIFIED EXPERT
Top Expert 2006

Commented:
Can you post the exact pop-up wordage, there are several on XP/2003 that sound the same but are different.
-rich

Author

Commented:
The window is titled:
Open File - Security

The details are:

The publisher could not be verified.  Are you sure you want to run this software?

Name:  nameoffile.exe
Publisher:  Unknown Publisher
Type:  Application
From:  C:\Windows\system32


The choices are:

Run Cancel

It does this for every process.

Then the desktop appears after clicking run about 20 times (not 6-8 as I previously stated).
Then I will launch word and it will say the same messge only for winword.exe and the location locally on the C drive.

There is no check box about running the program.
Security Samurai
CERTIFIED EXPERT
Top Expert 2006
Commented:
That dialog box is defiantly from IE launching the application, does this happen if the  nameoffile.exe is double-clicked on where it is stored?
You may also be able to change that dialog by these methods...
http://www.experts-exchange.com/Operating_Systems/Windows_Server_2003/Q_21684026.html
If it's an Html file that holds the link to that exe, you may experiment with a copy of that html file renamed to .hta (rather than .html or .htm)
-rich

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Rich RumbleSecurity Samurai
CERTIFIED EXPERT
Top Expert 2006

Commented:
Just found this also: http://support.microsoft.com/kb/921281
-rich

Author

Commented:
OK, we did find that one on experts-exchange prior to posting.  No help for us.

We are reviewing our settings based on the Microsoft KB article, I will let you know.  BTW, thanks for the fast responses.

Author

Commented:
The MS arctile didn;t apply for us.  The solution on experts-exchange was re-visited.


The part of that question that helped was this:

To disable the warning start the Group Policy Editor (Start > Run, type
-gpedit.msc- and press OK) and go to:

-User Configuration > Administrative Templates > Windows Components >
Attachment Manager- then set -Inclusion list for low file types- to
Enabled and enter the file types you don't want to be warned about in
the box (for example: .exe).

Thanks again for the help
Rich RumbleSecurity Samurai
CERTIFIED EXPERT
Top Expert 2006

Commented:
Good to know, glad to help.
-rich
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.