We help IT Professionals succeed at work.

Email with multiple recipients bounces back with "#4.0.0 smtp;452 Too many recipients" error

OSSupport
OSSupport asked
on
Medium Priority
4,500 Views
Last Modified: 2009-08-23
Hi,

I'm running Exchange 2003 on a Windows Server 2003 platform. Recently, when sending an email to multiple recipients I receive the following error message.

<server.xx.domainname.xxx #4.0.0 smtp;452 Too many recipients>

More specifically, the bounce backs seem to occur with email addresses ending in @yahoo.com. I tried the following:

I sent a msg to 30 yahoo.com recipients and 24 bounced back with the Too many recipients error.
I sent a msg to 20 yahoo.com recipients and 14 bounced back with the Too many recipients error.
I sent a msg to 10 yahoo.com recipients and 4 bounced back with the Too many recipients error.
I sent a msg to 7 yahoo.com recipients and 1 bounced back with the Too many recipients error.
I sent a msg to 6 yahoo.com recipients and NONE bounced back.
I sent a message to 7 gmail recipients and they all went through.
I sent a message to 120+ yahoo.com recipients from my GMAIL account and they all went through.

I've been spinning my wheels on this for 3 days now. Any help would be most appreciated.
Comment
Watch Question

Commented:
I would verify your Exchange settings in ESM.  Check the following:

1.  ESM, global settings, message delivery, defaults tab.  Recipient limits.  By default it should be 10000.
2.  ESM, Administrative groups, "group name", Servers, "server name", Protocols, SMTP, default SMTP, Messages tab.  Limit number of recipients per message.  By default is should be 64000.

And is the bounce back coming from your mail servers or the domain's mail servers you are sending too?
Take a look at Yahoo!'s inbound email policies here http://help.yahoo.com/help/us/mail/bulk/bulk-01.html.  They look at the email traffic coming from your ip and domain, and they can "deprioritize" (their term) your smtp connections based on the number of invalid recipients, on your reverse DNS, and on whether users designate your email as spam.

Author

Commented:
Thanks for responding so quickly.

1. My Recipient limits is set at 5000.

2. "Limit number of recipients per message to" is set at 64000.

The bounce back message (NDR) seems to come from my server, here is what I received:

From:   System Administrator  
Sent:   Friday, October 27, 2006 8:52 AM
To:     recipientname@yahoo.com; (+ 120 other yahoo.com addresses)

Subject:        Undeliverable:FW: What to do during an Earthquake

Your message did not reach some or all of the intended recipients.

      Subject:  FW: What to do during an Earthquake
      Sent:     10/27/2006 8:51 AM

The following recipient(s) could not be reached:

      recipientname@yahoo.com on 10/27/2006 8:52 AM
            The e-mail system was unable to deliver the message, but did not report a specific reason.  Check the address and try again.  If it still fails, contact your system administrator.

            <server.xx.domainname.xxx #4.0.0 smtp;452 Too many recipients>

Commented:
Do you have an SPF record for your domain?  They may be considering you are spam as lollygagr stated.

Author

Commented:
I don't believe I do, however I do have a reverse DNS entry for my static IP and I've confirmed that I am not an open mail relay.

Commented:
I would try setting up an SPF.  Its very simple.

http://www.openspf.org/dns.html
You will see the error happen on whatever smtp server was the last one to accept the message.  If a receiving smtp server rejects a connection, as it looks like Yahoo is doing in this case, then it can appear the error happened on the last sending smtp server.  It makes more sense when you realize that if an smtp server refuses the connection in the first place, it isn't going to generate a non-delivery-report for the message it wouldn't accept.  

I am pretty sure the problem here is that Yahoo is "throttling" your connections.  You mentioned that you had a gmail account, so I wondered if you could do a test.  Pick 25 yahoo recipients and send the message from your regular server to them and to your gmail account.  Then forward the same message from your gmail account to the same recipients.  If you can deliver from gmail, then it's pretty certain that Yahoo's filters don't like your server's ip or your domain, and you would want to contact Yahoo using their form (http://add.yahoo.com/fast/help/us/mail/cgi_bulkmail) to see if you can get de-listed.  As mmudry said, SPF can be one way to help make your ip look less "spammy"; Yahoo is using a similar framework called Domainkeys (http://antispam.yahoo.com/domainkeys).

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Commented:
 <server.xx.domainname.xxx #4.0.0 smtp;452 Too many recipients>

this means that when you smtp service connected to Yahoo's server and attempted to send the e-mail, it was blocked by Yahoo because you have exceeded Yahoo's limit for number of recipients.

I suggest you ask the sender to reduce the number of receipients he or she is sending to.

Cheers,
NITADMIN
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.