Solved

CISCO ASA 5510 Security BY Pass Question

Posted on 2006-11-01
12
552 Views
Last Modified: 2008-01-09
Dear Experts,
I know I seem like a broken record with these configurations but I am so close now I can feel it.

Before my ASP will sign off on this configuration and allow for deployment of the ASA 5510 I need to show them I can perform certain connections.

The way it is currently configured I am able to Remote Desktop from my ASA 5510 Inside interface (Workstation A 10.8.1.4) to my PIX 501 through the Acccounting Interface (10.8.3.1) to a workstation on the PIX (Workstation B 10.1.1.9).

I am not able to ping via either Workstation with my current running-config and I believe they are both configured to ping properly with the current access-lists?

I can Ping 10.8.3.2 from the INSIDE Interface (workstation A) but I cannot Ping interface 10.8.3.1 (the actual Accounting interface).

From Workstation B I can ping 10.8.3.1 (but I cannot ping the Outside Interface on the PIX 501 10.8.3.2).

here is a little diagram:

          10.8.1.4 Workstation A<----ASA5510           PIX501---->10.1.1.9 WorkS B
                                                        |                                |
                                                        |--------------------------|
                            Accounting Interface (10.8.3.1)     Outside Interface (10.8.3.2)

The ASP company says that using workstation A and connecting to workstation B with RDP will not necessary show that my connectivity is bi-lateral.  They need to know that the AS400 on 10.1.1.9 will be able to communicate back to the Workstation on the Inside interface of the ASA5510.

here is my running config of the ASA5510

asdm image disk0:/asdm505.bin
asdm location WTS1 255.255.255.255 inside
asdm location JRA-XSERVE1 255.255.255.255 inside
asdm location ATROPOS 255.255.255.255 inside
no asdm history enable
: Saved
:
ASA Version 7.0(5)
!
hostname ciscoasa
domain-name jrabbott.com
enable password 1q1dWhr/XLfzW0/Y encrypted
names
name 10.8.1.6 WTS1 description Citrix Server
name 10.8.1.20 ATROPOS description Database Server
name 10.8.1.8 JRA-XSERVE1 description MAIL SERVER
dns-guard
!
interface Ethernet0/0
 description ISP / Route
 nameif outside
 security-level 0
 ip address 208.xxx.xxx.100 255.255.255.248
!
interface Ethernet0/1
 description Network Traffic
 nameif inside
 security-level 100
 ip address 10.8.1.50 255.255.255.0
!
interface Ethernet0/2
 description Web Application Server / Front-End Exchange Server
 nameif Exchange
 security-level 50
 ip address 10.8.2.1 255.255.255.0
!
interface Ethernet0/3
 description JD. Edwards Inteface to WTS Accounting (10.1.1.9)
 nameif ACCOUNTING
 security-level 100
 ip address 10.8.3.1 255.255.255.0
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone pst -8
same-security-traffic permit inter-interface
object-group service RDP tcp-udp
 description Remote Desktop (Terminal Services)
 port-object range 3389 3389
access-list INBOUND extended permit tcp any interface outside eq smtp
access-list INBOUND extended permit tcp any interface outside eq www
access-list INBOUND extended permit tcp any interface outside eq pop3
access-list INBOUND extended permit tcp any interface outside eq imap4
access-list INBOUND extended permit tcp any interface outside eq 993
access-list INBOUND extended permit tcp any interface outside eq 88
access-list INBOUND extended permit tcp any interface outside eq ldap
access-list INBOUND extended permit tcp any interface outside eq ldaps
access-list INBOUND extended permit tcp any interface outside eq 3389
access-list INBOUND extended permit tcp any interface outside eq 1604
access-list INBOUND extended permit tcp any interface outside eq citrix-ica
access-list INBOUND extended permit icmp any any echo-reply
access-list INBOUND extended permit icmp any any unreachable
access-list INBOUND extended permit tcp any interface ACCOUNTING
access-list INBOUND extended permit icmp any interface ACCOUNTING
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu Exchange 1500
mtu ACCOUNTING 1500
mtu management 1500
no failover
monitor-interface outside
monitor-interface inside
monitor-interface Exchange
monitor-interface ACCOUNTING
monitor-interface management
asdm image disk0:/asdm505.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 10.8.1.0 255.255.255.0
nat (management) 0 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp JRA-XSERVE1 smtp netmask 255.255.255.255
static (inside,outside) tcp interface www JRA-XSERVE1 www netmask 255.255.255.255
static (inside,outside) tcp interface pop3 JRA-XSERVE1 pop3 netmask 255.255.255.255
static (inside,outside) tcp interface imap4 JRA-XSERVE1 imap4 netmask 255.255.255.255
static (inside,outside) tcp interface 993 JRA-XSERVE1 993 netmask 255.255.255.255
static (inside,outside) tcp interface 88 JRA-XSERVE1 88 netmask 255.255.255.255
static (inside,outside) tcp interface ldap JRA-XSERVE1 ldap netmask 255.255.255.255
static (inside,outside) tcp interface ldaps JRA-XSERVE1 ldaps netmask 255.255.255.255
static (inside,outside) tcp interface 3389 ATROPOS 3389 netmask 255.255.255.255
static (inside,outside) tcp interface 1604 WTS1 1604 netmask 255.255.255.255
static (inside,outside) tcp interface citrix-ica WTS1 citrix-ica netmask 255.255.255.255
static (Exchange,outside) 208.xxx.xxx.99 10.8.2.10 netmask 255.255.255.255
static (inside,ACCOUNTING) 10.8.1.0 10.8.1.0 netmask 255.255.255.0
access-group INBOUND in interface outside
access-group INBOUND in interface ACCOUNTING
route outside 0.0.0.0 0.0.0.0 208.xxx.xxx.97 1
route ACCOUNTING 10.1.1.0 255.255.255.0 10.8.3.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd lease 3600
dhcpd ping_timeout 50
dhcprelay server 10.8.1.10 outside
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
Cryptochecksum:40cdd880797e2e49226863cba9cd7439
: end


Here is a running config of the Pix 501

PIX Version 6.3(4)                  
interface ethernet0 auto                        
interface ethernet1 100full                          
nameif ethernet0 outside security0                                  
nameif ethernet1 inside security100                                  
enable password 1q1dWhr/XLfzW0/Y encrypted                                          
passwd 2KFQnbNIdI.2KYOU encrypted                                
hostname pixfirewall                    
domain-name ciscopix.com                        
fixup protocol dns maximum-length 512                                    
fixup protocol ftp 21                    
fixup protocol h323 h225 1720                            
fixup protocol h323 ras 1718-1719                                
fixup protocol http 80                      
fixup protocol rsh 514                      
fixup protocol rtsp 554                      
fixup protocol sip 5060                      
fixup protocol sip udp 5060                          
fixup protocol skinny 2000                          
fixup protocol smtp 25                      
fixup protocol sqlnet 1521                          
fixup protocol tftp 69                      
names    
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168                                                                                
.1.0 255.255.255.0                  
access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 192.168.1.0 255.255.255.0              
access-list INBOUND permit icmp any any echo reply                                                  
access-list INBOUND permit icmp any any unreachable                                                  
access-list INBOUND permit ip 10.8.1.0 255.255.255.0 host 10.1.1.9                                  
access-list INBOUND permit ip 10.8.3.0 255.255.255.0 host 10.1.1.9                                                                  
pager lines 24              
mtu outside 1500                
mtu inside 1500              
ip address outside 10.8.3.2 255.255.255.0                                        
ip address inside 10.1.1.1 255.255.255.0                                        
ip audit info action alarm                          
ip audit attack action alarm                            
pdm location 10.0.1.0 255.255.255.0 outside                                          
pdm location 192.168.1.0 255.255.255.0 outside                                              
pdm logging informational 100                            
pdm history enable                  
arp timeout 14400                
global (outside) 1 interface                            
nat (inside) 0 access-list inside_outbound_nat0_acl                                                  
nat (inside) 1 0.0.0.0 0.0.                        
static (inside,outside) 10.1.1.0 10.1.1.0 netmask 255.255.255.0 0 0                                                                  
access-group INBOUND in interface outside                                        
route outside 0.0.0.0 0.0.0.0 10.8.3.1 1                                        
timeout xlate 0:05:00                    
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00                                                                            
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00                                                              
timeout uauth 0:05:00 absolute                              
aaa-server TACACS+ protocol tacacs+                                  
aaa-server TACACS+ max-failed-attempts 3                                        
aaa-server TACACS+ deadtime 10                              
aaa-server RADIUS protocol radius                                
aaa-server RADIUS max-failed-a                            
aaa-server RADIUS deadtime 10                            
aaa-server LOCAL protocol local                              
http server enable                  
http 192.168.1.0 255.255.255.0 inside                                    
no snmp-server location                      
no snmp-server contact                      
snmp-server community public                            
no snmp-server enable traps                          
floodguard enable                
sysopt connection permit-ipsec                              
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac                  
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 10.0.1.1
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 192.168.1.1 netmask 255.255.255.255 no-xauth no-conf
ig-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.1.1.2-10.1.1.8 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:2c8bcdd3f53a465b7cbf9470c9635821
: end
As always I appreciate your help.

Thanks
Pete
0
Comment
Question by:peter_ophoven
  • 7
  • 5
12 Comments
 
LVL 2

Expert Comment

by:HeavyWaterLTD
ID: 17852906
Your access-list does allow ICMP traffic from the ACCOUNTING interface. I may be wrong but I believe the PIX and the ASA natively will not allow ping to the interface from another security zone. I don't understand a particular need to ping to the interfaces you indicated. Why not do host to host testing to confirm bilateral connectivity.

In my opinion, pinging the interfaces from the hosts you indicated does not do much to prove any end to end connectivity. traceroute and other end to end tests are probably useful in proving to your ASP connectivity.

0
 

Author Comment

by:peter_ophoven
ID: 17852940
No You are exactly right HeavywaterLTD.
The interface testing is only a test that I performed.
Ulitimately the host to host connectivity is the goal.

I can connect Remote Desktop connections from a workstation on interface 10.8.1.4 (inside interface of the ASA) to the 10.1.1.9 workstation on the PIX.

This works great.  This doesn't prove anything to the ASP since they say that a session is opened and it doesn't prove that I can send traffic from the 10.1.1.9 workstation back to the 10.8.1.0 inside interface.

I tried to do a remote connection back from 10.1.1.9 to the 10.8.1.4 with no luck.
I am unable to ping 10.1.1.9 from the workstation nor am I able to tracert.

0
 

Author Comment

by:peter_ophoven
ID: 17852979
Do I need a remark that basically allows traffic from the Accounting interface to the inside interface?
0
 
LVL 2

Expert Comment

by:HeavyWaterLTD
ID: 17852987
Can you put up the PIX config as well?
0
 

Author Comment

by:peter_ophoven
ID: 17853108
Yes it is already posted directly under the ASA 5510 config.

0
 
LVL 2

Expert Comment

by:HeavyWaterLTD
ID: 17853123
ooops.... =)
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 2

Expert Comment

by:HeavyWaterLTD
ID: 17853266
modify your access-list lines that read such as:

access-list INBOUND extended permit tcp any interface ACCOUNTING

instead of ACCOUNTING use your destination IP address in the 10.8.1.x range


0
 

Author Comment

by:peter_ophoven
ID: 17853811
You mean on the ASA 5510

The Last two Access-List items read as follows:

access-list INBOUND extended permit tcp any interface ACCOUNTING
access-list INBOUND extended permit icmp any interface ACCOUNTING

Change them to something like this:

access-list INBOUND permit tcp host 10.1.1.9 255.255.255.0 10.8.1.0 255.255.255.0

Allowing all traffic originating from host 10.1.1.9 to have access to 10.8.1.0 (the Inside Interface) ??

Something like that?

0
 

Author Comment

by:peter_ophoven
ID: 17854273
I eliminated the access-list INBOUND entries that apply to accounting.
When I applied the group to interface accounting it of course applied all of the inbound access-list commands.

instead I created a new access list that is titled INBOUND_ACCOUNTING
And I think I am close now but do I need a NAT Command for information that is flowing from ACCOUNTING to INSIDE.

Do I need static (inside,accounting)  10.3.1.0 10.3.1.0 255.255.255.0

My ASDM doesn't like having the access-list command:

access-list INBOUND_ACCOUNTING permit ip host 10.1.1.9 10.8.1.0 255.255.255.0
It says that my NAT is missing or incomplete.

Here is another example of my running config as it stands now:

asdm image disk0:/asdm505.bin
asdm location WTS1 255.255.255.255 inside
asdm location JRA-XSERVE1 255.255.255.255 inside
asdm location ATROPOS 255.255.255.255 inside
no asdm history enable
: Saved
:
ASA Version 7.0(5)
!
hostname ciscoasa
domain-name jrabbott.com
enable password 1q1dWhr/XLfzW0/Y encrypted
names
name 10.8.1.6 WTS1 description Citrix Server
name 10.8.1.20 ATROPOS description Database Server
name 10.8.1.8 JRA-XSERVE1 description MAIL SERVER
dns-guard
!
interface Ethernet0/0
 description ISP / Route
 nameif outside
 security-level 0
 ip address 208.252.102.100 255.255.255.248
!
interface Ethernet0/1
 description Network Traffic
 nameif inside
 security-level 100
 ip address 10.8.1.50 255.255.255.0
!
interface Ethernet0/2
 description Web Application Server / Front-End Exchange Server
 nameif Exchange
 security-level 50
 ip address 10.8.2.1 255.255.255.0
!
interface Ethernet0/3
 description JD. Edwards Inteface to WTS Accounting (10.1.1.9)
 nameif ACCOUNTING
 security-level 100
 ip address 10.8.3.1 255.255.255.0
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone pst -8
same-security-traffic permit inter-interface
object-group service RDP tcp-udp
 description Remote Desktop (Terminal Services)
 port-object range 3389 3389
access-list INBOUND extended permit tcp any interface outside eq smtp
access-list INBOUND extended permit tcp any interface outside eq www
access-list INBOUND extended permit tcp any interface outside eq pop3
access-list INBOUND extended permit tcp any interface outside eq imap4
access-list INBOUND extended permit tcp any interface outside eq 993
access-list INBOUND extended permit tcp any interface outside eq 88
access-list INBOUND extended permit tcp any interface outside eq ldap
access-list INBOUND extended permit tcp any interface outside eq ldaps
access-list INBOUND extended permit tcp any interface outside eq 3389
access-list INBOUND extended permit tcp any interface outside eq 1604
access-list INBOUND extended permit tcp any interface outside eq citrix-ica
access-list INBOUND extended permit icmp any any echo-reply
access-list INBOUND extended permit icmp any any unreachable
access-list INBOUND_ACCOUNTING extended permit icmp any any echo-reply
access-list INBOUND_ACCOUNTING extended permit icmp any any unreachable
access-list INBOUND_ACCOUNTING extended permit ip host 10.1.1.9 10.8.1.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu Exchange 1500
mtu ACCOUNTING 1500
mtu management 1500
no failover
monitor-interface outside
monitor-interface inside
monitor-interface Exchange
monitor-interface ACCOUNTING
monitor-interface management
asdm image disk0:/asdm505.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 10.8.1.0 255.255.255.0
nat (management) 0 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp JRA-XSERVE1 smtp netmask 255.255.255.255
static (inside,outside) tcp interface www JRA-XSERVE1 www netmask 255.255.255.255
static (inside,outside) tcp interface pop3 JRA-XSERVE1 pop3 netmask 255.255.255.255
static (inside,outside) tcp interface imap4 JRA-XSERVE1 imap4 netmask 255.255.255.255
static (inside,outside) tcp interface 993 JRA-XSERVE1 993 netmask 255.255.255.255
static (inside,outside) tcp interface 88 JRA-XSERVE1 88 netmask 255.255.255.255
static (inside,outside) tcp interface ldap JRA-XSERVE1 ldap netmask 255.255.255.255
static (inside,outside) tcp interface ldaps JRA-XSERVE1 ldaps netmask 255.255.255.255
static (inside,outside) tcp interface 3389 ATROPOS 3389 netmask 255.255.255.255
static (inside,outside) tcp interface 1604 WTS1 1604 netmask 255.255.255.255
static (inside,outside) tcp interface citrix-ica WTS1 citrix-ica netmask 255.255.255.255
static (Exchange,outside) 208.252.102.99 10.8.2.10 netmask 255.255.255.255
static (inside,ACCOUNTING) 10.8.1.0 10.8.1.0 netmask 255.255.255.0
access-group INBOUND in interface outside
access-group INBOUND_ACCOUNTING in interface ACCOUNTING
route outside 0.0.0.0 0.0.0.0 208.252.102.97 1
route ACCOUNTING 10.1.1.0 255.255.255.0 10.8.3.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd lease 3600
dhcpd ping_timeout 50
dhcprelay server 10.8.1.10 outside
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
Cryptochecksum:ac3f40b793bfc77e158355be2c3d68c4
: end

Thanks again.
0
 
LVL 2

Accepted Solution

by:
HeavyWaterLTD earned 500 total points
ID: 17854686
you may need a static statement the other way since your security level is both 100 for ACCOUNTING and inside...... (ACCOUNTING,inside)


(ACCOUNTING,INSIDE)  10.1.1.0 10.1.1.0 255.255.255.0
0
 

Author Comment

by:peter_ophoven
ID: 17854866
Dear HeavyWaterLTD

So with my new Access-list INBOUND_ACCOUNTING;

access-list INBOUND_ACCOUNTING extended permit icmp any any echo-reply
access-list INBOUND_ACCOUNTING extended permit icmp any any unreachable
access-list INBOUND_ACCOUNTING extended permit ip host 10.1.1.9 10.8.1.0 255.255.255.0

I already have line:
static (inside,ACCOUNTING) 10.8.1.0 10.8.1.0 netmask 255.255.255.0

and I should add:
static (accounting,inside) 10.1.1.0 10.1.1.0 255.255.255.0
this will facilitate traffic from the subnet 10.1.1.0 getting from the accounting network to the inside network on the ASA 5510.

I will try this and see how it works.
i think you are right on.

Pete

0
 

Author Comment

by:peter_ophoven
ID: 17863675
Just wanted to thank you again for your help.
I think it worked.

I am able to RDP the workstation A from workstation B.
I am also able to ping from workstation B to workstation A.  
I wasn't before we added the corrected access-list and the correct static translation.

Although I still cannot ping workstation b from workstation a I can RDP workstation A from workstation B.  I am confident that it should work.
There must be something on the PIX 501 that is stopping the icmp traffic but allowing the other IP information.
Weird.

Anyway, the Accounting ASP passed on all of my running configs and authorized for deployment so we will see what happens in production.

I thank you again for your support.

I am sure I will have more for you soon.

Thanks
Pete Ophoven
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now