Solved

ntldr not found after image restore with ghost

Posted on 2006-11-01
8
588 Views
Last Modified: 2012-06-27
Hi Experts, i have a problem. I have 5 Windows XP Professional 64 bit edition machines all configured exactly the same way. All have a RAID 1 array setup.

I made a ghost image after running sysprep on my master machine and pushed out the image to another machine. I successfully booted up the imaged machine and went through the mini-setup process to get it up and running. However, when i pushed out the image to another machine and tried to boot it up i get the error "ntrdl not found" and it tells me to reboot. I went into the raid configuration utility and rebuilt the array thinking this might be the culprit, but still get the same error. I tried booting up off the windows cd and running the repair function but when i do that i get the error that there are no hard drives found, i assume this has something to do with the RAID setup. Does anyone have any ideas as to what might be going on?
Just to make sure it wasn't ghost that was causing the problems, i downloaded the newest version of Acronis True Image 9.1 and tried making an image and pushing it out through that program. It resulted in the same error. I tried a different hard drive just to be safe with the same result. I also took a look at the content of the hard drive after pushing out the image and i can SEE the file ntrdl so i know it's there.

PLEASE, I NEED HELP.
0
Comment
Question by:Forensicon
  • 5
  • 3
8 Comments
 
LVL 1

Expert Comment

by:joelcpatterson
ID: 17853420
I would guess it has something to do with the motherboard not seeing the hard drives.  Some SATA controllers need you to load drivers before Windows setup can see them.  When the system is booting into windows setup it lets you press the F6 button and load the drivers necessary.  Howerver, this doesn't answer why if you have the exact same systems, that ghosting doesn't work.  The only guess that I have is that either the motherboards or SATA controllers are just enough different that it doesn't recognize it. Or, the Ghost image isn't tranfering everything the new system needs to boot.

Try looking up your motherboard manufacturer, look for the SATA drivers on their website. On the machine that you are trying to move the ghost image to, load the ghost image, then reboot onto the windows CD and load those SATA drivers before the setup loads.  Then try the repair install option.

One last idea, that I'm sure you have already tried, but just in case,  make sure that you have the system bios set to boot off of the correct hard drive.  Maybe when you ghost the image back it's putting it on the Raid 1 drive rather than the Raid 0 drive?

Let me know what happens.
0
 

Author Comment

by:Forensicon
ID: 17853759
Thanks for the reply Joel, right now i am rebuilding the array, again, and then will try what you suggested with the driver. FYI: My MOBO is a  SuperMicro X6DHR-8G. I tried creating another image, this time without running sysprep, thinking maybe that had something to do with it. No luck. I tried copying over the ntldr file off the imaged HD and copying it onto the new HD. No luck. All roads lead to "cannot find NTLDR".
0
 

Author Comment

by:Forensicon
ID: 17854348
Still no luck even after loading the drivers. Windows Repair still says it can't see the HD's.
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 1

Accepted Solution

by:
joelcpatterson earned 500 total points
ID: 17854851
1.Does Windows setup even see the Hard Drives when they are wiped without trying to ghost them?  On some Western Digital Hard drives, I have had instances where you have to put the utility CD that came with the HD's in and go through a setup process.

2.What Norton Ghost version are you using?  Found this on Symantecs website...

http://service1.symantec.com/SUPPORT/ghost.nsf/1e3e8ce700f06dd6882567fd007af73b/7205dc44f3434700882566f10077bfd2?OpenDocument&prod=&ver=&src=sg&pcode=&svy=&csm=no

Though, this shouldn't cause issues with Hardware Raid 1 I don't belive.  Hardware mirrored drives shouldn't even be seen as two drives.

3.One last thought....try doing the ghost over with only one SATA drive plugged in.

Let me know if any of this works.. :-)
0
 

Author Comment

by:Forensicon
ID: 17858362
I have not tried wiping the drives and trying to reinstall windows. I didn't want to go down that road yet, but maybe i will today. I ghosted the HD's locally, as in i removed the hard drives from the machines and plugged them in directly to our ghost server, so i only had one of the HD's from each array plugged in at a time.
0
 

Author Comment

by:Forensicon
ID: 17859805
I tried re-ghosting the master HD but instead of doing the whole disk, i ghosted by partition. Then i pushed out the partition image to the HD and viola, it worked. I don't know why it didn't work when trying to ghost the whole disk but i'm not going to worry about it right now. Thanks for all your help joel, i'm going to award you the points for your time and effort. If you have any ideas about what the difference is between partition and disk i would be happy to hear them.
0
 
LVL 1

Expert Comment

by:joelcpatterson
ID: 17867805
My guess is that it has something to do with the MBR portion of the image.  For some reason when you pushed out the full HD Image, it must overwrite the MBR with something unreadable by the new system.  This probably causes the new system to not recognize the partitions on the HD.  

When you push out individual partitions it probably doesn't even touch the MBR because it not an actual part of the partitions, but instead a bit of code at sector 0 of the HD.

Here is a good website that explains the MBR a bit more.
http://www.ata-atapi.com/hiwmbr.htm

Either way, it's fixed and you know how to make it work.  I wish I had a better answer for the reasoning behind it, but what I said above seems to make sense to me.  Maybe somebody else will shed some light on the topic?
0
 

Author Comment

by:Forensicon
ID: 17868376
Thank you very much. That makes a lot of sense.
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
2 windows xp desktops computer 8 150
RemoteApp Printing 5 99
Delete Folder and its contents in a batch file 12 76
Computer software inventory 5 95
Can I legally transfer my OEM version of Windows to another PC?  (AKA - Can I put a new systemboard in my OEM PC?) Few of us are both IT and legal experts but we all have our own views of Microsoft's licensing rules and how they apply.  There are…
Sometimes people don't understand why download speed shows differently for Windows than Linux.Specially, this article covers and shows the solution for throughput difference for Windows than a Linux machine. For this, I arranged a test scenario.I…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question