• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2661
  • Last Modified:

Peachtree 2007 premium won't connect to gateway server on IP address

When i try to open up Peachtree 2007 i get an error saying the "Your Peachtree gateway server is unavailable. Please make sure the gateway computer is logged in or that the  database service is running. Click retry when the gateway is available or Cancel current operation."

I know the server is logged in and the database service is running because other people can get into Peachtree. The datapath for Peachtree is set to X: which is mapped to the server by IP. Previously, X: was pathed to the server by UNC name which works and is the way the other users are setup. However, i need it to path by IP because this user works from home and UNC doesn't work from home, but IP does over the VPN. Does anyone have any idea why Peachtree doesn't like using an IP as opposed to UNC and how i can fix this. I'm about ready to give up and buy a support plan with Peachtree for 300 bucks but thought EE might be able to help me.

Yaniv Schiff
Yaniv Schiff
  • 3
1 Solution
A lot more information may be required but lets start with some basics.

What OS are you tryin gto connect from?.
Are there any Hardware Firewalls, Software Firewalls or Routers or switches at the remote location.

First thing I would do is find out how to open up the firewalls that are in place. Software first then Hardware. Peachtree gives you a nice Software tutorial.


As far as opening hardware ports I would call them for the port numbers. I can't seem to locate them.

Yaniv SchiffDirector of Digital Forensics Author Commented:
Client Machine: Windows XP Professional
Server: Windows Small Business Server 2003

There are no hardware firewall or software firewalls between the client and the server.

There is a switch between them but i highly doubt that is the culprit. We utilize another sql based program that maps to the same server by IP. We can access the server by simply typing in the IP or UNC name no problem. We don't block any ports.

The weird thing is when i installed the program it worked, but then when i rebooted the machine it gave me this error and i haven't gotten it to work since.
Have you tried to add a DNS entry on the users home machine hosts file?
Yeah ,now that I think about it,you probably need to edit the lmhost file so that your data path can resolve using the unc over the WAN.
Here is a trouble shooting how to:

Unable to browse through PPTP/VPN connection
Symptoms: 1. If the WINS server is on the same computer as the PPTP/VPN
server, and you attempt to connect to a computer using a PPTP/VPN client,
you may experience following problem: 1) The NetBIOS name of the computer to
which you are attempting to connect is not resolved. 2) You may receive an
error message similar to the following error message: "System error 53 has
occurred. The network path was not found" when using net view or opening
Network Knighthood.
2. If the WINS server is not on the same computer as the PPTP server and you
attempt to connect to a computer using a PPTP client, you may be able to
connect to computers on your local area network (LAN), but you may be unable
to connect to network shares or resources on the PPTP server.
Resolutions: Inability to browse often means the client can't resolve
NetBIOS names.
1. If this is a workgroup network, enable NetBIOS over TCP/IP on the server
and clients.
2. If this is domain network and the WINS server is on the same computer as
the PPTP/VPN server, move the WINS server to a different computer.
3. Add the NetBEUI protocol for your PPTP tunnel instead of, or in addition
to, TCP/IP.
4. By default, most routers and firewalls prevent the transmission of
NetBIOS names unless you enable UDP ports 137 and 138 and TCP port 139. Try
to enable UDP ports 137 and 138 and TCP port 139 across all routers and
firewalls between the PPTP/VPN client and PPTP/VPN server.
5. Make sure the client has correct DNS, WINS and Master Browser settings.
6. Make sure the default gateway points to the remote network rather than to
the ISP.
7. Some ISP might block ports required for NetBIOS name broadcasts.
8. If WINS address is not distributed upon connection to VPN, LMHOSTS should
be configured to enable Domain to be located.
9. If you try these techniques and the client still can't browse, try to use
UNC to connect to the remote resources by ip, for example, use the net use
h: \\serverip\sharename command.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now