Solved

Disabling FTP in Unix

Posted on 2006-11-01
7
920 Views
Last Modified: 2013-12-04
We're trying to keep FTP from listening on our HP UX system.  We do this by commenting it out in services and in inetd, but after this happens we cannot establish a FTP (client) connection to another server.  Are we doing this right?  We want to be able to use FTP, but not have it listening on port 21.

Also, can anyone explain the difference between commenting out in services and commenting out in inetd.conf?
0
Comment
Question by:kryptotech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 34

Assisted Solution

by:PsiCop
PsiCop earned 500 total points
ID: 17853441
Just comment it out in inetd. Leave it in /etc/services.
0
 
LVL 34

Accepted Solution

by:
PsiCop earned 500 total points
ID: 17853458
inetd.conf tells the inetd listening daemon what services are allowed. It is what listeds on port 21 and allows clients to connect to the FTP server.

/etc/services defines what ports are associated to what services, and is used by client and server software alike. However, it is merely an information source, it does not define running services.
0
 

Author Comment

by:kryptotech
ID: 17853514
Just to be clear, will FTP still say listening even if it's disabled in inetd?
0
What Is Transaction Monitoring and who needs it?

Synthetic Transaction Monitoring that you need for the day to day, which ensures your business website keeps running optimally, and that there is no downtime to impact your customer experience.

 
LVL 38

Expert Comment

by:yuzh
ID: 17854654
>>will FTP still say listening even if it's disabled in inetd?

No!
after you edit the inetd.conf, you should restart inetd  or reboot the box.
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 17858540
As yuzh says, changes to inetd.conf require that you restart the inetd daemon, or reboot the server, in order to be effective. I'm not familiar with HP-UX so I'll default to suggesting a reboot.

inetd.conf is only read upon inetd's initialization.
0
 
LVL 48

Expert Comment

by:Tintin
ID: 17862995
Just a side note about /etc/services.

Entries in /etc/inetd.conf refer to service names defined in /etc/services.  If you remove/comment the entry in /etc/services, it means the associated entry in /etc/inetd.conf won't work.
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 17867024
Good point - another reason not to futz with /etc/services.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently, a new law in my state forced us to get a top-to-bottom analysis of all of our contract client's networks. While we have documentation, it was spotty at best for some - and in any event it needed to be checked against reality. That was m…
Container Orchestration platforms empower organizations to scale their apps at an exceptional rate. This is the reason numerous innovation-driven companies are moving apps to an appropriated datacenter wide platform that empowers them to scale at a …
This is a high-level webinar that covers the history of enterprise open source database use. It addresses both the advantages companies see in using open source database technologies, as well as the fears and reservations they might have. In this…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question