?
Solved

laptop's touchpad only works while any key is depressed

Posted on 2006-11-01
26
Medium Priority
?
755 Views
Last Modified: 2008-01-09
A very unsual problem but a very frustrating issue nonetheless.

DELL Latitude D500
It is the opposite of making the touchpad disabled while you are typing on the keys; to stop you from accidentally moving the cursor or pressing the touchpad's mouse buttons.

The only time i am able to move the touchpad's cursor or use the mouse keys is to press and hold any other keyboard key; the best key at the moment to use is the Fn key, other keys causes problems as i try and move the cursor.

I have tried to uninstall and reinstall other touchpad drivers but it appears in vain.
Currently I am using Alps Pointing device version : 5.4.102.8

I have also looked extensively on the touch pads control properties but there is nothing to enable/disable this locking issue.

This surely must be a software fault but i cannot rule out a hardware fault.

Any help is appreciated and the solution finder will receive the 500 points!
0
Comment
Question by:randomronald
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 6
  • 4
  • +1
26 Comments
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 17855026
Check your BIOS settings.
Usually there is a way to disable the touchpad to allow a regular mouse and no touchpad.
It may disabled in the BIOS and using the FN key is bypassing the disable.
0
 

Author Comment

by:randomronald
ID: 17855284
Thanks for your reply.

BIOS is fine, the touchpad is enabled.

I do not want to disable the touchpad. The pad was working fine previously.
I do not want to use a regular mouse at all (it is not pratical)
The laptop has to be portable with no wires or accessories dangling.
Using the Fn key or ANY other key bypasses the disable of the touchpad: that is the problem.

I fear it is a key-combination that has been inadvertently pressed but I fail to find a resolution.

0
 
LVL 31

Accepted Solution

by:
rid earned 1000 total points
ID: 17855967
Test the function in (windows assumed) safe mode, or use a live CD O/S like knoppix (www.knoppix.org). If the problem goes away there it's safe to assume a driver/software issue, if still there, it's likely to be a hardware problem.

If you think it is software, check what processes/programs are started automatically and disable all but the really necessary ones, see if that makes a difference.
/RID
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:randomronald
ID: 17857356
yes im using xp pro

safe mode with no extras =  no difference.

I will try a linux cd install and check the pad
0
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 17857792
The built in touchpad and the keyboard are normally both PS2 devices  and work through a controller chip inside the laptop. (They both go through the same chip.)

Some possibilities I see.
A misaligned or loose keyboard or touchpad connector (or ribbon cable) causing the signal to go to the wrong 'pins' on the controller chip.
Bad keyboard or touchpad - same problem, wrong signals to the chip.
Bad controller chip.
Bad ribbon cable.
.
0
 
LVL 4

Expert Comment

by:keola75
ID: 17857945
What is the pointing device setting in BIOS?  If it is set to <Touchpad - PS/2 Mouse> try setting it just to <Touchpad>.  You also mentioned that you were using Alps Pointing device...is this what came with the system?  I just thought Dell utilized the Synaptic Pointing device drivers.
0
 

Author Comment

by:randomronald
ID: 17858478
Checking the pins/ribbons will require a strip down, which I will not do until I exhaust all other avenues.

BIOS
Pointing device options:
1. Touch Pad-PS/2 Mouse
2. PS/2 Mouse
3. Serial Mouse

Currently set to 1.
There is no option just for Touch Pad.

I have been using Alps for nearly a year and havent changed or updated any drivers except to try and solve this issue
I use Alps as it has more features of control such as disabling the annoying touchpad trigger happy mouse click which you do not get with Synaptic.
When the option is enabled and you double tap the pad, it simulates you that you have double clicked the mouse button: for efficiency I believe, but annoying when it is accidental, hence I disable the double pad tap.







0
 
LVL 4

Expert Comment

by:keola75
ID: 17858959
This is unusual.  There does seem to be a newer driver for what I believe you're using.  Have you tried this yet?  Here's the link:

http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R113813&SystemID=LAT_PNT_PM_D600&os=WW1&osl=en&deviceid=2514&devlib=0&typecnt=1&vercnt=7&formatcnt=1&libid=17&fileid=149404


By the way, what OS are you using?

-Keola
0
 

Author Comment

by:randomronald
ID: 17859159
I have actually just installed the Synaptic driver which has obviously removed the Alps driver, but the exact same results happen: Touchpad requires any key on the keyboard pressed to activate touchpad.
There is a config in the Synaptic options to have the touchpad disabled totally, which works of course, but of course this is not what i desired - i was hoping that if i disabled it the reverse would work :s

OS = xp pro

I saw that dell driver update earlier, i will download and install it now, but i fear the same results.
Im also just about finished the knoppix dvd so im heading towards a conclusion.
0
 
LVL 4

Expert Comment

by:keola75
ID: 17859224
To be honest with you, I'm starting to hit a wall on this.  The only other things I can think of is to update the BIOS (if it isn't already) or reinstall Windows due to a possible corruption.  I apologize I couldn't help you out further.  I know how frustrating it can be.  Personally, I just use a USB Wireless Notebook Laser Mouse instead of the touchpad, but that's me and I know you mentioned it's not feasible for you.  It seems like there is a conflict somewhere, but you've already checked all the normal places.

-Keola
0
 

Author Comment

by:randomronald
ID: 17859541
ok i installed that latest driver from dell but alas, it hasnt worked.

I have also tried uninstalling all the relevant drivers and let windows reboot to auto detect and auto install drivers, however although windows detected and installed the driver for the touchpad the end result is that it didnt work to solve my issue.

I am going to blame windows on this problem if knoppix works fine.

if knoppix gives me the same results, then it is certainly a bios or hardware fault.

I wont update the BIOS with a new version unless knoppix fails.
0
 
LVL 4

Expert Comment

by:keola75
ID: 17859914
That's a good plan.  I don't like to mess with the BIOS until all else fails.
0
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 17864293
>> Touchpad requires any key on the keyboard pressed to activate touchpad. <<

With both the alps and synatic drivers......

Whether you wanna hear it or not, you have a -hardware- problem.
0
 
LVL 31

Expert Comment

by:rid
ID: 17864940
Touchpads are usually PS/2 devices. If no brand-specific driver is loaded, they work on the generic PS/2 mouse drivers that come with the O/S that you use (most have those included).

If you want to use the enhanced features of a touchpad, you must load  the brand-specific drivers, and not only that, they need to be suitable for the touchpad model. Alps and Synaptic are the most common touchpads and they have drivers on their web sites for download. Drivers are not interchangeable between brands, though; they may work, but most settings will be a bit messed up, if the driver loads at all (if no touchpad of the expected type is detected, drivers won't load in some cases).

So, in this case, any O/S that has mouse support can be used for hardware testing. If you can't run the touchpad in a decent manner with generic PS/2 mouse drivers, it's probably shot. Knoppix (you don't need the DVD, the CD is quite enough for running a test environment), FreeDOS, etc, etc could be what you need to try something else than windows. Safe mode *should* be enough, really, unless the windows PS/2 drivers are totally messed up.

IF it proves to be a hardware problem, the touchpad can be exchanged for a new one; some models may have the touchpad integrated with the KB.
/RID
0
 

Author Comment

by:randomronald
ID: 17878107
what a suprise...

knoppix loaded up and the same fault applies.

bios or hardware fault now...

will check out the bios versions that dell has to offer.

for your information, i had the laptop off for about 24 hours or so, when it powered up the touchpad worked as normal for a few minutes during bootup; i.e. the login screen, then initialising/loading software. Then something odd happened the mouse pointers movement appeared to be 'jaggy' / laggy. I tried to bring up the processes to see what was lagging the cursor, but the whole system started to non-respond and i saw the cpu was 99% busy on something.
Then after a few moments the cpu calmed down and hey presto i lost my touchpad again, only to be activated by holding down a key.

Crazy yes, i really cannot blame the O/S software though as knoppix gave the same fault as windows, press and hold a key to activate the touchpad.

Temperature? perhaps?
What other dynamic conditions may affect this?

 
0
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 17885062
Bad capacitors.
Bad voltage to the PS2 circuit. (Onboard voltage regulator)
Faulty PS2 controller chip.
Or one of the easier problems I listed way up the page here.
Cross your fingers and hope it's one'a them.
.


0
 

Author Comment

by:randomronald
ID: 17934423
grrrr...

is it possible that a replacement keyboard and touchpad would enable this fault to be corrected?

how do i test the bad circuitry?

0
 
LVL 26

Assisted Solution

by:PCBONEZ
PCBONEZ earned 1000 total points
ID: 17934761
The sequence should go:
Check the cables and connectors.
Replace keyboard/touchpad.
If that doesn't do it the problem is in the motherboard.

If I had to guess I'd say it's the touchpad or touchpad wiring.
(Having trouble wording this.)
It sounds to me like the touch pad is not passing the power? signal? to tell the PS2 chip turn on and accept the motion signals. - Pressing a key happens to send power to the same pin on the PS2 chip so it then accepts the motion signals from the touchpad.
(Totally a guess.)
.
0
 

Author Comment

by:randomronald
ID: 18083776
Apolgies for not being able to answer sooner.

This issue has no answer so therefore I request for it to be deleted (as stated in the Community Support)
0
 
LVL 26

Expert Comment

by:PCBONEZ
ID: 18149597
The question does have an answer and it was given.
The keyboard/touch-pad, the PS2 controller, or the wiring in between is bad.

We can't physically isolate the problem or fix it FOR you.
Lack of the ability or desire to do the physical trouble shooting on your part does not mean the answers were not given here.

.
0
 

Author Comment

by:randomronald
ID: 18162609
lol
there was no lack of ability or desire to do the physical trouble shooting just as much there was no answer.
the laptop is faulty, not even Dell can diagnose it effectively to impliment an economical solution.

suggestions were provided here for potential answers, but the end result is no-one can tell what has happened or how to solve this issue - except scrap it and buy a new laptop.

However, the laptop is a write-off as diagnosed by Dell; my insurance covers it, replacement on its way.

thank you for all your time and support.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you hit the power button on your laptop and it does nothing there are a couple of things that you need to check. You will need to check your Ac Power Adapter and your DC Power Jack.  Tip: If you have checked your Ac power adapter and know …
I am not new to IT, I have been working in the field since 1985.  But recently I came up against something that stumped even me (it doesn't happen as often as I would like).  I was running a screencasting session from the laptop to my TV via ChromeC…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question