Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2623
  • Last Modified:

home Folder Not Mapping Correctly...

Hi,

A few of our users home folder will not map properly. In active directory, we set it up to connect to a folder on our server.
But sometimes, it will connect to the root of that drive, rather than the specified folder. Example

We set it to connect H to the following path \\ourserver\users\username
Now, instead of connecting to the path username, it connects to \\ourserver\users. So when the user opens up their H drive,
they see every ones personal folder. Thankfully they can't access anyone's but their own.

Normally a reboot will sort this out, however, it's becoming a recurring problem with one of our users.

Is there a reason why this happens, and more importantly, is there a fix for it?

Any help would be great, thanks!
0
internacionale
Asked:
internacionale
3 Solutions
 
Pete LongConsultantCommented:
Ive seen this happon on XP clients that have "Fast Logon" enabled

See http:Q_21503242.html#14518597
Try disabling the fast logon feature on the xp clients via group policy, run gpupdate and see if this helps at all,
Description of the Windows XP Professional Fast Logon Optimization feature
http://support.microsoft.com/kb/q305293/
0
 
Erik BjersPrincipal Systems AdministratorCommented:
Not sure if this will fix the problem but may make your admin a litle easier.  When you set the home folder map it to \\ourserver\users\%username% This way it will automaticaly grab the usernmae of the user.

eb
0
 
DenisCooperCommented:
i believe that if you change the users share to a hidden shared using users$ this will solve your problem...we had the same problem here and it resolved it for us...

to make life easier for you, select all your users, and change there home path to us the h: drive and map it to \\ourserver\users$\%username% as mentioned above by ebjers - this will change them all at once for you.

if this doesn't work, run a logon script that deletes the h: mapping then recreates it to \\ourserver\users$\%username%
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
internacionaleAuthor Commented:
@ ebjers

Sorry, i think you misunderstood the path there. We input there user name in there. Example..

\\server_name\folder_on_server\folder_within_that_folder. If I'm setting up a user called bob, with a user name of bobby, a folder would be created on our server called bobby. So i then go into AD and say connect H to \\ourserver\usersfodler\bobby.

but for some reason, it will not always map to bobby. It will map to \\ourserver\users.
0
 
Erik BjersPrincipal Systems AdministratorCommented:
I understand what you are doing.  However if you create user bob and set his home path to \\ourserver\users\%username% a folder named bob will be created at \\ourserver\users\

Then later when you want to add a new user you just right click bob and select copy.  Name the new user (let's say kim) and the home folder is automaticaly created and maped.  Just a little short cut.  Again not sure if it will solve the problem, but may streamline the creation of users.

eb
0
 
DenisCooperCommented:
yes i too understood your problem...and would use the %username% variable - if this isn't suitable for your organisation, then thats fine, but you need to set the users as a hidden share and give everyone full share permissions to it
0
 
oklaitguyCommented:
I have had this problem with users who don't log off. That is why the reboot solves it.  I have also had this problem with laptop users who shut the lid and hybernate, but rarely shut down or log off.  Maybe this is what is causing your issue as well?

We at one time had a DC on a new site that didn't have subnet setup correctly in sites/services.  consequently that server was answering log on requests all over the place and we had issues with mapped drive and printers because of it.
0
 
MarkWYnneCommented:
The user that is having the recurring problem, check LMHost file to see if there is a mapping "\\blah\users xx.xx.xx.xx"
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now