Solved

Adding second server to farm

Posted on 2006-11-02
9
1,640 Views
Last Modified: 2008-01-09
Hello, Citrix Experts!

I am a new(bie) Citrix admin and have a couple of questions I hope someone can help with.  We have a MetaFrame XPa 1.0 FR3 installation running on a Win2K Server SP4 machine.  Applying the MS Update Rollup 1 broke ICA clients being able to connect.  Uninstalling the Rollup restored things back to normal.  I understand a hotfix is available from MS as is a hotfix from Citrix (XE104W2KR02).  Are both hotfixes needed or will the Citrix download fix whatever problem(s) occur  when/if the Update Rollup pkg is re-installed?

I've also set up a second Win2K Server and applied all updates (SP4 as well as the problematic Update Rollup pkg, too).  I added this server to the existing farm this morning and find I am able to connect without issue.  I'm not complaining but am wondering why ICA clients can connect to this machine without any hotfix(es) being applied?  Is it possible that the Update Rollup pkg being installed <b>before</b> I loaded Citrix had something to do with this?

Last, I see the second server added to the farm (from the CMC) but when I look at the farm properties (on the first server) the Information section shows the farm as having only one server.  Pulling up the CMC on the newly added machine, right-clicking to check the farm properties shows the farm as having two servers.  Why the disparity?

Thanks in advance for helping this beginner admin out.
0
Comment
Question by:MutleyFDI
  • 5
  • 4
9 Comments
 
LVL 10

Expert Comment

by:chrisnewman01
ID: 17859564
As far as the hotfixes go -- it seems that <almost> every time a hotfix is released from MS, it breaks Citrix in some way :-)  You should definitely install BOTH hotfixes for successful connections to your Citrix farm.  Yes, the Citrix one fixes what MS broke or "secured".

It's possible that the existing Citrix server was upgraded from NT, or that it may have been upgraded from 2000 SP1 up to its current stage -- that's why that one may have stopped accepting connections.

I don't have XP in front of me, but is it possible that you're talking about servers in the particular zone you're talking about?  The zone may have been renamed or called something other than the default (192.168.x.x <-- if you're using those IP addresses).  When you setup Metaframe, you may have gone with the default zone name.

When you added the 2nd server and joined the farm, did you point to the other server (if you're using Access) for indirect access to the MS Access database?
0
 

Author Comment

by:MutleyFDI
ID: 17867134
Thanks for the quick reply...things have gone from curious to worse.

When I setup the farm and server1, initially, I configured it to Access for the data store.  When I added server2 the other day I had it point to the Access data store on server1 and yes, it defaulted to the 10.10.10.0 zone.  As I said, things SEEMED to proceed smoothly.  After posting my initial question(s) about the disparity in the number of servers in the farm I opted to rebooted both machines.  After the reboot both servers were showing the same information (i.e. 2 servers in the farm) and, on this side of our firewall, I was able to connect to both machines with either the web client or ICA (via PN?) client.  Shortly after that, things got progressively worse.

First, remote users began calling me to let me know that they were unable to login to server1 via their web clients; those using the ICA client (via Program Neighborhood?) didn't seem to have problems.  Then the ICA client users began reporting they were logging in ok, but nothing was appearing on their desktops.  Thinking the problem might be related to the Update Rollup being installed on server2, I tried to install the XE104W2KR02 hotfix on server2.  That didn't work (Windows Installer error; The upgrade patch cannot be installed...because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program...).  I finally resorted to uninstalling server2 and removing it from the farm which restored, after multiple reboots of server1, normal web/ICA client connections.  One of those IT day from Hades...

What the heck was happening here?  Why did the server2 install prevent normal remote client connections?  Isn't XE104W2KR02 the right patch?
0
 
LVL 10

Expert Comment

by:chrisnewman01
ID: 17867566
When you say nothing was appearing on users' desktops (in your latest post), do you mean they have icons directly on their workstation desktop, or do they get a desktop from the Citrix server?  If you're getting the "the upgrade patch cannot be installed because the program to be upgraded may be missing..." you may have a corrupt Citrix installation (worst case).  When you go into add/remove programs, how many different Citrix items are in there (including items that begin with C and also begin with M, and/or additional items)?  You should only get that message if you don't actually have Metaframe XP installed.  

Also, if you rebooted both servers at the same time, it's possible that the IMA service wasn't started on server1 when server2 tried to start its IMA service.  Using the MSAccess mode with server1 (or the whichever server the database server is) MUST be started in order for server2 to speak to it.

Are you publishing applications, or are you publishing a locked-down desktop for users to connect to?

Yes, if you have Metaframe XP running on Windows 2000, XE104W2KR02 is the correct patch.  You must first have Metaframe XP FR3 + Metaframe XP SP4 (not just MFXP FR3 and Windows 2000 SP4 -- Metaframe SP4) installed prior to installing R02.  That may be why you received the error message.

Good luck,
Chris
0
 
LVL 10

Accepted Solution

by:
chrisnewman01 earned 250 total points
ID: 17867596
From Citrix's support site for the R02 MFXP patch:

"You can apply this hotfix rollup pack only to a Windows 2000 Server with MetaFrame XP Version 1.0 with Feature Release 3 and Service Pack 4 installed."

It's a little confusing with both FR3 and SP4 for Metaframe, plus SP4 for 2000...
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 

Author Comment

by:MutleyFDI
ID: 17867873
Thanks for that info...I was only at SP3 for Metaframe, so that is likely the issue re: the patch installation.  I'll try it again after upgrading to Metaframe SP4.  When I unistalled Metaframe on server2 I did that via Add/Remove programs which showed only a single instance of Citrix Metaframe installed on the server.

Some remote users are receiving a published Desktop from Citrix via Program Neighborhood ICA connections I've set them up with.  Others are using the web client and first see the Metaframe login page, then the Applications window with a Desktop icon in it.  In each case, the connection seemed to open OK, but nothing appeared (i.e. no desktop icons).

In the scramble to get remote clients reconnected again, I can't say for certain what order I rebooted the two servers.  Understood about the IMA service needing to be up and running on server1 (the database server) before server2 is rebooted.  I'll keep that in mind going forward.

With nearly 30 remote users (and the CEO logging in remotely from China this week!) I'm a little wary about reinstalling server2 again and losing remote connectivity.  Any thoughts on why that situation occurred?
0
 
LVL 10

Expert Comment

by:chrisnewman01
ID: 17868072
I'm not sure what happened with server2, but you could still bring it online and setup a test published desktop -- specifically for testing by yourself or other users (call it "Desktop Test" and only server2, then add yourself and another user or two for testing).  

If you had SQL for the Citrix data store instead of Access, you won't have to worry about rebooting either server, because you're directly accessing the SQL database.

Is server2 in the same OU as server1 (if using AD).  If you're missing desktop icons when users log in, it's possible that you have a group policy being applied to that server that's locking down access for the users.  Is server2 a fresh installation of 2000 and Metaframe, or was it another server with a different function before?  I'm asking because of the desktop icon issues you experienced when bringing it online.  
0
 

Author Comment

by:MutleyFDI
ID: 17869815
Yes, Server2 is in the same OU as Server1 and is a fresh install of Win 2000 Server (up through SP4 and all patches incl. Update Rollup 1).  I will apply Metaframe SP4, Update Rollup 1 and hotfix XE104W2KR02 to Server1 (and keep my fingers crossed).  Assuming all goes well with that adventure I will re-install Server2 (again), apply the SP and hotfix and try your suggestion of creating the test published desktop.

Thanks for your help.  I will get back to you on the results.
0
 

Author Comment

by:MutleyFDI
ID: 17884701
I applied Metaframe SP4, Update Rollup 1 and the XE104W2KR02 hotfix to Server1 and all appears ok.  Today I reinstalled Metaframe XP/FR3 on Server2 (adding it to the existing farm),applied Metaframe SP4 and the XE104W2KR02 hotfix...all installed successfully but now the CMC will not start on Server2.  As before, I've set Server2 to point to the data store on Server1.  Why won't the CMC start on Server2?
0
 

Author Comment

by:MutleyFDI
ID: 17884995
Pls disregard previous post.  CMC came up on Server2 after mutiple reboots of the machine.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
Citrix XenDesktop, Citrix Studio, Citrix Policies, Citrix XenApp
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now