• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1000
  • Last Modified:

EMC LUN unreadable, weird chain of events

Host1: emulex lp1150 hbas / win2003 with 2 luns (400gb and 1200gb)
Host2: emulex lp1150 hbas / win2003 with 1 lun (300gb)

Both hosts are connected to 3 luns from 1 dae.

Host1 had lun400gb show up as 'unreadable", so I unbinded and then rebinded causing it to go into "Transitioning" mode. While the transistion, host1 dropped LUN 1200gb also. After adding lun400gb back to the strge grp, lun1200gb shows unreadble and lun400gb is fine.

During all this, Host2 was just fine with its lun300gb.

Any insight?
Thanks.
0
sudipmis
Asked:
sudipmis
  • 3
  • 3
1 Solution
 
arnoldCommented:
Are you connected to a switch or directly into the EMC dpae?  Are you making changes on the EMC itself?
Double check the allocation to make sure that both host are configured with access.  Are these hosts in a cluster or does each host have rights to access the luns?  If the latter, that might be your problem.
0
 
sudipmisAuthor Commented:
Connected to through a cisco 9216.
Yes, I made the LUN binding/unbinding changes in Navisphere on a agent pc.
Yes, at one point both hosts had access to each of the assigned lun's.
Not to sure as what is a cluster in a san....we only have one DPE, 2 switches for reliablity and about 6 hosts so far.
0
 
arnoldCommented:
When you zoned the hosts, did you do it based on the port or on the host id?  It looks like an issue with zoning and paths.  on the host, powerpath admin/monitor should tell you if there is a problem.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
sudipmisAuthor Commented:
In powerpath,
   under Disks, i see Disk001 and Disk002....now, I have 3 400gb disks and no 1200gb disks.  any idea? Under errors column, it shows1 error for SP-B0 for disk 001 and 002.
   Our ppath is unlicensed.
I
0
 
arnoldCommented:
I gather you mean that your powerpath is in a failover mode.  With EMC some licensing is provided for powerpath.
sp-b0 has a path problem.  This is either due to a cable issue or to the zoning on the switch/EMC.  How are the LUNS configured?  Are they owned by spa or spb?  
0
 
dovidmichelCommented:
Two general troubleshooting items:
1) Enable logging on the switch - this is great for identifying  which side of the switch as a problem
2) update Storport.sys - this driver is being updated about every 3 to 4 months and has solved many problems for me relating to Windows systems. The latest version I know of is:
http://support.microsoft.com/kb/916048
Storport.sys 5.2.3790.2723 100,352 13-Jun-2006 10:25 x86
0
 
sudipmisAuthor Commented:
arnold,
   It turned out the cisco 9216 didn't correctly distribute the zone...its fine now.

dovidmichel,
  I also updated the .sys file.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now