Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 16212
  • Last Modified:

Linksys router won't connect to the internet

Ok, just got myself an ethernet modem and router. Want to connect to the internet via the router so i can get wireless internet on my laptop.

Modem - D Link DSL320T
Router- Linksys WRT54G v7
ISP - Pipex DSL Connection

I connect it all up, and I get the following indicator lights showing:
On the modem -
Power, ADSL, Ethernet (all solid)
Status (flashing)

On the router:
Power, WLAN, port number, Internet (all solid)

However when I try to connect, by going to 192.168.1.1, then going to status (which shows disconnected), I then press connect, and it says it cannot find an IP address. I have installed the router using the following guide -
http://linksys.custhelp.com/cgi-bin/linksys.cfg/php/enduser/std_adp.php?p_faqid=2210&p_created=1110937569&p_sid=btIGUT4i&p_accessibility=0&p_lva=1650&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9MSZwX3Byb2RzPTAmcF9jYXRzPSZwX3B2PSZwX2N2PSZw
Also I may add that the modem connects fine to the net without the router (hence me being able to write this) - I'm just really confused as all the appropriate indicator lights on modem/router are showing...

Any help greatly appreciated...

Thanks
Sam
0
fresh04
Asked:
fresh04
  • 2
1 Solution
 
zephyr_hex (Megan)DeveloperCommented:
first, make sure that you power on your modem AFTER you power on the router.  the reason for this is that many modems are also routers themselves, and they will try to run DHCP if they do not detect DHCP.  if you power on your modem first, it will not detect DHCP and it will run it, and then you power on your router and it's running DHCP, too ... and then you have a problem.  so power on the router first, wait about 30seconds, and then power on the modem.

also... you may need to configure your router with the proper default gateway, and dns.  the correct default gateway is the IP address of your modem.  the dns should be the dns settings provided by your ISP.  you may need to call your ISP for these settings.

once you have your router configured, verify that you can surf the internet when your laptop is plugged into the back of the router.  if this is the case, then all you need to do is secure your wireless signal.  here is a good article on how to do that: http://www.onlamp.com/pub/a/bsd/2004/10/21/wifi_ipsec.html
0
 
zephyr_hex (Megan)DeveloperCommented:
sorry, here is the article i meant to post about securing your wireless signal: http://www.microsoft.com/windowsxp/using/networking/expert/bowman_03july28.mspx
0
 
fresh04Author Commented:
Sorry, I think I have it figured- I made a mistake in my original post- I am connected to "Pipex Extreme ADSL" - and the router is a DSL router- if you can confirm that this is why the internet isn't connecting- I'm pretty sure it it- then I will give you the points, for taking the time to reply.

Thanks
Sam
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now