We help IT Professionals succeed at work.

Sonicwall Pro 2040 VPN client connection

vamsi_uk
vamsi_uk asked
on
Medium Priority
559 Views
Last Modified: 2010-04-12
Hello Experts,

I have tried to configure VPN on my Sonicwall Pro 2040 with SonicOS Standard 3.1.0.7-77s. Problem is that my office network is 192.168.xxx.xxx.  But when i use the Global VPN client, im getting a message that im getting connected successfully to my sonicwall, but im getting an IP allocated which is like 213.1.1.128 and obviously i cannot connect to any of my servers. I thought i should get a 192.168.xxx.xxx address.

Let me give you the configuration I have done and maybe you can point out where i am going wrong.

Under VPN - Settings tab, i have used pretty much most of the default settings in the default Group VPN policy.

Under 'Advanced' tab settings, these are the options that i have chosen..

 Disable all VPN Windows Networking (NetBIOS) Broadcasts  
 Enable Fragmented Packet Handling  
 Ignore DF (Don't Fragment) Bit    
 
 Enable NAT Traversal  
 Enable IKE Dead Peer Detection
 Clean up Active tunnels when Peer Gateway DNS name resolves to a different IP Address  

Under DHCP over VPN tunnel tab,

Central Gateway configuration:

Send DHCP requests to the server addresses listed below (select this option and given our internal DHCP server's address)

The above options are the ones pretty much that i have configured under VPN settings..

Now i tried to connect using Global VPN client and i got a message that im succesfully connected to the IP address of the sonicwall, now instead of getting a 192.168.xxx.xxx which is the internal LAN address of our office network, im getting some IP address like 213.1.1.128. I just dont get it why im getting an IP like that. I cant obviously connect to any of the servers in my office. Can someone please tell me what i should be checking or correcting as im not very much familliar with firewalls and vpn, infact this is the first time im configuring a vpn. So i would really appreciate any help to solve my problem.

thank you
vamsi


Comment
Watch Question

on the vpn setting page check the two boxes to enable vpn
under group vpn on the advanced tab > check require authentication of vpn ...
on Client page >  cache xauth > single session
virtual adapter setting > dchp lease

create a local user on users page in the sonicwall
fill in user name password and check give access to vpn's and access from vpn client with xauth

Central Gateway configuration:

Send DHCP requests to the server addresses listed below (select this option and given our internal DHCP server's address)
use this if using windows server as dhcp server

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Hi Jason,

I have done all the settings initially except the "DHCP lease in virtual adapter settings" and that is what was causing problem all the while. Now im getting a 192.168.xxx.xxx address and im able to ssh and ping to my local servers. However, there seems to be a small glitch now, im able to ping and ssh by ip addresses, but not by using hostnames. Is this anyway related to sonicwall,can you think of anything that might be causing this problem?

thank you
Vamsi
Glad I could help.
Do you have your DNS settings configured in the sonicwall?
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.