We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Cannot FTP out from PCs on network. Works ok from server

BigCap
BigCap asked
on
Medium Priority
236 Views
Last Modified: 2010-03-18
ftp works ok from the server but none of our pc's will connect to any connection at all. The error is 'connection refused'.

Server:
Windows 2003 SBS
IIS 6.0
ISA 3.0

The server is setup as a proxy.
Any ideas what i need to be looking at to fix the issue? Is there a rule i need to setup somewhere in IIS or ISA?

Comment
Watch Question

check ISA for a deny on Outbound  port 21
Keith AlabasterEnterprise Architect
CERTIFIED EXPERT
Top Expert 2008

Commented:
Are you running the premium version of SBS with ISA?
If so, have you enabled a rule to let ftp go out? Needs to be from local host & internal to external

open the ISA gui, select monitoring - logging - click on start query.
Make an FTP attempt from a client, what do you see in the log?

Author

Commented:
The option to add a new rule or edit an exisiting rule doesn't exist.
I have the following protocol definition setup:

Name                               Defined by            Port Number             Protocol Type                 Direction
FTP download only            ISA Server                  21                            TCP                       Outbound

I read somewhere that ISA is configured differently on server that only have one NIC and are sat behind a firewall.
Is it called cached mode or something like? Could this have any bearing?

I logged onto my hardware firewall (Sonicnet) and setup a rule to allow all LAN traffice FTP access to the WAN.
Still the same message!!  surely it's got to be ISA or my firewall causing the issue??
Keith AlabasterEnterprise Architect
CERTIFIED EXPERT
Top Expert 2008

Commented:
Sorry, missed the ISA comment in your first post. There is no such thing as ISA 3.0, it will be ISA2000, ISA2004 or the new ISA2006 but I don't think ISA2006 ships with SBS yet. if you only have a single nic in the box, then no, you cannot change the protocols as it is acting as a Proxy only, not a firewall.

The ftp rule you have for port 21 is for when you use a full blown ftp client. Have you tried ftp within the web browser? make sure the IE proxy settings - advanced have all the settings pointed to the same port number.

Author

Commented:
Hi all,

Thanks for your advice with this problem. I managed to get it sorted in the end.
It was down to our firewall (sonicwall TZ170SP) blocking the ftp traffic.

Basically the TZ170SP as default only allows 10 connections. Our web traffic is directed via a proxy server which would only mean it uses one of the connections but ftp traffic goes out directly and uses one of the remaining 9 connections.

The sessions should be released after use but the firewall wasn't doing it's job and was seeing all 10 concurrent connection in use and therefore preventing any further outbound connections.  A hard reset fixed the problem.
Keith AlabasterEnterprise Architect
CERTIFIED EXPERT
Top Expert 2008

Commented:
<<Have you tried ftp within the web browser? make sure the IE proxy settings - advanced have all the settings pointed to the same port number.>>

FTP through the web browser and with its proxy settings set cannot go direct to the firewall by definition but the important bit is that its working but yeah, PAQ it.
Closed, 200 points refunded.
kb
Experts Exchange Moderator

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.