Solved

Wireless and Wired network connection active at same time, which one is used?

Posted on 2006-11-03
9
765 Views
Last Modified: 2010-04-24
Hi All,

I have a laptop that has integrated wireless and a ethernet port.  Typically when user comes into office, the connect to the wired network and work.  There is also wireless available in office.  When the laptop boots up, the wireless is automatically enabled and connects.  They are also connected to the wired network.  This causes a problem when running logon scripts as some network resources are not seen or correctly mapped.  When I boot-up with the wireless disabled, no issues.  So the questions are:

1. Short of manually disabling the wireless (enabling it when needed), how do I make sure that the wired network connection is used when it is connected?
2. Is there a way to have the wireless disable itself when a wired connection is active?

Thanks!
0
Comment
Question by:ClearBlueTechnologies
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +2
9 Comments
 
LVL 12

Expert Comment

by:WallD
ID: 17870143
I take it that there isnt a manual switch to turn on and off the wireless network.

Are you using the same subnet for the wire and wiesless networks?

Do you have just one machine with problems and do any work?

David
0
 
LVL 39

Expert Comment

by:PUNKY
ID: 17870896
If your laptop does not have switch On/Off, then check the manual see if any function key (normally Fn+F5) to trun on and off wireless device.
0
 
LVL 1

Author Comment

by:ClearBlueTechnologies
ID: 17878544
Yes there is an on/off switch. Yes, the wired and wireless are on the same subnet. Yes, more than one laptop has this problem.

I don't want the user to have to remember to manually shut off the wireless card prior to logging on to the network.  

Any other thoughts?
0
Surfing Is Meant To Be Done Outdoors

Featuring its rugged IP67 compliant exterior and delivering broad, fast, and reliable Wi-Fi coverage, the AP322 is the ideal solution for the outdoors. Manage this AP with either a Firebox as a gateway controller, or with the Wi-Fi Cloud for an expanded set of management features

 
LVL 39

Expert Comment

by:PUNKY
ID: 17879063
As now, there is no automatic shut off a network device when other plug in. User must use on & off switch or key command (Fn +F5), or have to manual disable deivce thru its property. Other experts might have better idea or soft tool can help.

Good luck.
0
 
LVL 12

Expert Comment

by:WallD
ID: 17879509
All I can think of is making sure that when you connect via the wireless that yur connection is good and that all mapped drives work properly, easier done than said.

David  
0
 
LVL 88

Expert Comment

by:rindi
ID: 17886042
Usually the connection that get's a valid connection first will then also be used. That will usually be the wired connection as it connects faster (no need for for wpa etc which would be used in wireless). Also a lot of wireless devices connect only after login, particularly if you use the manufacturer's utility and not the zero config one. So if your users first connect the PC to the LAN, then bootup, they should 1st connect to the wired LAN and that should then also be used for further communications.
0
 
LVL 1

Author Comment

by:ClearBlueTechnologies
ID: 17893450
Short of using a sniffer to look into the packets, is there a way to determine which NIC a packet decides to take?  I agree that the wired connection will setup first but the wireless connection is also setting up before the logon occurs.  Then when the startup script runs and tries to map the drives it does not do it correctly.  There might not be a solution for this other than disabling the wireless NIC when not in use.

0
 
LVL 34

Accepted Solution

by:
jamietoner earned 500 total points
ID: 17924225
On my D810 it uses the wired connection when one or both the wireless connections are connected to my knowledge xp defaults to the wired connection ( i havent read this any where but both my laptop, desktop and friends system behave the same way). To verify what nic its using simply open up task manager with ctrl+atl+del (assuming here your using xp) then click the networking tab, now down load a file or transfer something over the network and see which nic has the higher network utilization.
0
 
LVL 1

Author Comment

by:ClearBlueTechnologies
ID: 17927152
Jamie - thanks for the reminder about viewing the nic through tskmgr.  While that doesn't completely answer my question, it will give me a good idea what what is going on with the NICs.

Thanks!
0

Featured Post

Now Available: Firebox Cloud for AWS and FireboxV

Firebox Cloud brings the protection of WatchGuard’s leading Firebox UTM appliances to public cloud environments. It enables organizations to extend their security perimeter to protect business-critical assets in Amazon Web Services (AWS).

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have had so many issues with my Vodafone 3G card (Novatel Merlin u630, provided by French carrier SFR) on Windows XP laptops that I thought I would create an help page for other users (I solved the issues). First issue, with my IBM/Lenovo lapto…
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question