Solved

How to disable Fn-Spacebar Hotkey on Toshiba Laptop

Posted on 2006-11-03
13
5,546 Views
Last Modified: 2012-06-27
Hi all. Pressing Fn-spacebar on  my Toshiba P-20 causes my screen resolution to toggle between 1024x768, 1280x1024 and its native 1440x900 (desired) setting.

The problem is that I use an application that has a repeated CTRL-spacebar hotkey that I need to use. If  my finger slips onto the Fn key while I press spacebar, the darned screen resolution swaps, causing me all sorts of headaches.

Does anyone know what feature / control panel / registry setting or other setting can be used to deactivate this feature. I can't imagine it being useful to anyone, but that's besides the point. If you have any info, I sure would appreciate it!

Tom
0
Comment
Question by:tomaugerdotcom
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
13 Comments
 
LVL 70

Expert Comment

by:garycase
ID: 17870776
I don't know for sure ... but those types of shortcuts can often be turned on/off either in (a) the BIOS Setup; if it's a universal mode setting that does not depend on Windows;   or (b) in Display Properties (probably on the advanced tab of Settings) if it's a Windows shortcut.
0
 
LVL 14

Author Comment

by:tomaugerdotcom
ID: 17873882
I'll check the BIOS but I know for sure it's not under Settings > Advanced or the nVidia control panel either, which is where it would seem the most logical to me. But I have all nVidia CP functions turned off and there are no shortcuts available in Advanced settings. any other ideas?
0
 
LVL 70

Expert Comment

by:garycase
ID: 17874012
Simple way to confirm if it's a BIOS setting or a Windows driver setting:

Boot to the BIOS Setup, or to a Windows 98 boot disk (or any other floppy-based environment ... for example MemTest86+) and see if the Fn-Spacebar combo changes the resolution.  If not, then it's a Windows driver hotkey ... and there HAS to be a setting in the nVidia controls to disable it !!   These kinds of things are often "hidden"  (i.e. buried in a not-so-obvious submenu).
I don't have a PC handy with a newer nVidia card to try it ... mine all use ATI-based cards ... but if you have patience and look very carefully I'm sure you'll find it :-)
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 14

Author Comment

by:tomaugerdotcom
ID: 17877117
Hmm. I didn't see any settings in the BIOS that had anything to do with keyboard combinations. It looks like I will be hunting for a while...

does anyone else have any suggestions?

Tom
0
 
LVL 70

Expert Comment

by:garycase
ID: 17877124
Does the key combination change the display resolution if you're "outside of Windows" ??  [the test I suggested above]
0
 
LVL 70

Expert Comment

by:garycase
ID: 17877178
... because if it does NOT, then there won't be any settings in the BIOS => they will be in the nVidia settings.  

I booted up an older machine I have with an nVidia card and took a look at the nVidia settings.   If I go to Display Properties; the Settings tab; and click the Advanced button; and then click on the tab for the display adapter, then expand Desktop Management ... there is a HotKeys section.

While this may be slightly different for your system (depending on which version of nView you have and exactly which adapter), there is almost certainly an equivalent path to the hotkeys => and all you have to do is disable the hotkey that's causing the issue :-)
0
 
LVL 14

Author Comment

by:tomaugerdotcom
ID: 17881159
Thanks for the additional comments. in the nView manager, I have everything turned off - desktop management is not enabled, and all my hotkey options are deactivated - there are no hotkey mappings enabled in the nView desktop manager. So, something tells me it's not nView, it's Toshiba. the IBM thinkpad has a similar problem but for some reason that one is quite heavily documented on the Internet, while the Toshiba issue is not. I have, of course, logged a ticket with toshiba, but I will be shocked if they respond.

I'll keep digging. Meanwhile, additional ideas or suggestions would be appreciated!

Thanks

Tom
0
 
LVL 70

Expert Comment

by:garycase
ID: 17881722
I'm still curious whether the key has any effect outside of Windows -- does it ????
0
 
LVL 14

Author Comment

by:tomaugerdotcom
ID: 17899215
As we guessed, the hotkey combination did not have any effect outside of Windows. In fact, it wasn't even recognized on the Windows login screen (where you choose the user you want to log in as). Only once actually logged into the Window XP Home Edition environment did it immediately become active.

Arghhh! I hate this feature!! How to deactivate it?

Thanks for your continued interest in this question.

Tom
0
 
LVL 70

Accepted Solution

by:
garycase earned 390 total points
ID: 17899584
You're missing something in the nVidia drivers --- it's clearly a function of the drivers.

First, see if it's a startup program or the base drive:  Run MSCONFIG  (Start - Run - MSCONFIG) and disable ALL of the items on the Startup tab.  Reboot (it will warn you about the diagnostic startup on reboot) and see if you still have the behavior.
0
 
LVL 14

Author Comment

by:tomaugerdotcom
ID: 17916450
I have determined from the Toshiba web site and from a lot of sniffing about that it is in fact a toshiba control panel called "eKey", which can be uninstalled using your standard windows add/remove programs.

removing the Toshiba hotkey control panel will disable the Fn-spacebar feature, but does not seem to negatively impact the other Fn-hotkeys such as CRT/LCD switching or the brightness controls etc.

Thank you to all for looking into this issue with me. I will now close the topic.

gary, I will split points with you because of your continued efforts, although it didn't prove to be the solution.

Many thanks again!

Tom
0
 
LVL 14

Author Comment

by:tomaugerdotcom
ID: 17916469
Guess I can't split points between you and myself, so I've accepted your answer. Once again, thank you.

Tom
0
 
LVL 70

Expert Comment

by:garycase
ID: 17916676
You're welcome.
0

Featured Post

Why You Need a DevOps Toolchain

IT needs to deliver services with more agility and velocity. IT must roll out application features and innovations faster to keep up with customer demands, which is where a DevOps toolchain steps in. View the infographic to see why you need a DevOps toolchain.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Will either laptop run DayZ? 2 160
Bad_Pool_Header 0x0000019 BSOD tho can boot in safe mode 18 114
Black screen on my Lenovo U31 laptop 11 65
hp laptop chargers 4 67
Introduction: I have always been fascinated by wireless technology ranging from Infrared to Wimax. Bluetooth comes next to Infrared (in terms of distance of operation) and is commonly used in gadgets like Cellphones, PDAs and Computers for the ex…
Sometimes a user will call me frantically, explaining that something has gone wrong and they have tried everything (read - they have messed it up more and now need someone to clean up) and it still does no good, can I help them?!  Usually the standa…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question