Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 481
  • Last Modified:

How to disable XGL & 3D Acceleration from command prompt

I enabled the 3D Acceleration and XGL desktop effects on my SLED 10 system. However, my hardware is old and doesn't support it (thought I'd try anyway). I can no longer get the GUI to run.

So... Can anyone tell this newbie how to turn off these settings from the terminal on SUSE Linux Enterprise Desktop 10?  Short of reinstalling the OS that is!  If I have to reinstall its not a big deal, as this is a brand new, clean install. Still, if I can just change the video settings it would be quicker.

Thanks!
0
bereanbs
Asked:
bereanbs
  • 2
  • 2
1 Solution
 
ygouthamCommented:
you can use the command gnome-xgl-switch --disable-xgl as root to disable Xgl from the command line. (You will probably also need to do rcxdm restart to restart X and the login screen.)
0
 
bereanbsAuthor Commented:
Thanks, that did the trick!

Have a great weekend!
0
 
bereanbsAuthor Commented:
FYI, I did not need to run RCXDM... As soon as I disabled XGL it restarted X by itself.

Prior to disabling XGL, when I attempted to restart X it would go into the GUI for about 1/2 second then kick it back to the command prompt.

Cool Deal!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now