Solved

my png is not showing in firefox

Posted on 2006-11-04
5
274 Views
Last Modified: 2012-06-27
this is the css


#left {
background-image:url(../images/middle.png);
width: 435px;
position:absolute;
height:350px;
top:160px;
left:0px;
border:1px #663366 solid;



}
0
Comment
Question by:roscoeh23
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 6

Expert Comment

by:badalpatel
ID: 17872630
Which version of FF u r using??
u try to update the FF version..
0
 
LVL 143

Expert Comment

by:Guy Hengel [angelIII / a3]
ID: 17872652
does it show in other browsers?
0
 
LVL 3

Assisted Solution

by:jsev1995
jsev1995 earned 250 total points
ID: 17872961
OK, this happened to me once with Drupal: the logo would not display. Things to try:

1. Make sure it's actually a PNG (not just with the png file extension)
2. Use a format other than PNG (gif, jpeg, etc)

Hopefully this helps
0
 
LVL 19

Accepted Solution

by:
VoteyDisciple earned 250 total points
ID: 17872963
For that matter, do you see the border at that position and just not the image inside?  I'm wondering if that entire rule is never applied (the simple case being there's a typo in the element's ID, for example), or if it's the image itself that's problematic.

Firefox plays very well with PNGs, alpha transparency and all.  I doubt the PNG format has anything to do with it.  

If it is just the image that's not showing up, you might trychanging the rule to...

background-image:url(../images/middle.png) !important;

... to see if there's some other rule overriding what you wrote somewhere else (like a .parent-element div #left { background: white; } rule or something -- that rule would take precedence over what you wrote there).  If it works with !important, then you can go hunting for what other rule might be taking precedence.

I suppose to be thorough I should also suggest trying to put an <img src="../images/middle.png" alt="" /> tag on the page directly to make sure the image can show up at all (answering the questions "Is it a permissions problem on the server?"  "Is that really where the image is?" et cetera)
0
 
LVL 3

Expert Comment

by:jsev1995
ID: 17872975
Well it did happen to me where it worked in IE and Safari but not Firefox. So try both solutions, we'll see.
0

Featured Post

Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Color can increase conversions, create feelings of warmth or even incite people to get behind a cause. If you want your website to really impact site visitors, then it is vital to consider the impact color has on them.
There’s a good reason for why it’s called a homepage – it closely resembles that of a physical house and the only real difference is that it’s online. Your website’s homepage is where people come to visit you. It’s the family room of your website wh…
The viewer will learn how to count occurrences of each item in an array.
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question