Solved

Quicktime installation errors during upgrade

Posted on 2006-11-04
17
632 Views
Last Modified: 2008-01-09
I have been getting the below event details while trying to upgrade quicktime.  I have tried all permission changes, I am an administrator, and I have uninstalled all previous versions.  However, this error keeps stopping the installation of the new version.  Any ideas?

Event Type:      Error
Event Source:      MsiInstaller
Event Category:      None
Event ID:      11402
Date:            11/4/2006
Time:            8:34:09 AM
User:            HOME\home-pc
Computer:      HOME
Description:
Product: QuickTime -- Error 1402. Could not open key: HKEY_LOCAL_MACHINE\Software\Classes\QuickTimePlayerLib.QuickTimePlayerApp\CLSID.  System error 5.  Verify that you have sufficient access to that key, or contact your support personnel.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 7b 46 30 37 42 38 36 31   {F07B861
0008: 43 2d 37 32 42 39 2d 34   C-72B9-4
0010: 30 41 34 2d 38 42 31 41   0A4-8B1A
0018: 2d 41 41 45 44 34 43 30   -AAED4C0
0020: 36 41 37 45 38 7d         6A7E8}  
0
Comment
Question by:envoygc
  • 11
  • 6
17 Comments
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17916556
Try a few things :

1. Open up regedit and navigate to that registry key and right click on it and go to permissions of that registry key and make sure that you have full control of the registry key.

2. Un install quicktime including the upgrade etc

3. make a full back up of your registry

4. get ccleaner ( www.ccleaner.com )

5. Run the registry cleaner in ccleaner and fix all the issues it finds making sure to run it a few times and you can also save the changes before fixing them.

6. download quicktime ( stand alone installation ) and re install it.
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17916573
Also it may be an idea to use the windows clean up utility described on this page :

http://support.microsoft.com/kb/290301
0
 

Author Comment

by:envoygc
ID: 17935594
Thanks for the comments.  I have tried both of your ideas and the same problem still exist.  Basically, I just need to figure out how to delete registry entries that I cannot take ownership of.  Can I do this at some command line level?  As for the options above, ccleaner worked, but it also could not delete the quicktime registry entries that there are no permissions to.  The eindows clean up utility did not list quicktime as an installed application even though it has existing registry entries.  I assume this is because I have already uninstalled quicktime.

So if you have any ideas on how to get rid of these protected registry entries, I think that will do it.
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17935631
Re install quicktime over itself and then try the above methods again ( including the windows clean up utility )
0
 

Author Comment

by:envoygc
ID: 17935642
I have tried and the install get to the point of registering keys and then fails giving me a message that I do not have permissions to the key.  I am already the system administrator, so I do not know what else to do.  I fell like I may need to format.
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17935670
can you take ownership of the key ? if you right click on the key and go to permisions does it tell you who has owner ship of the key ( If not then what about closing regedit and going to control panel --> folder options --> disable simple file sharing

basically the last checkbox and apply that then go back to reg edit and see if you can view who has owner ship , then if its not administrator you need to make administrator have full control / ownership of the key(s) and then delete them.
0
 

Author Comment

by:envoygc
ID: 17935739
I cannot take ownership.  Looking at the permissions of the key the current owner box list "unable to display current owner".  If I try to take ownership, I get a message telling me that I cannot. I am sure if I could get ownership, it would fix this problem.
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17935745
if you go to control panel --> admin tools --> event viewer, does it display any error messages regarding you trying to delete the quicktime registry keys or quicktime or anything like that, if so what are the event id's for those events.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17935751
can you delete the registry keys in safe mode or even for that matter un install quicktime in safe mode ?
0
 

Author Comment

by:envoygc
ID: 17935761
no, nothing is logged in event viewer while trying to delete keys.  only the event id related is the one above that I get every time I try to install quicktime.  this is driving me crazy.  could the registry be corrupt?  if so, can that be fixed?
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17935779
have you got system restore enabled, if so maybe go to a restore point before you installed quicktime.
0
 

Author Comment

by:envoygc
ID: 17935781
i have not tried safe mode.  i will have to try that and report back.
0
 
LVL 23

Accepted Solution

by:
gecko_au2003 earned 500 total points
ID: 17935792
what about going to control panel --> user accounts --> create a new administrator user , log off and back on as that new user and then try to delete those registry keys making sure to see if you can try to take ownership and full control of those registry keys with that new account ?
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17935804
Found this :

1. Go in the registry editor. The top most folder listed i
HKEY_Classes_Root.
Right-click on this folder and select PERMISSIONS from the menu.
2. Once there, look through the permissions listed and make sure that
Administrators and System are both listed. If they are not, pleas
refer to
the bottom of this write-up under "Conditional Step".
3. If they are both listed, make sure that both have Full Control
checked on ALLOW. If they are not yet checked, click in that box an
select
APPLY. This will put the proper permissions through the registry an
should
set you up for a good installation. Once finished with this area selec
OK
and close the Registry Editor.

source site : http://www.daniweb.com/techtalkforums/thread31171.html
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17935811
Conditional Step
---------------------
If you've found that System and/or Administrators are not listed i
the
permissions section, you will need to add them. To do so, click th
Add
Button and in the following screen type System or Administrator
depending
on which is missing. (You may only do one at a time). Once typed
select the
CHECK NAME button which will end up highlighting the name and then yo
can
select OK.
0
 

Author Comment

by:envoygc
ID: 17935865
I think you are onto something with the new account.  I logged in with one of my other accounts and could delete the keys and install the program.  I will work later on removing/migrating my profile completely, but this looks like the fix.

I will report back.  Thanks, John

BTW - I had already tried before the permission setting on the HKEY_Classes_Root folder.
0
 
LVL 23

Expert Comment

by:gecko_au2003
ID: 17935926
here is what apple says about it :

http://docs.info.apple.com/article.html?artnum=93865

Also there was an mskb here :

http://support.microsoft.com/kb/236427/

 but it only applied to windows 98 and ME thats why i suggested the new account because they were saying that it was due to profile corruption or the registry being corrupt and to use regscan to restore or fix the registry.

Not sure what the equivelant is in windows xp though. Probably system restore.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Many programs have tried to outwit PowerPoint in terms of technology and skill. These programs, however, still lack several characteristics that PowerPoint has possessed from the start. Here's why PowerPoint replacements won't entirely work for desi…
Users will learn how resize a batch of photos from a single command in Photoshop via Photoshop's Image Processor. Open up an Image you'd like to resize in Adobe Photoshop: Adjust the image size according to your preferences. Image > Adjustments > …
Viewers will learn how to use LFOs to modulate the sound of their Sampler instruments. Click the Modulation tab in Sampler: Choose one (or more) of the three available LFOs, and click the respective button to turn it on: Select a waveform, an LF…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now