IIS6 and Exchange Server 2003

Two Servers:  Both have Windows 2003 Enterprise OS
This is a residential operation so the network router is gateway with IP of
Our ISP assigns a static IP of xxx.xxx.x.x

One is IIS 6.0 Web Server
One is Exchange 2003 Email Server
Both are running IIS 6.0 (Should they be?)

I am using Port Forwarding on the router, so
Application    Port    IP
HTTP            80  (IIS 6.0 Web Server)
POP              110  (Exchange Server)      
SMTP            28  (Exchange Server)      

My Question:
The MX record for the DNS should point to the static address right?  say, xxx.xxx.x.x
assigned by the ISP, in this case both servers are routed through the assigned ISP static address via Router  

Is IIS required on the Exchange server?  Can I remove SMTP services on the IIS6 Web Server?
What would be the best configuration?  

Who is Participating?
poweruser32Connect With a Mentor Commented:
yes the mx should point to the external static  ip assigned to you by the isp and just configure your router or firewall as you have it-do you need to use pop?
iis is required for owa which is the best feature of exchange and can eliminate the need for pop
smtp can be removed by iis as it is not need by the web server

SembeeConnect With a Mentor Commented:
If you remove IIS on the Exchange server then your Exchange server will not function. You cannot have Exchange without IIS.

In this configuration you will have no remote access to Exchange for OWA. If you want to use OWA then you could use an SSL certificate and then redirect port 443 to the Exchange server.

kibbsAuthor Commented:
I should have been more clear in my description, the IIS server on the web server previously had SMTP (w2k3 version) which was removed;  Should it not havce been removed?  Is it required on the web server IIS?  
W2k3 SMTP is NOT running on the IIS on the exchange server.  

This server will primarily be used to communicate with several thousand registered users of our products.  We have clients that need to access POP feature SMTP and OWA.    

the domain is XXXBESI but we have almost a hundred different domain names that we want to use for sending and receiving email.  
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Stacy SpearConnect With a Mentor President/Principal ConsultantCommented:
On your setup you have port 28 instead of port 25.
Exchange server doesn't do the final sending of the message, the SMTP service does. Without it, your server will not send nor receive email. Exchange is like cake batter. It needs an oven (smtp) to do its baking. :)

Interesting domain name.
You removed SMTP from IIS?
Oh dear.

That has broken Exchange.
Exchange 200x doesn't have its own SMTP engine.

You might get away with installing SMTP again and then reinstalling Exchange on top and finally re-service packing the server.
If that doesn't work, then I hope you have good backups. You will have to remove Exchange, then remove IIS and then reinstall both.

Rule number one with Exchange - once Exchange is installed, do not touch the IIS configuration.

kibbsAuthor Commented:
kibbsAuthor Commented:
Which IIS should the SMTP be installed?  On tyhe web server or the Exchange Server?
Stacy SpearPresident/Principal ConsultantCommented:
Exchange server
kibbsAuthor Commented:
okay, everything should be fine them.. I only removed it from the Web Server IIS
kibbsAuthor Commented:
One last question - The web server is also a DNS, domain controller.  Do I need to modify the MX records there also?  
The DNS MX records were modified through ISP already, so wouldnt doing it at the DNS of our local server be redundant?  Is it required?
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.