Daemon not Shutting down at run level change.

We're running a cold backup and we change runlevels to do this.

I am not a big UNIX guy, but our UNIX guy is on vacation. So it's my job.

One of the daemons is hung on stopping on the rc scripts and it's been hung for a while.  Can I tell it to move on to the next thing and just hard shut it down.  It's the Veritas volume administrator daemon.  We don't use VxVM, so it's not a big deal.

Anyway.  Is there a way to force it to stop, move on, ignore, etc?

this is HP-UX 11.11.
LVL 4
flood_landAsked:
Who is Participating?
 
Kent OlsenConnect With a Mentor Data Warehouse Architect / DBACommented:
Hi flood_land,

Kill the task.  Enter "ps -ef" to find the task.  Then enter "kill <task_number>".   Task_number was displayed by the "ps" command.

The daemon may trap and ignore a simple kill signal.  If so, try "kill -9 <task_number>".  It should terminate for that signal.


Good Luck!
Kent
0
 
JJSmithConnect With a Mentor Commented:

Something like Veritas Volume manager would probably be started by one of the scripts in /sbin/init.d directory.

If you can identify them with something like ' grep -l vx  /sbin/init.d/* ' then you should be able to call the scripts with a stop argument.

If it's hanging; are you absolutely sure you are not using Veritas - I know some HP-UX systems were shipped with the root volume group under veritas rather than HP's LVM.

If you're not using veritas then someone needs to look at the parameter files in /etc/rc.config.d to stop the processes starting when the machine boots.

Cheers
JJ
 
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.