• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 875
  • Last Modified:

PHP 5 to 4 downgrade

Okay experts, I am out of my league on this one so I need some very specific help.  My company has been using a LINUX based file exchange package that runs on PHP and Zend.  We LOVE this thing but the hardware decided it didn’t want to play any more.  I have replaced the HW with newer, better, stronger (you get the idea) and installed Red Hat Fedora.  This version comes with PHP 5.1.4.  Apparently this version does not have the --with-mysql' option turned on.  I have spent 7 days trying to figure out how to turn it on and recompile PHP with no luck.  

The questions:  Can I just uninstall 5 and go back to 4? OR Is it easier to recompile with the option on and if so, what specific command do I need to put in?

I ran phpinfo.php and this is the configure command:

'./configure' '--build=i386-redhat-linux' '--host=i386-redhat-linux' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--with-mime-magic=/etc/httpd/conf/magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter'

If I am ready the instructions correctly, I need to change ‘--without-mysql' to –with-mysql=/usr/bin/mysql but I do not know whare or how to do this.

Help help help

0
Helixx
Asked:
Helixx
1 Solution
 
Guy Hengel [angelIII / a3]Billing EngineerCommented:
you take this command, and run it in the command line. (of course with the option --with-mysql set instead of --without-mysql)
you only have to ensure that the resource file mysql.o is present also in the inluced lib directory
0
 
hernst42Commented:
If you use Fedore core there must be a package php5-mysql or php-mysql which will bring the support for mysql and php5. after installing that package restart the webserver and check if the mysql-extension is activated automaticly. If not edit the php.ini and add
extension=mysql.so
and restart the webserver again. Now you should habe mysql-support. Many distibutuion create php without an extension, but have many small packages with the extensions.
0
 
HelixxAuthor Commented:
okay.  
Where do I get the php5-mysql or php-mysql or mysql.o?
Do I just put it in the /lib directory?
I have to type everything in the block above starting with ./configure?  !!  (Can't I just do ./configure –with-mysql=/usr/bin/mysql? and the computer will remember the rest?)
Which directory do I do this process in? ./lib? there is no file called configure in /lib.
Is there an RPM command that will downlaod and install this option?

I still have hope!
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
HelixxAuthor Commented:
Anyone?
0
 
HelixxAuthor Commented:
I ended up runing this from the command

yum install yumex

Then under the GUI going to Applications and System Tools and running Yum Extender.
I found the PHP-mysql module and selected it for download.  Yum installed and configured everything for me.
0
 
ygouthamCommented:
normally a simple

yum install php-mysql

should have done the trick.  i had a FC5 and selected php-mysql at install and it worked fine.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now