We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

Debian - Ethernet stuck in half duplex

elmoredaniel
elmoredaniel asked
on
Medium Priority
1,597 Views
Last Modified: 2013-12-16
My eth0 is stuck in half duplex.

When I run:  ethtool -s eth0 duplex full  the console pauses for 10 secs and returns to the prompt, but the nic is still in half duplex. This is a 1Gig full duplex card.

I even added this to the etc/host/interfaces
ETHTOOL_OPTS="autoneg off speed 10 duplex full"

Any ideas?
Comment
Watch Question

Author

Commented:
correction: /etc/network/interfaces
ibu1Senior System Administrator

Commented:

mii-tool -F 100baseTx-FD eth0

Author

Commented:
That did not work for me. No madder what commands I use I can't change the duplex or the speed. Below is the ethtool output.

----------------------------
Settings for eth0:
        Supported ports: [ MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 10Mb/s
        Duplex: Half
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Current message level: 0x000000ff (255)
        Link detected: yes
ibu1Senior System Administrator

Commented:
Most people suggest using the mii-diag (used to be mii-tools, i think, and may still be in Sarge;  just search for "mii-", and then cycle through 'til you find it).

If you go into aptitude and check out the mii-diag package, it suggests several chipset-specific packages that you might want to think about installing.

Here's a more detailed explanation;  Debian instructions are towards the bottom.  The solution as they present it is to write your own script, which is considerably more detailed than the steps you've posted up here so far:

http://www.cyberciti.biz/tips/howto-linux-add-ethtool-duplex-settings-permanent.html

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Okay, the problem occured because autoneg was on, and the switch was broadcasting half duplex. I'll award points for the cyberciti.biz article because it mentioned that.

Thanks everyone.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.