Solved

RPC Server is unavailable

Posted on 2006-11-06
13
29,180 Views
Last Modified: 2013-11-21
We have recently gotten the error message System cannot log you on due to the following error The RPC Server is unavailable. This happens when I try a REMOTE DESKTOP SESSION. This error has just recently occured but I noticed this off and on for probably the past 3 weeks. I never saw it before. 250 Points
0
Comment
Question by:forestincentives
13 Comments
 
LVL 16

Accepted Solution

by:
AdamRobinson earned 64 total points
ID: 17881502
Could a recent patch/update from Microsoft have changed your firewall settings?  

Can you check your services and make sure RPC Server is still activated?

Have you blocked any ports recently on your Firewall?

Did you recently install XP SP2?

0
 

Author Comment

by:forestincentives
ID: 17881587
This is a windows 2003 Server I forgot to mention
0
 
LVL 3

Expert Comment

by:pweegar
ID: 17882078
Log in locally to the server that is having the RPC Service problem. Go into services. Make sure the RPC is running.  If it isn't restart it.  If it is showing that it is running, stop and restart it.
0
 
LVL 3

Assisted Solution

by:DaSpug
DaSpug earned 62 total points
ID: 17882589
Hi,
I've had this before on Terminal Servers running 2003 with dodgy NIC's/Drivers/Cables.

If you've recently updated the driver, roll it back. If it's old and not updated, update it.

If that fails, change the network cable.

If all else fails, you can try changing the NIC.

DaSpug
0
 
LVL 3

Assisted Solution

by:dcsbeemer
dcsbeemer earned 62 total points
ID: 17886822
Having the exact same thing on my side unfortunately...

Personally, I'm gunning for one of these (taken from elsewhere on experts-exchange.com and MS.com):

"If the DNS is not correct, that could also cause the problem.  Here is how to setup your DNS (replace the server names and IPs with your own):

 

DC IPs

server1: 192.168.1.10

server2: 192.168.1.11

 

DNS config:

Server1:  Point DNS to 192.168.1.11 only (second entry blank)

Server2:  Point DNS to 192.168.1.10 only (second entry blank)

All other servers/workstations:  192.168.1.10 primary, 192.168.1.11 secondary

 

 

 

 

just delete the zone in dns and recreate it. this will clear everything out. make sure dynamic updates are enable and the domain controller will add everything it needs back in.

 

then in the dns manager, right click on your server and go to properties. on the forwarders tab add the ip's of your isp dns servers. this way all lookups that are not part of your zone will be forwarded to your isp.

"

"MORE INFORMATION

It may be required to create secondary DNS zones for correct name resolution between several domains or forests. On the Primary DNS server for each domain, create a secondary zone for the domain that you are trying to generate a trust with. For example, create secondary zones that are similar to the following zones:•            Domain1 DC1.Domain1.com - Hosts DNS Primary Zone for Domain1.com

•           Domain2 DC1.Domain2.com - Hosts DNS Primary Zone for Domain2.com

 

These two zones may receive the following message when a trust is generated or validated:

RPC Server is unavailable

To resolve this problem, configure the secondary zones in the following way:•     Domain1 DC1.Domain1.com - Hosts DNS Primary Zone for Domain1.com & Secondary Zone for Domain2.com

•           Domain2 DC1.Domain2.com - Hosts DNS Primary Zone for Domain2.com & Secondary Zone for Domain1.com

 

When DNS name resolution is correctly configured for both domains, communication between the domains functions as you expect.
"


"RESOLUTION

Use either of the following methods to work around this problem:            Back to the top

 

Method 1: Remove the CrashOnAuditFail Value

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

 

Use Registry Editor (Regedt32.exe) to delete the CrashOnAuditFail value from the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\

After you make this change, quit Registry Editor and restart the computer to cause the change to take effect.       Back to the top

 

Method 2: Change the Event Log Settings1.       Start Event Viewer.

2.         On the Log menu, click Log Settings.

3.         In the Settings dialog box, you can either increase the size of the Security log, or change the Log File Wrapping setting to Overwrite events as needed.

            Back to the top

"
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 1

Expert Comment

by:aniesm
ID: 17893190
it is a dns problem. check the dns server ip address on the remote machine and the client machine.
0
 
LVL 4

Assisted Solution

by:asrdias
asrdias earned 62 total points
ID: 17927172
Hello !!!

The RPC Server is unavailable may just be a firewall issue.

Make sure that the 3389 port is available on the server side.
Make sure the remote connections are allowed.

Try connecting to the server by using the ip and not the name. That will put away DNS issues.
If connecting by ip is not working try to ping the server.

ADias
0
 

Expert Comment

by:frsupport
ID: 21718915
hi,


i'm getting this error whilst trying to replicate a Server2k PDC to a new Server2008 SDC. This is a small branch/business.........only ever had one domain controller in operation...now trying to add a second, hitting "replicate" and getting this......

the following error occured during the attempt to contact the domain controllers
"the RPC server is unavailable"

this condition may be caused by a DNS lookup problem


Any help appreciated


0
 

Expert Comment

by:Pattonair_IT
ID: 21826906
To resolve the issue, I went to command prompt and ran ipconfig/flushdns on client machine.  After doing this, I was able to remote into the server using Remote Desktop.
0
 

Expert Comment

by:davidgerber123
ID: 25943613
I was having this same issue.  I could connect to the RD, and it would prompt for a password.  About 20 seconds after putting in the password the RPC server message would appear and close.  Like the solution says, it was simply a DNS issue.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now