Solved

how to disable sound in ica session

Posted on 2006-11-06
13
8,195 Views
Last Modified: 2012-01-19
Hi,

just recently, when a someone logs into an ica session and trys to save a  word doc for example or anything that requires a yes or no response, the system beeps loudly.  Where would you disable this within citrix?  It's really annoying but also strange that happened all of a sudden after 3 years of no sound at all.  Thanks.
0
Comment
Question by:eservando
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
13 Comments
 
LVL 10

Expert Comment

by:chrisnewman01
ID: 17881483
There are 2 ways to do this:

1)  Create a policy (within Citrix Management Console), create a name, disable sound (one of the options within the policy), then click OK.  Once you do this, right-click the policy and select either servers or users you want this policy to apply to.  Since it sounds like you want to do a system-wide option, select the Citrix servers to apply this policy to.

2)  Within the Citrix Connection Configuration tool, double-click the ica-tcp connection, click the "Client Settings" button, then check the "Disable Client Audio Mapping".  NOTE:  This will have to be done on all Citrix servers, that's why a policy-based solution would work better (unless you only have 1 server).  

Chris
0
 

Author Comment

by:eservando
ID: 17886766
Hi,

i tried option 2 since only have one server but it still beeps.  However, i didn't do it from server console, i did it from within ica session.  Would that be the problem?  Does server need reboot after making this change if i do make the change on console tomorrow?  Thanks.
0
 
LVL 10

Expert Comment

by:chrisnewman01
ID: 17889362
Is it a standard workstation beep, or is it the Windows ding (on server or workstation, too)?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:eservando
ID: 17890528
Hi Chris,

was testing this a lot yesterday and this is what i found.  There is no sound card or sound at all in citrix server so beep is definately coming from client audio which is my laptop.  I disabled all references to client audio mapping but still beeps.  I muted volume in my laptop and of course no sound but still wanna find out why client audio cannot be controlled by disabling in citrix connection settings or by creating policy in managment console.  I took quick look in citrix site and saw instances where disabling client audio still creates sound when speed latency option was enabled.  The beep is a loud windows ding.  It's funny how most people in citrix site were trying to get sound to work, whereas i wanna turn it off.  Any suggestions?  I know if i disable client mappings that would keep me from attaching to network drives but really thought disabling client audio would work.  Is there any setting such as "inherit user config" that is overriding the audio setting?  Thanks.
0
 
LVL 10

Expert Comment

by:chrisnewman01
ID: 17892229
Have you also turned it off on the actual published application (in addition to what you've done already)?  It might be worth a shot.  It really shouldn't be making any sounds, since you're turning it off at the system level, but maybe it's a newer Windows or Citrix "enhancement" :-) If you set it at the system level, that overrides the "inherit user config" settings.

Is this Metaframe XP, PS3, or PS4?

http://support.citrix.com/article/CTX110318

Chris
0
 
LVL 5

Accepted Solution

by:
Christophermagee earned 250 total points
ID: 17895764

This is providing you are using Windows 2003

http://support.microsoft.com/default.aspx?scid=kb;en-us;901115

Hope this helps

0
 

Author Comment

by:eservando
ID: 17901757
Hi Chris,

we are using metaframe xp.  I'm not that familiar with published apps but i thought that since this is beeping in non microsoft apps it is a system wide issue.  Just strange that cannot turn this off on client audio setting.  Any other suggestions?  Thanks.
0
 
LVL 5

Expert Comment

by:Christophermagee
ID: 17902138
I meant Windows server 2003.
That fix applies to citrix as well since citrix runs off terminal server.

Regards

Chris
0
 
LVL 10

Expert Comment

by:chrisnewman01
ID: 18350818
Christophermagee's recommendation should resolve the issue.
0
 
LVL 5

Expert Comment

by:Christophermagee
ID: 18355539
You know whats funny, I had the exact same issue. However when i removed the beeping i had a tonne of complaints. *shrug*
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

#Citrix #POC #XenDesktop #vCenter #VMware #ESX
CITRIX XENAPP 6.5 FARM CUSTOM POLICY - CHANGE MANAGEMENT WINDOW REBOOT SCHEDULE
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question