Solved

Arcserve error E1056 Invalid file header when trying to merge a tape

Posted on 2006-11-06
5
1,366 Views
Last Modified: 2007-12-19
We are running Netware 6.5 SP5 and Brightstor Arcserve 11.1 with SP2.  We are trying to get our disaster recovery working correctly.  We have run a backup at our corporate office and then we have sent the tapes to our disaster location.  When we put the tapes in the remote server, we are able to scan the tapes, but when we try to merge the tapes into the database, we receive the error:

"Failed to find catalog file."
"E1056 Invalid file header []  signature=5555aaaa"
"Recover file"

And the merge never merges any information into the Arcserve DB.  I then decided to check and see what happens if I try to merge a tape on our Corporate backup server.  A tape that we backed up at the Corporate server, can not be merged on our Corporate server either.  It kicks back the same error, even though it was the server that originally did the backup.

Anyone have any ideas on how to solve this problem?  Computer Associates had me place this line in my ASCONFIG.INI

"MergeUsingCatFile=False"

That seemed to resolve the header issues, but our Merge took 16 hours for a 200/400 GB LTO Tape.  That can't be right.  I can't believe that a special setting needs to be in the ASCONFIG.INI file in order for me to merge a tape.

Thanks,
Mike
0
Comment
Question by:michreyn
5 Comments
 
LVL 4

Accepted Solution

by:
Nilesh Roy earned 250 total points
ID: 17887653
Hi Mike,

Try this, your path may be a little different but under Base it will be the same.

Open regidt32.exe
Go to HKEY_LOCAL_MACHINE on Local Machine
Open it to
HKEY_LOCAL_MACHINE\SOFTWARE\ComputerAssociates\ARCserveIT\Base\Task
Highlight Task and select Edit Add Key from the menue bar.
Key Name: Merge
Class: <leave blank>
Hightlight Merge and select Edit Add Value
Value Name: DonotUseCatalogMerge
Data Type: REG_DWORD
click OK
Data: 1         *// 1 = Enabled, 0 = Disabled


Let me know if it worked.

Regards,

Nilesh Roy.
0
 

Author Comment

by:michreyn
ID: 17914299
This is running on Netware, but I would think it essentially does the same thing that the entry "MergeUsingCatFile=False" seems to do.  I am beginning to think that there is no Catalog file in Netware.  Can anyone verify that?
0
 
LVL 22

Assisted Solution

by:dovidmichel
dovidmichel earned 250 total points
ID: 17915244
The database information is written to a catalog file, the catalog file is written to tape as the last file in that session. Merge will restore that file and then merge the data in it into the database. That fails so the ini hack forces it to read through the whole session to build the  database information and that is why it is so slow.

The problem could be that either the file header really is invalid or it failed to position the tape to the correct location. In either case you will have to go back to CA support to track that down.

First check out to see if this with all sessions. Does it happen with sessions backed up via an agent, or local backups with no agent, these type of questions will help narrow down the nature of the problem.

What about the DR site, does it have the problem? don't know? so Have them run a small backup and try the merge to see if this problem is universal or server specific.

Also try a backup with Verify Compare enabled.

If you do decide to go back to CA on this, you don't have to open a new issue, just reopen the old one since they gave you a temporary work-around and not a solution. You know India support is all about the #s so they are quick to close issues, and it is not just CA I worked with support from other companies and it is always the same. So reopen the issue and push for it to be escalated state side.
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I provide some information on storage disks which go into calculations that will help you figure out how much Input/output Operations Per Second (IOPS) your disk subsystem can deliver. To effectively size & tune up applications l…
Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question