• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 163
  • Last Modified:

Windows 2000 server stuck on saving setting -- functions: DC/GC/File/Print

Hi All,

My server all of a sudden not able to move around. It got lock up. I manage try to log off windows but then it got stuck on saving setting. I don't want to cold boot it because it is my DC/GC/File/Print server.  Nothing was install recently. The only thing i can think of is doing a prep for a windows 2003 to become a DC.  But that was last week. Everything else is functionig fine. Users are still able to access their file and print.  I don't want to cold be if necessary. Any help will be much appreciated..

JL
0
jli168
Asked:
jli168
  • 2
1 Solution
 
plimpiasCommented:
Go to another computer, log in as admin.

Right click my computer go to manage
Right click the top and hit connect to another computer
Connect to the server
Righ click the top again and hit properties
Goto the advance tab
Hit start up and recovery
Hit shutdown
Hit reboot and force shutdown
0
 
ibu1Commented:
There are several registry settings that can be changed to decrease shutdown time.

1. End services faster when shutting down. Saves alot of time.
-Open regedit by typing "regedit" in the run box located on the start menu.
-Browse to “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control”
-Right click on the string value “WaitToKillServiceTimeout”
-Select modify and change the value to “1000”

2. Give windows the ability to automatically close non-responding apps.
-Open regedit
-Browse to “HKEY_CURRENT_USER\Control Panel\Desktop”
-Right click on the string value “AutoEndTasks”
-Select modify and change the value to “1”

3. Reduce the timeout for windows to discover a non-responding application.
-Open regedit
-Browse to “HKEY_CURRENT_USER\Control Panel\Desktop”
-Right click on the string value “HungAppTimeout”
-Select modify and change the value to “1000”
-Browse to “HKEY_USERS\.DEFAULT\Control Panel\Desktop”
-Right click on the string value “HungAppTimeout”
-Select modify and change the value to “1000”

4. Reduce the delay to close non-responding applications and speed up the closing on apps at shutdown.
-Open regedit
-Browse to “HKEY_CURRENT_USER\Control Panel\Desktop”
-Right click on the string value “WaitToKillAppTimeout”
-Select modify and change the value to “1000”
-Browse to “HKEY_USERS\.DEFAULT\Control Panel\Desktop”
-Right click on the string value “WaitToKillAppTimeout”
-Select modify and change the value to “1000”


You could also try disabling the "Nvidia Driver Helper" service if using a nvidia card.
- Go to the run box and type "services.msc"
- Select "Nvidia driver helper"
- Right click and press stop.
- Go to properties of Nvidia Driver helper and change the startup type to "disabled"


You "should" now see a marked improvement in shutdown speed.
0
 
jli168Author Commented:
Hi guys,

My server is still stuck on saving setting. It's more then 24 hours.  I'll try to force the shutdown as plimpias say.

- ibu1
I will modify registry once i have ability to change them. When i connect to the computer i can't pull the event or services up. It hung when i try to pull them. I was able to put the registry of it from another computer but it's does not have current user.
0
 
ibu1Commented:
Go to safe mode and try to change registry.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now