Solved

Website only shows up as text in Safari

Posted on 2006-11-06
16
284 Views
Last Modified: 2006-11-18
I am not a web developer and I did not create the site but I have a client that is having a problem.

In IE the site shows up fine.  When it is opened in Safari the site only show up as plain text (I am told).

http://www.diegoandson.com

Any ideas?

Thanks,

Phil
0
Comment
Question by:pricep
  • 6
  • 6
  • 3
  • +1
16 Comments
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 17885912
pricep,

What text do they see?  Do they get forwarded on to the diegoandsonprinting domain or does the address stay there?  Do they have shockwave and flash installed?  I'm not an expert on Safari but these are some general things to start with.

Let me know if you have any questions or need more information.

b0lsc0tt
0
 

Author Comment

by:pricep
ID: 17885941
I will have to check and get back to you.  I don't have Safari on any of my computers...
0
 
LVL 3

Expert Comment

by:rixlabs
ID: 17886238
In Firefox too there are some problem

I can't see the real content but I see the code
0
 
LVL 21

Expert Comment

by:jvuz
ID: 17887531
I don't see the starting body tag.
0
 
LVL 3

Expert Comment

by:rixlabs
ID: 17888146
The body tag is included by this row:
<!--#include virtual="/includes/body.incl"-->

0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 17891047
@Rixlabs - You may be having the same problem Pricep's client reported then because the site works for me in IE and FF.  When you use the link what is the URL or address that you end up at?  What is the text or content you see?  Do you have flash and shockwave installed?

I end up at http://www.diegoandsonprinting.com/.  I do see the a page that is mainly a shockwave file.  The HTML source looks good basically although FF is in quirks mode.  It does include a body tag though.  I definitely don't see anything that shows include files and it isn't normal for those to be seen.

bol
0
 
LVL 3

Expert Comment

by:rixlabs
ID: 17891172
my problem is inside the contents of the site, if I go here -> http://www.diegoandsonprinting.com/services.shtml
I don't see the real content of the page but I see the code
0
 
LVL 54

Accepted Solution

by:
b0lsc0tt earned 250 total points
ID: 17891257
@Rixlabs - Did you have a problem with the main page I just provided a link to?

@Pricep - It looks like your webserver isn't correctly supporting the SSIs (server side includes).  Although IE does seem to compensate for missing tags, etc and display a page it seems like it isn't completely correct.  FF does display it just as text and there are some serious validation errors (i.e. missing body tag, etc).  This is on the page the Rixlabs just provided a link to but may very well be the issue your client saw.  I would start by making sure that SSI are working good.  The web page does end with shtml but if the server isn't set up correct then just that extension won't be enough.  Let us know if you have any questions.
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 3

Expert Comment

by:rixlabs
ID: 17891276
no the main page with the flash movie work good... all the other page return me the shtml code
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 17891332
@Rixlabs - Thanks for the information.  I think it will be very useful to Pricep.  We'll have to wait for  his response.

bol
0
 
LVL 3

Expert Comment

by:rixlabs
ID: 17891359
you too have this problem????
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 17891434
@Rixlabs - Yes, in FF.  I didn't go into subpages on the site though and never saw it until you provided the link.  The main page works fine for me even in FF.  It may still be some issue in Safari on that main page but I think the issue is the one you pointed out.  The client just wasn't specific enough.  We'll see when Phil (Pricep) replies.
0
 
LVL 3

Expert Comment

by:rixlabs
ID: 17891493
@b0lsc0tt:
I downladed the code of the ->http://www.diegoandsonprinting.com/services.shtml page and i set the extension to .html

The page work fine but obviously the inclusions dont works
0
 

Author Comment

by:pricep
ID: 17892844
I need to take a look at it this evening.  I'll take a look at the SSI and ask the client if the subpages work OK.

I have a regular day and can't really take a good look at this other part time consulting work during most of the day...
0
 

Author Comment

by:pricep
ID: 17908968
Thanks b0lsc0tt!

I set up the website in a test environment and did some tweaking with the SSI and it seems to be working just fine (on my test server).  I have some additional changes to make before I publish it live but thanks for your assistance!

R/Phil
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 17909621
Your welcome!  I'm glad that I could help.  Rixlabs was helpful in this too.  Thank you for the grade, the points and the fun question.

bol
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

How many times have you been browsing the internet, with multiple tabs open, and closed the wrong one? Have you ever clicked 'Close all tabs' instead of 'Close current tab' ? Internet Explorer 8 now brings to you, what Firefox has had for a wh…
Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now