Solved

Website only shows up as text in Safari

Posted on 2006-11-06
16
283 Views
Last Modified: 2006-11-18
I am not a web developer and I did not create the site but I have a client that is having a problem.

In IE the site shows up fine.  When it is opened in Safari the site only show up as plain text (I am told).

http://www.diegoandson.com

Any ideas?

Thanks,

Phil
0
Comment
Question by:pricep
  • 6
  • 6
  • 3
  • +1
16 Comments
 
LVL 54

Expert Comment

by:b0lsc0tt
Comment Utility
pricep,

What text do they see?  Do they get forwarded on to the diegoandsonprinting domain or does the address stay there?  Do they have shockwave and flash installed?  I'm not an expert on Safari but these are some general things to start with.

Let me know if you have any questions or need more information.

b0lsc0tt
0
 

Author Comment

by:pricep
Comment Utility
I will have to check and get back to you.  I don't have Safari on any of my computers...
0
 
LVL 3

Expert Comment

by:rixlabs
Comment Utility
In Firefox too there are some problem

I can't see the real content but I see the code
0
 
LVL 21

Expert Comment

by:jvuz
Comment Utility
I don't see the starting body tag.
0
 
LVL 3

Expert Comment

by:rixlabs
Comment Utility
The body tag is included by this row:
<!--#include virtual="/includes/body.incl"-->

0
 
LVL 54

Expert Comment

by:b0lsc0tt
Comment Utility
@Rixlabs - You may be having the same problem Pricep's client reported then because the site works for me in IE and FF.  When you use the link what is the URL or address that you end up at?  What is the text or content you see?  Do you have flash and shockwave installed?

I end up at http://www.diegoandsonprinting.com/.  I do see the a page that is mainly a shockwave file.  The HTML source looks good basically although FF is in quirks mode.  It does include a body tag though.  I definitely don't see anything that shows include files and it isn't normal for those to be seen.

bol
0
 
LVL 3

Expert Comment

by:rixlabs
Comment Utility
my problem is inside the contents of the site, if I go here -> http://www.diegoandsonprinting.com/services.shtml
I don't see the real content of the page but I see the code
0
 
LVL 54

Accepted Solution

by:
b0lsc0tt earned 250 total points
Comment Utility
@Rixlabs - Did you have a problem with the main page I just provided a link to?

@Pricep - It looks like your webserver isn't correctly supporting the SSIs (server side includes).  Although IE does seem to compensate for missing tags, etc and display a page it seems like it isn't completely correct.  FF does display it just as text and there are some serious validation errors (i.e. missing body tag, etc).  This is on the page the Rixlabs just provided a link to but may very well be the issue your client saw.  I would start by making sure that SSI are working good.  The web page does end with shtml but if the server isn't set up correct then just that extension won't be enough.  Let us know if you have any questions.
0
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

 
LVL 3

Expert Comment

by:rixlabs
Comment Utility
no the main page with the flash movie work good... all the other page return me the shtml code
0
 
LVL 54

Expert Comment

by:b0lsc0tt
Comment Utility
@Rixlabs - Thanks for the information.  I think it will be very useful to Pricep.  We'll have to wait for  his response.

bol
0
 
LVL 3

Expert Comment

by:rixlabs
Comment Utility
you too have this problem????
0
 
LVL 54

Expert Comment

by:b0lsc0tt
Comment Utility
@Rixlabs - Yes, in FF.  I didn't go into subpages on the site though and never saw it until you provided the link.  The main page works fine for me even in FF.  It may still be some issue in Safari on that main page but I think the issue is the one you pointed out.  The client just wasn't specific enough.  We'll see when Phil (Pricep) replies.
0
 
LVL 3

Expert Comment

by:rixlabs
Comment Utility
@b0lsc0tt:
I downladed the code of the ->http://www.diegoandsonprinting.com/services.shtml page and i set the extension to .html

The page work fine but obviously the inclusions dont works
0
 

Author Comment

by:pricep
Comment Utility
I need to take a look at it this evening.  I'll take a look at the SSI and ask the client if the subpages work OK.

I have a regular day and can't really take a good look at this other part time consulting work during most of the day...
0
 

Author Comment

by:pricep
Comment Utility
Thanks b0lsc0tt!

I set up the website in a test environment and did some tweaking with the SSI and it seems to be working just fine (on my test server).  I have some additional changes to make before I publish it live but thanks for your assistance!

R/Phil
0
 
LVL 54

Expert Comment

by:b0lsc0tt
Comment Utility
Your welcome!  I'm glad that I could help.  Rixlabs was helpful in this too.  Thank you for the grade, the points and the fun question.

bol
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Due to recent concerns over the inevitable depletion of the current pool of IPv4 addresses and the desire to provide additional functionality for modern devices, an upgrade to IPv6 on my Internet connection was needed for me to explore the world of …
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now