Solved

VB6 with crystal report 10 - report does not display

Posted on 2006-11-06
6
749 Views
Last Modified: 2008-02-01
have a crystal 8.5 rpt converted to crystal 10.  We call the crystal 10 .rpt file in the vb application.   Run  the vb app which will create the report in crystal 10 and preview on our machine (which has crystal 10 and vb loaded loacally).  
Report runs fine with no errors and data.

Our problem is that when we use the vb package and deployment wizard to deploy this app to a different machine (that does not have crystal loaded)  the report will not preview on the screen.  No errors just no report.
0
Comment
Question by:jroesch
  • 3
  • 2
6 Comments
 
LVL 17

Expert Comment

by:MIKE
ID: 17886831
You need to have the correct drivers loaded. Are all programs updated with correct drivers?

MikeV
0
 

Author Comment

by:jroesch
ID: 17890196
I'm not sure.  Are you referring to the printer drivers?  

I believe we've loaded all of the necessary DLLs with the package.  CRAXDRT.DLL, CRVIEWER.DLL, CRQUE.DLL etc.  When we upgraded from Crystal 8.5 to 10 we had to change the Crystal viewer, we changed the reference and component from 8.5 to 10 and it worked on one computer.

The computer we deployed the package to is running a different OS - Windows 2003 Server.  Previously this program was loaded on Windows 2000 Server.  
0
 
LVL 100

Accepted Solution

by:
mlmcc earned 500 total points
ID: 17969966
Did you use the merge modules to help deploy the Crystal dlls?

Check this article
http://support.businessobjects.com/communityCS/TechnicalPapers/rdc10_deployment.pdf.asp

mlmcc
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 

Author Comment

by:jroesch
ID: 17990132
thx mlmcc.

I converted my rpt from crystal 8.5 to 10.  I then included the new cr10 viewer and saved the report in cr10.  The rpt was wrapped around a vb6 program.    I then used the vb6 package and deploy wizard to deploy.  When lauching the .exe, I received the error that crqe.dll could not be registered.   I then created an .msi package using the merge modules and there i included the crqe.dll.   I then launched the .msi and it worked correctly.    There was a snafu earlier when no report would display but that was because I included the wrong version of the .rpt in the vb6 package.   Once that was corrected and the crqe.dll finally registered, it worked succesfully.

I was unsuccessful manually registering the dll's in cr10.   Something that cr8 allowed me to do.   Live and learn
thanks for the info.

0
 

Author Comment

by:jroesch
ID: 18030951
The problem was actually a picnic - problem in chair not in computer
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 18032491
Glad i could help.  Try a new chair to get rid of the problem with the chair ;>)))

mlmcc
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I hate sub reports and always consider them the last resort in any reporting solution.  The negative effect on performance and maintainability is just not worth the easy ride they give the report writer.  Nine times out of ten reporting requirements…
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question