Solved

Installing VNC

Posted on 2006-11-07
20
3,601 Views
Last Modified: 2013-12-06
I'm installing VNC on a Fedora Core 4 server. When installing I get the following error:

error: Failed dependencies:
        libstdc++-libc6.2-2.so.3 is needed by vnc-3.3.6-2.i386

I've downloaded an RPM for the library, but when i come to install it the system just repeats:

warning: user ldv does not exist - using root

then after a few seconds, it stops and returns to the command line, when I try to install VNC again, I still get the failed dependencies error, so I'm assuming the library needs something else so that it can install. I'm a PHP developer, but unfortunately have never had to deal with Linux, now I'm finally learning, but struggling. Any help would be appreciated.

Thanks,
Ross
0
Comment
Question by:Rozwaldeo
  • 10
  • 10
20 Comments
 
LVL 1

Expert Comment

by:devnull22
ID: 17889136
I unfortunately don't have an install of fedora core 4 up and running, but I'm pretty sure vnc should be in the yum repositories.

yum is a tool with which you can easily update the software on fedora, and install or remove software.

Try this line, while logged on as root:

yum install vnc-server

This should install vnc server version 4, and every dependency it might have. It might take a while as yum will first need to update itself, and then will proceed with the install.

Hope this helps!
0
 

Author Comment

by:Rozwaldeo
ID: 17889243
Hi devnull,

thanks for the quick reply! That seems to have worked!

I've typed vncserver at the prompt, but now get this message:

vncserver: couldn't find "xauth" on your PATH.

do I have to edit some config files?
0
 
LVL 1

Expert Comment

by:devnull22
ID: 17889993
Try doing a similar line:

yum install xorg-x11-xauth

And see if it installs that package, then try again. It would seem your install did not have that package, and it's necessary for vnc to spawn a x11 session (graphical session)
0
 

Author Comment

by:Rozwaldeo
ID: 17890140
That's now installed, I've run vncserver and it's created a new desktop, but when I connect I get a connection refused error (10061). There isn't a firewall on the machine, could anything else cause this?
0
 
LVL 1

Expert Comment

by:devnull22
ID: 17890245
when it created a new desktop, did it state something like :Creating a new desktop on host:1"?

the :1 means the port vnc listens on, by default in your vncviewer, if you use just your host name or ip address, it will connect on :0 (or port 5900) try putting in your ipaddress in vncviewer along with :1 like this:

1.2.3.4:1

Tell me if it works!
0
 

Author Comment

by:Rozwaldeo
ID: 17890331
I tried the IP Address and host name and still get the same error, the port is no.1

Thanks
0
 
LVL 1

Expert Comment

by:devnull22
ID: 17890398
when vncserver runs, it usually prints info like this:

user@machine:~$ vncserver

New 'machine:1 (user)' desktop is machine:1

Starting applications specified in /home/user/.vnc/xstartup
Log file is /home/user/.vnc/machine:1.log

can you do a:
cat /home/user/.vnc/machine:1.log

and paste here the last few lines?
0
 

Author Comment

by:Rozwaldeo
ID: 17896402
It's coming back with this:

-bash: cd: /user: No such file or directory
0
 

Author Comment

by:Rozwaldeo
ID: 17896414
sorry, my mistake, typed it incorrectly.

Heres what it says:

Wed Nov  8 09:10:16 2006
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
 vncext:      Listening for HTTP connections on port 5801
 vncext:      created VNC server for screen 0
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/75dpi/, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!

Fatal server error:
could not open default font 'fixed'
/root/.vnc/xstartup: line 9: xsetroot: command not found
/root/.vnc/xstartup: line 11: xterm: command not found
/root/.vnc/xstartup: line 12: twm: command not found
vncconfig: unable to open display "s15211463.onlinehome-server.info:1"
[root@s15211463 home]#

Thanks again for this Devnull, sorry it's taking so long!
0
 
LVL 1

Expert Comment

by:devnull22
ID: 17897791
Do you know if this server has X installed? It's starting to look as if no gui is installed at all, since xauth wasn't present, and it's now trying to execute other usual commands which are not installed, like xterm and twm.

If you can confirm to me if a graphical session is installed, we can fix this, but it's a whole other problem ;-) I'll need to find out how to install X and at least gnome, and modify the vnc startup file so it launches it, which shouldn't be too hard.

Let me find out how to install x11 and gnome and confirm if it was installed as a server, and the graphical environment isnt installed. We'll go from there.
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 1

Expert Comment

by:devnull22
ID: 17897871
Okay, this looks to be easier than I thought, but remember, I can't test it since I don't have a fedora core 4 install available that I can try this part.

yum install nautilus gedit gdm gnome-panel gnome-session

This should install all gnome components, and x components that are missing.

After that, you'll need to edit the /root/.vnc/xstartup that you saw in the log above, this is the file that tells vnc what to launch, basically, you can remove evrything in there, and just keep:

gnome-session &

Which will launch gnome once you launch vnc. Can you try that and tell me how that goes? If not, paste the log like you did again.

This is a bit like installing windows over dos to be able to get a graphical remote desktop session, so it's a bit normal that we have to go over hurdles, since your server seems to have been installed without any graphical components.

0
 

Author Comment

by:Rozwaldeo
ID: 17898016
Thanks Devnull, I'll try all that now, and get back to you :)
0
 

Author Comment

by:Rozwaldeo
ID: 17898069
I started the yum process, it's download 104 items out of 104 but says this on the last line:

warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID db42a60e


Public key for xml-common-0.6.3-17.noarch.rpm is not installed
0
 
LVL 1

Expert Comment

by:devnull22
ID: 17898290
Try this next, and rerun the yum command:

rpm --import /etc/pki/rpm-gpg/RPM*

if it's anything like the fedora core 5 install I use as a reference, it could solve the no key error. Re-run the yum command, and if it goes well, modify the xstartup and try launching vnc again.
0
 

Author Comment

by:Rozwaldeo
ID: 17898578
everything seems to have worked, but I'm now getting this error in the log file:

 Connections: accepted: 80.177.96.253::56181
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VncAuth(2)

Does that just mean I have to download the latest VNC viewer?
0
 
LVL 1

Expert Comment

by:devnull22
ID: 17898640
yep, just download it from realvnc.com and get the 4.1 client, it should work.

you can download just the client as an exe, no install needed.
0
 

Author Comment

by:Rozwaldeo
ID: 17898740
It now says:

 SConnection: AuthFailureException: Authentication failure
 Connections: closed: 80.177.96.253::56609 (Authentication failure)

I've tried it using the root password and using no password
0
 
LVL 1

Accepted Solution

by:
devnull22 earned 500 total points
ID: 17899128
does the vncclient ask you for a password?

Did the vncserver first ask you a password when you started it the first time?

If so it's that password you need to put in, if not, we'll need to set one up like this:

vncpasswd ~/.vnc/passwd

It'll ask you to type and retype your passowrd, then use a vncserver -kill :1 to kill your current vncserver session, then relaunch it, vncserver -geometry 1024x768

this will launch it in a 1024x768 session, adjust to your liking!

0
 

Author Comment

by:Rozwaldeo
ID: 17899581
Thanks Devnull! All is working fine now!

Thanks for your patience aswell!
0
 
LVL 1

Expert Comment

by:devnull22
ID: 17900566
No problem, glad I could help! Linux is a tricky business, but once you get used to it, it becomes as easy as fixing other windows problems. ;-)
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now