We help IT Professionals succeed at work.

You do not have sufficient acces to your computer to connect to this printer

miloudi
miloudi asked
on
Medium Priority
4,475 Views
Last Modified: 2008-01-09
I have a Windows 2003 domain and for some reason now i am getting this error above for newly created users :
you do not have sufficient access to your computer to connect to the selected printer
In other words, nobody can add a shared printer unless they are adminof their PCS.
sppol folder hsa RR and execute rights.
What do you guys think..?
Comment
Watch Question

Windows XP Users Must Be a Member of Local Administrator Group
Microsoft added significant local security to Windows XP.  A user with minimal rights does not have access to write files to the "C" drive or to re-direct printing to shared network printers, both of which are required for RDP software to function properly.  To solve this problem, each user of a Windows 2000 or XP workstation must be a member of the administrator group on the workstation, which gives the user complete access and all rights for the local workstation.  Please note that network security is not compromised, since the user must only be a member of the local administrator group on Windows XP workstations.  All RDP users should not be a member of the domain administrator group.  To add a user to the local administrator group, see the link below:

Windows 2000/XP Users Must Be a Member of Local Administrator Group.

Commented:
Try group policy settings, in both Computer Configuration and User Configuration go to Administrative Templates/Windows Components/Windows Installer and change the "Always install with elevated prifileges" to enabled.

To get to the GP editor, go to Start, Run, gpedit.msc.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
marine 7275,

You want your users to have local admin rights...
I don't think you should advise me to do that....
roorks,
Windows Installer(options are not enabled)

Any other ideas....?
Thanks

Commented:
Double click on the policy and it should give you a choice.  Must be done in both Computer and User configurations.

Author

Commented:
by default
prevent users from installing printers drivers is enabled.
disabled that
gpupdate did the trick.

Commented:
I was working with Windows 2003 R2 Terminal Server and several users were having the same issue trying to install a printer getting the "You do not have sufficient acces to your computer to connect to this printer".  I found that since the printer itself was not installed on the terminal server they did not have "access" to install the drivers from the terminal session.

The quick fix was to install the printer first on terminal server then allow the users to install said printer, and presto done in a flash. This of course ensuring that I had already disabled "Prevent users from installing printer drivers" in the Local Security Policy and have added Domain Users to "Load and unload device drivers".

Hope this helps.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.