Solved

Clusterware installation problem

Posted on 2006-11-07
13
6,848 Views
Last Modified: 2007-12-19
I am installing clusterware 10gR2 on linux.
at the end of the installation it ask me to run orainstRoot.sh and Root.sh.
orainstRoot.sh OK on both nodes
but root.sh is generating following error,
Failed to upgrade Oracle Cluster Registry configuration.
after that when I check the configToolFailedCommands i found three failed command there.
one is Ok, but other two are generation error,
the command is:
oifcfg setif -global  eth1/192.168.155.0:cluster_interconnect eth2/10.201.60.0:public
result:
PRIF-12: failed to initialize cluster support services
other command
./cluvfy stage -post crsinst -n richxraccn01,richxraccn02
result:
Checking CRS integrity...

Checking daemon liveness...
Liveness check failed for "CRS daemon".
Check failed on nodes:
        richxraccn02,richxraccn01

Checking daemon liveness...
Liveness check failed for "CSS daemon".
Check failed on nodes:
        richxraccn02,richxraccn01

Checking daemon liveness...
Liveness check failed for "EVM daemon".
Check failed on nodes:
        richxraccn02,richxraccn01

CRS integrity check failed.

Thanks,
Abdul Nisar
0
Comment
Question by:anisar
  • 8
  • 4
13 Comments
 
LVL 13

Expert Comment

by:anand_2000v
ID: 17899014
Check your Host file ,copy and paste you host file here


/etc/host
0
 
LVL 13

Expert Comment

by:anand_2000v
ID: 17899021
Hav you tried pinging all the ips available in the host file with the other nodes ??

0
 

Author Comment

by:anisar
ID: 17900326
Thank you Anand for reply, the etc/hosts entries are given bellow,

[oracle@richxraccn01 ~]$ cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               localhost.localdomain localhost
10.201.60.186           richxraccn01 richxraccn01.cavalier.com
10.201.60.187           richxraccn02 richxraccn02.cavalier.com
192.168.155.1           richxraccn01-priv richxraccn01-priv.cavalier.com
192.168.155.2           richxraccn02-priv richxraccn02-priv.cavalier.com
10.201.60.188           richxracvn01 richxracvn01.cavalier.com
10.201.60.189           richxracvn02 richxracvn02.cavalier.com
10.1.0.155              richxutil01 richxutil01.cavalier.com

when i ping from richxraccn01 to richxracvn02 and from richxraccn02 to richxracvn01 i got the following error message
 Destination Host Unreachable
but others are OK,

Thanks,
Abdul Nisar
0
 

Expert Comment

by:nmgzw
ID: 17904713
you can try it like below: 10.201.60.188/189 is your really host ip address,and other two ,one is virtual ip ,one is private ip!note:virtual ip address must not configure it manually.

10.201.60.186           richxraccn01_vip  
10.201.60.187           richxraccn02_vip  
192.168.155.1           richxraccn01_priv
192.168.155.2           richxraccn02_priv
10.201.60.188           richxracvn01 richxracvn01.cavalier.com
10.201.60.189           richxracvn02 richxracvn02.cavalier.com
0
 
LVL 13

Expert Comment

by:anand_2000v
ID: 17905135
yes try out what  nmgzw said.

Check your user equivalence and also time synchronice btw the two server.


 You should ping both ip address and also host name wise.
ex :

from node 1 :
 ssh richxraccn01_vip aslo ssh node1 virtual-ipaddress
 ssh richxraccn02_vip also ssh node2 virutal-ipaddress
 ssh richxracvn01 richxracvn01.cavalier.com also ssh ipaddress
 ssh richxracvn01 richxracvn02.cavalier.com also ssh ipaddress


 check this generate key,see to that oracle user can able to log on same node and other node it should log on without the passwd.

0
 
LVL 13

Expert Comment

by:anand_2000v
ID: 17905152
it shud ping even without the domain name
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:anisar
ID: 17906081
Thanks for reply,
10.201.60.188/189 are vip address, I am not able to connect by ssh from my desktop by these IPs,
but I am able to connect by Public ips and names,
that are 10.201.60.186/187

Thanks,
Abdul Nisar
0
 
LVL 13

Expert Comment

by:anand_2000v
ID: 17912262
vip ip should ping self and also with each other nodes.so that  your root.sh will run the vipca succesfullly during the database software installation.
0
 
LVL 13

Expert Comment

by:anand_2000v
ID: 17912309
Clean up the prior installation you did before you start with the new installation.

 Refer the below metalink document id for cleaning it : Doc ID: Note:239998.1
0
 

Author Comment

by:anisar
ID: 17917336
Thank you anand,
i followed the Doc ID: Note:239998.1 on your recomendation and I am able to run the root.sh script.
now CRS daemon, CSS daemon and EVM daemon are running, but set agian stop, and when i run the cluvfy post command then I got the following error,
ERROR:
OCR ID is inconsistent amongst the nodes.
Possibly different devices are in use across the nodes.

        OCR ID = "1415643988" found for nodes: richxraccn02
        OCR ID = "232714081" found for nodes: richxraccn01

Checking CRS health...
CRS health check failed.
Check failed on nodes:
        richxraccn02,richxraccn01
and when I run the VIPCA then i got the following error,
PRKR-1062 : Failed to find configuration for node richxraccn01
PRKR-1062 : Failed to find configuration for node richxraccn01


0
 
LVL 13

Expert Comment

by:anand_2000v
ID: 17921770
May i knw wheather you created the oracle user in the second node depending on the first node group and user id.

go throught the oracle note id :B10766-02 .Check with this notes and let me know wheather you followed all the pre installation steps.


 
0
 
LVL 13

Accepted Solution

by:
anand_2000v earned 500 total points
ID: 17924236
even if vip is not there,root.sh will run properly when you run it during database software installation.

Have you verified by issuing  crs_stat ( status) command when you installed crs software .Once when you install crs software you should run crs_stat and verify wheather any resources register with it,it should show no resources regsitered because you didnt install the database softtware.then after that start installating the database software when you run root.sh script you will be able to see root.sh running then finish running it in both the node and if you are creating a started database do it.once after you finish all the installation.check with crs_stat you will able to find the all the instance,vip,and all the sources registered with crs_stat
0
 

Author Comment

by:anisar
ID: 18019140
yes,
you are right, root.sh is not depend on vip, after analyzing the whole system I found that ' on restart the nodes firewall was turning ON on both nodes. that's why CRS-daemon, EVM-daemon and CSS-daemon was not starting on other nodes.
the I used the following commands to check and turn off the firewall.

Check Linux firewall configuration for IP routing using the command:
# iptables –L
If IP firewall routing is enabled, manually turn it off using the command:
# /etc/init.d/iptables stop
To ensure it will not start again on server reboot, use the command:
# chkconfig iptables off

Now the clusterware is installed successfully and working very well.
Thank you anand
your help is really appriciated.

 
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Join & Write a Comment

This article started out as an Experts-Exchange question, which then grew into a quick tip to go along with an IOUG presentation for the Collaborate confernce and then later grew again into a full blown article with expanded functionality and legacy…
Truncate is a DDL Command where as Delete is a DML Command. Both will delete data from table, but what is the difference between these below statements truncate table <table_name> ?? delete from <table_name> ?? The first command cannot be …
Via a live example, show how to take different types of Oracle backups using RMAN.
This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now