Solved

proftp problem

Posted on 2006-11-07
4
231 Views
Last Modified: 2013-11-13
I installed the proftp rpm on fedora 5. When I log in as a user using ftp, none of my files show. if I do a pwd I get / which is not my home directory. How to fix this?
0
Comment
Question by:gharnett
4 Comments
 
LVL 14

Accepted Solution

by:
ppfoong earned 100 total points
ID: 17895407

Edit the file /etc/proftpd.conf and restart the proftpd daemon.

Add the line:

DefaultRoot                     ~


and the default directory after login will become the user's home directory.

Also, double check the home directory of the user inside /etc/passwd to make sure it goes to the correct place.

0
 
LVL 3

Assisted Solution

by:bryanlloydharris
bryanlloydharris earned 100 total points
ID: 17909289
maybe that is a new user who has no files yet?  or possibly all the files are hidden files which start with a dot?
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't know how to downgrade, my instructions below should be helpful.
Fine Tune your automatic Updates for Ubuntu / Debian
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question