Solved

... device eth0 does not seem to be present, delaying initialization...

Posted on 2006-11-07
37
10,173 Views
Last Modified: 2008-01-09
Linux Redhat : Enterprise Linux Desktop Release 4  {cat /etc/redhat-release}
2.6.9-5.EL {uname -r}

Have tried 3 different network cards, working backwards in time to older cards, currently using a Dlink DE-530+.  

Upon system startup, and in logs, network device does not seem to intialize.  Device is in the "tulip" module family.
I can see the details of the network card in the Network DeviceControl configuraiton, but it shows as  inactive.  
The device is correctly picked up, as a   lspci -v shows the network card parameters clearly.  

lsmod lists the tulip module as loaded, but with 0 devices using it.

We have a static ip reserved for the machine, but have also tried dchp configuration, and a lot of rebooting, but it always during boot loading tosses a failure at this step.

Need some experts to help with the troubleshooting checklist at this point, I could keep searching for a week without knowing what order to test things in, but figure I got this far, showing that the module is correct and loaded!

Thanks in advance
0
Comment
Question by:GPrentice00
  • 20
  • 8
  • 3
  • +4
37 Comments
 
LVL 12

Expert Comment

by:ibu1
Comment Utility
Is this entry there in the /etc/mdoules.conf
alias eth0 via-rhine
0
 
LVL 5

Expert Comment

by:kyle_in_taiwan
Comment Utility
Hrm.  Very strange.

* Three different used cards, or new ones?
* Firewall settings in iptables?
* Improperly configured device permissions?

Also, try:

$ grep eth0 /var/log/{dmesg,syslog,messages}

and see if there are any helpful error messagse being generated.

Also:

What message gets returned with:

$ ifconfig eth0 up?

 
0
 
LVL 43

Expert Comment

by:ravenpl
Comment Utility
> lsmod lists the tulip module as loaded, but with 0 devices using it.
It means that the module does not supports any card that is on the system.
> Linux Redhat : Enterprise Linux Desktop Release 4  {cat /etc/redhat-release}
Have You tried upgrading to v 4.4 ?

also, please do 'lspci' and show as the output for the netcard - maybe You trying to use wrong driver ?
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
ubu1: There is no file /modules.conf   assuming that is what you meant
assuming a step FURTHEr that you are referring to the MODPROBE.CONF  file...  it is

alias eth0 tulip

===

kyle "helpful error messages" is of course a relative term...
First, the ifconfig eth0 up returns:
eth0: unknown interface: No such device


looking strictly at entries from the last bootingup session, rather than me typing out everything from the past couple days...

/var/log/messages: (datetime) localhost ifup: tulip device eth0 does not seem to be present, delaying initialization
/var/log/messages: (datetime) localhose network: bringing up intreface eth0: failed

thats it - two entries


----
Pertanent lspci outputs

lspci -v output:
00:07.0 Ethernet controller: Digital Equipment Corporation DECchip 21041 [Tulip Pass 3] (rev 21)
Subsystem: D-Link System DE-530+
Flags: Busmaster, medium devsel, latency 64, IRQ 10
i/o ports at d400 [size=128]
memory at dfffbf80 (32-bit, nonprefetchable) [size=128]
Expansion Rob at dff80000 [disabled] [size=256k]

lspci -n output:

00:07.0 class 0200: 1011:0014 (rev 21)

=====
At this time, upgrading is not an option being considered for other limiting reasons.  We are trying to replicate an exact same kernal setup that is located on another machine running some software very specifically tailored for that version, and though backwards compatibility should be a theoretical no-brainer, I'd like to hold off on that for the moment.


0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
>> Three different used cards, or new ones?
used, proven working in different machines, with windows; one was in a system we did an earlier test ubuntu install on.

* Firewall settings in iptables?
>> we never set one up yet, and I dont know about iptables where to look etc, but a google search suggested to me to check if it was running with:
service iptables status
in which case, it comes back as:
Firewall is stopped.

>>* Improperly configured device permissions?

Money is on something being improperly configured, device permissions?  How to check, where to check, what to check?

0
 
LVL 43

Expert Comment

by:ravenpl
Comment Utility
the card You have is served by de2104x module.
try: modprobe de2104x
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
thats getting somewhere :)
I executed the command after booting the system up, it didnt display anything.  But, it allowed me to go to the network configuration and select "activate" the device.
It tossed a few error messages about lost packets and not enabling the device after trying to activate it for about 45s, it may have something to do with my network settings, but its further than ever gotten before - not instantaneously crapping out due to not being present....

Will my configurations now be permanently set to use this module?  Is there additional things to do after (if) it is confirmed to be the right one?
0
 
LVL 43

Expert Comment

by:ravenpl
Comment Utility
To make it persistent, edit /etc/modprobe.conf and change the alias for eth0 to the module I said.
> alias eth0 tulip
alias eth0 de2104x
then run: depmod -a # should show nothing as well.
If You get some errors(they should be available from 'dmesg' command) - post them here as well, maybe some default parameters have to be changed.
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
I rebooted, and during boot it hung at the network activation state for about a min, unable to ping the ips in its dns configuration, cancelled device intialization-- again, something quite different than before.

The device is still inactive, and I did a  lsmod just now, it lists
tulip      45025     0
de2104x   22357   0

I'm going to try configuring with a fixed ip that is supposed to be reserved for it, just in case
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
you typed while I was too...

before I do what I was going to do:
I will do the alias change and depmod -a #  command
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
it was already changed, I have run depmod -a # and there was no output, so error free?
0
 
LVL 43

Expert Comment

by:ravenpl
Comment Utility
OK, another shot: modprobe de4x5 # then check with 'dmesg' if any net-card was recognized
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
I see the earliest sign of anything in that output pertaining to network/cards

net: registered protocol family 2
ip: routing cache has table of 1024 buckets, 32kbyets
tcp: hash tables configured (established 32768 bind 9362)
initializing ipsec netlink socket
net: registered protocol family 1
net: registered protocol family 17
---
(all that was consecutive in the file)
then a bit later down

de2104x: unknown parameter 'irq'
de2104x: pci ethernet driver 0.7 (mar 17 2004)

then later

eth0: 21041 at 0xe0832f80, 00:80:c8:6e:69:52, IRQ 10
linux tulip driver version 1.1.13 (may 11 2002)

then way down the file

NET: registered protocol family 10
disabled privacy extensions on device c0366c20(lo)
ipv6 over ipv4 tunneling driver

then down lower in the file still

ip_tables: (c)-2000-2002 netfilter core team
ip_tables: (c)-2000-2002 netfilter core team
eth0: enabling interface
eth0: set link 10baseT auto
eth0:    mode 0x7ffc0040, sia 0x10c4, 0xffffef01, 0xffffffff, 0xffff0008
eth0:    set mode 0x7ffc0040, set sia 0xef01, 0xffff,0x8
irq 10: nobody cared! (screaming interrupt?)
irq 10: please try booting with acpi=off and report a bug.
(Then there is this big chunk of stuff indented under that section, with [de2104x] in brackets at the ends of most.)
then
Disabling IRQ #10
eth0: link up, media 10baseT auto
eth0: no ipv6 routers present
eth0: disabling interface


IRQ Problems?
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
indented section appears to be a bunch of memory addresses, with the output

 __report_bad_irq+0x3a/0x77
note_interrult+0x191/0x1b7
do_IRQ+0x19a/0x242

etc..
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
and lsmod comes back the same still - tulip and de2104x   with a big 0
0
 
LVL 43

Expert Comment

by:ravenpl
Comment Utility
OK, seems that there is a bug in the kernel You have.
Try booting with acpi=off parameter. Edit /boot/grub/grub.conf modify first line that look similar to
> kernel /boot/vmlinuz-2.6.9-42.ELsmp ro root=LABEL=/
to
> kernel /boot/vmlinuz-2.6.9-42.ELsmp ro root=LABEL=/ acpi=off
If it will not help(and none of modules from tulip de2104x de4x5 picks the card permanently) You have to upgrade the kernel at least.
up2date kernel # or up2date kernel-smp # if SMP is in use
rpm -qa | grep kernel # to see what kernel related packages You have.
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
modified boot file by adding    acpi=off  to the end of my string there...
rebooted

lsmod  still has only tulip and de2104x entries, oh, wait, no, also has de4x5 at the top of the file, 0 as well.

The errors in the IRQ segment seem to specify the de2104x byname.

I switched to static IP assignment, and the system is making it through that part in the boot up now with an OK after about 10s, and the card is always "active" in the device displays, etc.  But booting with that acpi=off doesn't seem to affect the module loading


I was really hoping not to change the kernal, perhaps I end up throwing one of the other card back in and redoing a lot of the troubleshooting again now?

the rpm -aq .....  command gave me
kernal-2.6.9-5.el
kernal-utils-2.4.13.1.48

I don't understand what the part between "at least" and "rpm" is asking me to try
0
 
LVL 43

Expert Comment

by:ravenpl
Comment Utility
I meant: You don't have to upgrade whole system: only kernel needs to be upgraded.
up2date kernel # command should connect to RH network, download newest available kernel and upgrade
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
so, you're saying that if I issue a particular command, the network card will immediately jump to life, become active, and let me temporarily download a file, so that I can permanently fix the problem :D

After thinking about that for a second after you typed it...  outline for me what to do please in my situation as the alternative, if I cant run a magic command that does everything in one fell swoop.


0
 
LVL 43

Expert Comment

by:ravenpl
Comment Utility
! LOL !
But maybe You have some RH machine with network set up?
Or just fetch http://people.redhat.com/~jbaron/rhel4/RPMS.kernel/kernel-2.6.9-42.23.EL.i686.rpm (beta kernel) and try it.
upgrade with: rpm -Uv kernel-2.6.9-42.23.EL.i686.rpm
0
 
LVL 34

Expert Comment

by:Duncan Roe
Comment Utility
If the card was recognised by a module, ifconfig -a should show it (ifconfig by itself only shows cards that are running).
What error do you get when you try to activate the card with ifconfig manually?
Don't expect the used count in lsmod to go to 1 until you start the card.
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
just got back from a seminar...

duncan_roe : if I run  ifconfig -a
it comes up with eth0 which is the card indeed, lo - which is always came up with before, and sit0 , the sit0 being link encap: ipv6-in-ipv4 yada yada yada


specificially, for the eth0

link encap: ethernet  hwaddr 00:80:c8:6e:69:52
inet addr: <my static assignment> bcast: <xx.xx.xx.255> mask: 255.255.255.0
inet 6 addr: fe80::280:c8ff:fe6e:6942/64 scope:link
UP BROADCAST RUNNING MULTICAST  MTU: 1500  Metric:1
rx packets: 0 errors: 0 dropped: 35717  overruns: 0 frame:0
tx packets: 0 errors: 0 dropped:0 overrruns:0 carrier:0
collisions: 0  txqueuelen:1000
rx bytes:0 (0.0 b)   tx bytes: 0 (0.0b)
interrupt: 10  base address 0x8f80

-------
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
meaning to say, ifconfig (no switches) never came up with anything other than  the   lo  entry before.

0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
checking my boot log now, I see where the network used to fail:

(time)  localhost network : setting network parameters: succeeded
(time)  localhost network: bringing up lookback interface: succeeded
(time)  localhost ifup: RTNETLINK answers: Invalid argument
(time)  localhost network: Bringing up interface eth0: succeeded

Thats new, and an invalid argument sounds 'encouraging' - what am I needing to look at now, configuration wise
0
 
LVL 43

Accepted Solution

by:
ravenpl earned 500 total points
Comment Utility
> (time)  localhost ifup: RTNETLINK answers: Invalid argument
It propably wanted down it first. I guess it's safe to ignore.

What helped, so Your card is now visible?
0
 
LVL 39

Expert Comment

by:noci
Comment Utility
Modules usage count only goes up if the interface is set to UP
using ifconfig ad likewise tools.
(A non-zero count inhibits unloading of modules).
0
 
LVL 34

Expert Comment

by:Duncan Roe
Comment Utility
If it's now RUNNING, I'd expect to see it with just ifconfig. I suspect "dropped: 35717" is not a good sign though. Possibly it's configured with an address that doesn't match the network it's on? Also check the routing tables: type "route" or possibly "/sbin/route". I would investigate the ifup error: look through the scripts in /etc/rc.d/init.d or somewhere similar - find where the "bringing up lookback interface" message is produced and check the commands following. Try the ifup command if you find it.
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
Configured in static mode (and, I very well likely could be missing a switch that needs to be manually added that would have been automatically added in an autoconfiguration, I don't know, this is my first linux experience) the system makes it through the boot up, device is "active" but no network cababilities - can't ping any sites in our local area that my laptop beside it is getting <2ms on thru windows, one being a hardware printerserver...

If I use the netconfig  and check the box for "dhcp" and reboot (or, restart network service) it fails.

boot log this morning, left in dynamic mode last night, is
localhose network: bringing up lookback interface: succeeded
localhost ifup:
localhost ifup: determining ip information for eth0...
localhost ifup: failed.
localuost network: bringing up interface eth0: failed

configured with static ip, boot goes through "ok" but the log has

(time)  localhost network : setting network parameters: succeeded
(time)  localhost network: bringing up lookback interface: succeeded
(time)  localhost ifup: RTNETLINK answers: Invalid argument
(time)  localhost network: Bringing up interface eth0: succeeded

and we're back where we were yesterday at 5pm EST

===============
for my university network, used in windows settings:
university is   aaa.bbb.###.### block
all computers on my floor in this building are in the  aaa.bbb.ccc.### subnet
we have aaa.bbb.ccc.19  on a reserved static list
default gateway is aaa.bbb.ccc.1
subnet mask 255.255.255.0
dhcp server is   aaa.bbb.ppp.11
dns are  aaa.bbb.ppp.11   (yes, same as dhcp)  and aaa.bbb.qqq.10

-----------
if I type  "route" when I have configured for static

destination           gateway                    genmask             flags            metric ref   use  iface
aaa.bbb.ccc.0      *                               255.255.255.0      u                 0           0      0 eth0
169.254.0.0         *                               255.255.0.0         u                   0       0       0  eth0
default               aaa.bbb.ccc.1               0.0.0.0              ug                0        0        0  eth0

---------------
This is where I now need handholding help pretty much at the "Invesitgate xxxxxxx" parts.  Do I need to close this question now because the system has micraculously managed to see the network card and let it be active even when it doesn't work, thus seeming like the initial problem is solved?  I just kept doing and redoing and undoing and redoing things over and over and finally it suddenly worked, and I don't know what the heck did it...  At the very least, you guys are going a long way out here to help, 500points is pretty lame.  






0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
'cause I can type the output of the "route" command, but it may as well be in chinese for what it means to me at this point :)
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
yeeahh - almost:)

I had a flash of understanding about trying the script out (ifup), and saw the ifup eth0  from a command line gives the same RTNETLINK error, then still not knowing anything about what I am looking at in the script, but knowing how to debug (windows programmer) I stuck a bunch of echos in the scripts to trace the execution indeed.

from ifup  to ifup-post  to ifup-routes ..

in the ifup-routes, I now have this

for file in $FILES; do
  if [ -f "$file" ]; then
    if egrep -q 'ADDRESS[0-9]+=' $file ; then
      #new format
      echo $"It gets to here before tossing an error" >&2
      handle_file $file $1
      echo $"It would have just tossed an error now" >&2
    else
      #older format
      while read line ; do
        /sbin/ip route add $line
      done < "$file"
    fi
 fi
done


===========
now to figure out where to go from there
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
Sorry Guys, forgot this was still open

We kinda put the computer on hold for a while, and have been focused on a different suite of tools on another machine - I'm planning on taking the machine home with me during our christmas break and try setting it up on my own, fully controlled network to find at least one working condition that I can have more control over, possibly with some alternate network cards, but until then, we don't have further time to look at it.

Someone propose a closure here - problem wasn't resolved, but all of the methods here would be worth others looking at?
0
 
LVL 5

Expert Comment

by:kyle_in_taiwan
Comment Utility
Eh, if your problem wasn't solved then don't worry about the points.  ;-)
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
GPrentice00,

For clarification purposes.  If your question wasn't answered why did you open a new question to continue the thread when you already had this one open (just curious).  On a question closing note,  please refer to http://www.experts-exchange.com/Community_Support/help.jsp#hs5

Hope this helps.

Cyclops3590
EE Cleanup Volunteer
0
 
LVL 5

Expert Comment

by:kyle_in_taiwan
Comment Utility
whups --

SOrry, i thought this was the other question!

By all means, close this one out and give the points!

K.
0
 
LVL 6

Author Comment

by:GPrentice00
Comment Utility
thats about as close an answer as I have myself for that phase of the problem.

Something happened suddenly -- "What worked?"  dunno either.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
This video discusses moving either the default database or any database to a new volume.
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now