• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 353
  • Last Modified:

ATA and SATA2

Hello,

I have a old 250gb ATA harddisk.. now i have gotten a new hitachi 400gb SATA2 hdd...

I usually boot from the ATA and am running win2k pro, but i just could not format my new sata drive... from win2k pro, i even tried partition magic 8 to do the job (this usually works for me) but no luck, i got all sorts of crappy errors...

so i disconnected the ATA, connected only the SATA2, and loaded winxp pro on it... which did the trick, it formatted the whole disk and installed windows.. I started up the comp and everything works great...

so then i shut down, reconnected the ATA, selected that as the boot disk... and restarted, I came back to windows 2000 perfectly, went into the explorer and tried to access my new sata drive (it shows as E: ) but when i clicked it it tells me:

"The Disk in drive E: is not formatted
Do you want to format it now?"

What the heck is the problem?

I actually bought the hdd and a kit to connect it as a USB hdd... but first this has to work...right?

PLEASE help!

Thanks!
0
brazil2006
Asked:
brazil2006
1 Solution
 
zephyr_hex (Megan)DeveloperCommented:
did the hard drive come with a prep utility?  some new hard drives require you to run a utility before you can use it for storage....
0
 
piiidttCommented:
Have you installed the latest service packs for win2k?
0
 
brazil2006Author Commented:
Hello,

zephyr_hex - > I didnt get anything other than the hdd in its plastic case....

piiidtt  -> Checking it tells me, I'm on update versions SP1; Q823353; Q903235
Going to windows update offers me no updates...

Thanks!
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
PUNKYCommented:
You should have at least service pack 4, see the link below:

http://www.microsoft.com/windows2000/downloads/servicepacks/default.mspx 
0
 
sulfur_basedCommented:
You could also be having a problem with the size of your hard drive.  Win2000 SP1 doesn't support hard drives greater than 137GB.  Also if you have Service Pack 4 then you have to set a registry key too.

Its a bit strange though because your old hard drive is 250gb, but i'm confused as to which drive you reinstalled windows onto.  

Please look at this link anyways.

http://support.microsoft.com/kb/305098

Cheers
0
 
brazil2006Author Commented:
Hi again,
I think i made a mistake in my last post... when i checked Internet Explorer it told me SP1 but when i went to control panel and checked under "System" it says :

Microsoft Windows 2000
5.00.2195
Service Pack 4

So it looks like i have the latest service packs... thats why my 250 gb ATA hdd is working fine.


Now what to do?

Thanks!
0
 
PUNKYCommented:
If your harddrive is SATA2, then you will need jumper to configure first, then you will see it in windows environment.

Regards.
0
 
brazil2006Author Commented:
on my mobo i have 4 connectors to sata...
depending on which of the 4 you pick, it shows in the BIOS as primary,slave, 3rd slave etc
i have tried connecting it as primary and as slave... it shows up in windows explorer as E: but as you click on it...it gives the format question that i wrote on top....
0
 
PUNKYCommented:
Do you have other system to try to hook it this drive as slave and see if it gives same error?
0
 
brazil2006Author Commented:
I have another system... but it does not support sata :(

I think i have a friend who does have a new system.... i'll check with him and let you know..

Thanks!
0
 
Computer101Commented:
PAQed with points refunded (250)

Computer101
EE Admin
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now