Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 333
  • Last Modified:

Connect a wireless PC to a domain

I am looking for a better solution then what we are doing right now. When we setup a computer (like a latop) and it is only wireless, you have to use cached creidentials for someone to log onto the PC i.e. only if the person has logged onto the PC when it was plugged into a wired network, then they can log into it when it is wireless. This is because when you use wireless, the it is not connected till AFTER the person has logged in. Kinda a catch 22. If you have never logged into the PC before it gives you an error saying that it cannot contact the domain controller. My solution that I have used now is to put the laptops on a workgroup, and then have it automatically login to the PC. This works for us, because everything is used in a Terminal Services environment. But, it still bugs me that it works this way and I would like to change it. It would really simplify things. Please help me create a better network! Thanks!
0
Nickon17
Asked:
Nickon17
  • 3
  • 2
  • 2
  • +1
1 Solution
 
redseatechnologiesCommented:
Hi Nickon17,

This will entirely depend on your hardware (and it's related driver).

Some wireless cards will fire up and connect to the wireless network BEFORE the login screen (as mine does, HP NC8230, default drivers), some do not.

If your's does not, then I would be looking to upgrade the drivers and hope that the new version will enable this function!

Hope that helps,

-red
0
 
Nickon17Author Commented:
Does that also work for you if you are using encryption on the network?
We are using Fujitsu laptops with built in wirless cards. I think that they are Intel cards.
0
 
Jay_Jay70Commented:
there is a group policy setting which should set you straight here

Administrative Templates\System\Logon    Always wait for the network at computer startup and logon

its a computer policy and you will need to be wired in initially to have this setting take, but then, once its hit, you wont be able to log on until the wireless connects. This problem arises purely from XP's "wuick boot" feature which basically uses cached credentials, logs on, and then applies policies shortly after.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Nickon17Author Commented:
Hmmm...that sounds like it could work! I will try it and then assign you the points if it works!!
0
 
Jay_Jay70Commented:
good luck with it
0
 
antis0cialCommented:
I am new to the domain environment of networking, though I have had success recently with the following

In my own domain environment all my notebook systems use Intel 3945 WIFI Cards which I use with the current Intel PROset drivers. I end up choosing custom install and installing the pre-logon connect as well as the admin tool. You then use the admin tool to setup a exe with the settings for your domain and apply it to your current machine and every other machine.
0
 
Nickon17Author Commented:
OIC, so that seems to work when you are using the Intel based wireless drivers?  That would make sence.  I heard a rumor around the office that this can be done via GPO, but I haven't seen it proved yet.  If I do find out how, I will make sure to post it here!
0
 
antis0cialCommented:
I am somewhat of a newb to corporate network environments, but I have also achieved this with Dell Wireless Software which I think is Broadcom. So most the major players in wifi cards should have software/drivers to achieve this pre-logon connect. I assume that the configuration file can be deployed via GPO (though I am just starting out in GPO) so dont quote me. I know with the intel one you can make the configuration file only use Microsoft Wifi Zero Configuration. Either way this has been a efficient work around for me at home. Another tip, I find it to work better if you connect via cable initially, if that makes sense.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now