Solved

external IP's resolving instead of internal for VPN clients

Posted on 2006-11-07
6
175 Views
Last Modified: 2010-04-12
I have the same problem at a number of clients and the same problem as others at Experts Exchange which have not got a solution.  VPN is working with simple pptp. I can browse etc.  
NSLOOKUP shows ISP DNS servers before Internal DNS servers for the clients; that looks wrong to me.  
IPconfig /all shows properly for WINS and DNS all showing internal IPs.
DNS works properly within the network for everyone internal.  Exchange is at abc.def.com internally at 192.168.1.1 and our ISP has an identical host name abc.def.com registered for an external address of xxx.yyy.zzz.aaa which also works for VPN connection.  The only time it doesn't work is after a vpn client accesses the local network for exchange and gets blocked because he gets the external ip for the host name.  I tried lmhosts lookup in the VPN networking advanced properties and also unclicking the "use default gateway on remote network" I put static entry's for DNS and WINS which did help for some things but not this.

Help!?
0
Comment
Question by:peterrhughes
  • 2
  • 2
6 Comments
 
LVL 8

Accepted Solution

by:
saw830 earned 500 total points
ID: 17895242
Hi peterrhughes,

I would suggest statically setting the DNS on the clients that roam outside the LAN.  I would set the Primary DNS to the internal, Active Directory DNS server address and set the Secondary DNS to a know external DNS server, like ISP's DNS server.  This will allow the client to always resolve based on the internal DNS server if it can, and only use the external DNS server when it can't reach the internal DNS server.

Hope this helps,
Alan
0
 

Author Comment

by:peterrhughes
ID: 17895306
Good idea, I will try it now.
0
 

Author Comment

by:peterrhughes
ID: 17895342
holy smokes you can't immmmagine how exciting this is.
Award this guy Alan 1000 points for answering my question and one just like it on the featured VPN questions that was sort of abandoned without a correct solution.  It was and internal external DNS question just like mine.

Beauty out to you buddy from Canada!

I didn't think the failover in DNS actually worked that well.
What an eligant answer getting something to fail when not being able to correctly configure something they way we should be able to.

I am happy happy happy.  And the answer came quick to.

Thanks Alan.  
0
 
LVL 8

Expert Comment

by:saw830
ID: 17896118
You are most welcome.  Glad it solved your problem.
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Secure VPN Connection terminated locally by the Client.  Reason 442: Failed to enable Virtual Adapter. If you receive this error on Windows 8 or Windows 8.1 while trying to connect with the Cisco VPN Client then the solution is a simple registry f…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now