Solved

Proofing tools vulnerability korean language wants to install itself

Posted on 2006-11-08
11
495 Views
Last Modified: 2008-03-03
Hi Experts,

We have recently purchased Proofing Tools for our Office 2003 users.

If one of the users presses "Z" in excel just after it's loaded, then office tries to install the Korean language pack.
I have installed this MS patch, though it didn't stop this behaviour.
http://support.microsoft.com/kb/905645
I also ran a full virusscan on the machine. Nothing detected. (McAfee 8.0i Patch 14 DAT 4888).
XP Pro, all updates are installed.

I just spent more than an hour circling around the MS sites to no avail.

Could someone please advise what I can do to block this dodgy behaviour.
Do I need to report this to MS? If so, how?

Cheers




0
Comment
Question by:DennisPost
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 2

Author Comment

by:DennisPost
Comment Utility
Additionally, Outlook and Word both have this as well after the application has just been started and plain text is used.
0
 
LVL 7

Expert Comment

by:killbrad
Comment Utility
For Microsoft Word try the following:
Tools -> Language -> Set Language
Uncheck 'Detect Languages Automatically' box at bottom.
0
 
LVL 7

Expert Comment

by:killbrad
Comment Utility
Systemwide, you can follow this (from the Excel help file):
1.      On the Windows Start menu, point to Control Panel, and then click  Language, and Regional Options.
2.      Click the Regional and Language Options icon, and then click the Languages tab.
3.      In the Supplemental languages support box, Uncheck the two boxes at the bottom.
0
 
LVL 2

Author Comment

by:DennisPost
Comment Utility
Hi Killbrad,

Thanks for the suggestions.
Ijust tried them out.
Systemwide, was already unchecked.
Word, even unchecked, the behaviour remains the same.

Any other idea's?

How can I find out if this is indeed a Windows / Office expliot?

Ad-Aware & Spybot found a lot but didn't resolve this.

0
 
LVL 8

Expert Comment

by:jako
Comment Utility
in addition to the last killbrad suggestion at the same location ("Languages" tab on "Regional and Language Options" dialog) Press "Details" button in a "Text services and input languages" group. "Text services and Input languages" dialog should pop up. Check the lower of the checkmarks ("Turn off advanced text services") on the "Advanced" tab. You lose some of the bells and whistles but chances are you aren't using them anyways. This should cripple the "feature" you've been wrestling with.
_
stay secure
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 12

Expert Comment

by:kneH
Comment Utility
righto... this is something you do not want.
But why not just install the pack and be done with it?
It's not like the Korean language is gonna hurt business is it.

Seems to me that'd be the easiest fix for you.
0
 
LVL 8

Expert Comment

by:jako
Comment Utility
Henk, from the security point of view the services that are unused are posing an unnecessary risk that is easily mitigated by disabling the service.
Prove it to the DennisPost here right now that you are not the cracker who has found a vulnerability in a Korean speller DLL and actively trying to use it.
0
 
LVL 2

Author Comment

by:DennisPost
Comment Utility
Thanks for posting!

kneH, did you visit the link in my original post?
Our Korean neighbours are apparently very clever in producing malicous software.

Jakopriit,
Just tried it. No go.
I even rebooted for good measure. The settings stayed, but didn't stop it.

McAfee now has DAT 4908, so i'll try another scan.
In the meantime, if you guys can think of anything else, don't be shy about it.

Cheers!
0
 
LVL 2

Author Comment

by:DennisPost
Comment Utility
Anyone got any more thoughts on this?
0
 
LVL 7

Accepted Solution

by:
killbrad earned 250 total points
Comment Utility
I would just insert the Office disc, and Add/Remove functionality, and remove the language features altogether.
Other than that, it sounds like a localized problem with your setup.  There doesn't seem to be any similar issues around the 'net.

Good luck.
0
 
LVL 2

Author Comment

by:DennisPost
Comment Utility
Hi Killbrad,

This issue doesn't occur anymore (as far as I can tell).
But since you tought  me a few useful things you get get the points.

Thanks for your input!
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Article by: dandraka
There are several quick shortcuts that can make your life easier in Microsoft Programs.  These simple tips and tricks will your work more productive and you faster at completing your tasks! MS Word (1) Creating Re-usable Scraps You can create s…
Entering a date in Microsoft Access can be tricky. A typo can cause month and day to be shuffled, entering the day only causes an error, as does entering, say, day 31 in June. This article shows how an inputmask supported by code can help the user a…
Learn how to make your own table of contents in Microsoft Word using paragraph styles and the automatic table of contents tool. We'll be using the paragraph styles in Word’s Home toolbar to help you create a table of contents. Type out your initial …
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now