Solved

Apache virtual host is not able to parse php extensions, when websphere module is included in httpd.conf file

Posted on 2006-11-08
3
471 Views
Last Modified: 2013-12-16
Hi experts,
                 I have coldfusion deployed on the websphere
                 
                 I am able to  see the coldfusion pages when the virtual host is at defualt port :80, but not php pages (only code is displayed)

                 PHP is working only when i change the port of virtual host from 80 to 90
                                                            or
                 when i remove websphere modules from httpd.conf  (in above both cases coldfusion is not working)

                 Can anyone please suggest the solution or point me the mistake i have made

Thanks
     
                 
0
Comment
Question by:nexus12345
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 

Expert Comment

by:krynnalex
ID: 17903682
Hi nexus12345,

May I ask a few questions?
1. Am I correct that I guess your PHP module are loaded on Apache?
2. What version of WebSphere Application Server that you are using? better with edition.

According to your testing result, I believe your PHP is require to be running on Apache Engine, for sure, with PHP module configured properly, so I think you better to review your plugin cfg xml and see what kind of URI that it will pass to WAS (make sure PHP is not the type will be forwarded), and review your httpd.conf to see whether your Virtual Hosting plus PHP module are configure correctly in that conf file.

0
 
LVL 41

Expert Comment

by:HonorGod
ID: 17951148
Do you have a VirtualHost directive in your httpd.conf file that identifies how to get to you php module?
0
 
LVL 5

Accepted Solution

by:
Waswiz earned 500 total points
ID: 18306920
Are the PHP and coldfusion pages under same context root ?
Then you may have to edit the plugin-config.xml to remove the .php extensions from flowing to WAS.

Or you may disable the fileServing servlet on Websphere thus forcing these php tp run on Apache. You need to edit the ibm-web-ext.xmi and modify the "FileServing Enabled" to false.
0

Featured Post

Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction In this tutorial, I'll explain how to create an animated progress meter in a wireframe prototype developed using Axure RP 7.0 - a leading prototyping tool for designing web sites and software. (For more information about Axure and gett…
Introduction Knockoutjs (Knockout) is a JavaScript framework (Model View ViewModel or MVVM framework).   The main ideology behind Knockout is to control from JavaScript how a page looks whilst creating an engaging user experience in the least …
The purpose of this video is to demonstrate how to set up an RSS Feed on a WordPress Website. This will be demonstrated using a Windows 8 PC. Feedburner will be used for this demonstration. Go to your WordPress login page. This will look like the…
The viewer will learn how to create and use a small PHP class to apply a watermark to an image. This video shows the viewer the setup for the PHP watermark as well as important coding language. Continue to Part 2 to learn the core code used in creat…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question